Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: KDE 4.5.1

  1. #1
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default KDE 4.5.1

    Just updated to KDE 4.5.1, and im having a hard time getting the tray icons to work.

    For instance, i cant get the Pidgin tray icon to show.
    I cant get Qinternet to show either.


    Thanks

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,489

    Default Re: KDE 4.5.1

    Hi,

    I have seen something similar on a cross-install between updates. Suggest you look at the repository file versions and make sure you upgrade and downgrade to the current standard.

    Note: On most files the latest file versions have a lower # than the old ones!!!! If you are using Yast and the version is showing RED or BLUE update it.

  3. #3
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: KDE 4.5.1

    Ok, will do so when repositories are working again

  4. #4
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: KDE 4.5.1

    Ok, so i checked and yes. I have all 4.5.1 packages.

    Its REALLY annoying !!

  5. #5
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: KDE 4.5.1

    By the way, im using this KDE repository:

    Index of /repositories/KDE:/Release:/45/openSUSE_11.3

  6. #6
    Join Date
    Aug 2010
    Location
    USA
    Posts
    87

    Default Re: KDE 4.5.1

    I've had this trouble with a few apps Scribus from a user repos and Blueman for instance. Blueman was a little more upstream issue but scribus was simple to fix just added the scribus.desktop to /usr/share/applications

    Seems like mostly Gnome based apps or where the packager was a Gnome user.
    | openSUSE 12.2 Milestone4 32bit | KDE 4.8.3
    | AMD Athlon(tm) XP 3000+ | MSI K7N2 Delta-L | 3GB Black Diamond DDR
    | GeForce 6200@433Mhz 512MB | NVIDIA-Linux-x86-295.49

  7. #7
    Join Date
    Oct 2008
    Location
    Santiago, Chile
    Posts
    648

    Default Re: KDE 4.5.1

    Well, Qinternet comes from OSS repository.

  8. #8

    Default Re: KDE 4.5.1

    I use 4.5.1 on 11.3. I have the same problem with tray icons. If I just boot up, I get about half of them. The other apps are running, but no tray icon.

    This is where it gets interesting. I found that if I killed one of the apps in the tray, then the tray would expand to accommodate all icons. I couldn't find a fix. Some research showed that the tray was redesigned to get messaging from dbus (or something like that). I guess it just doesn't work yet.

    As a work around, I made a script for Autostart with the command:

    Code:
    #!/bin/bash
    /home/john/bin/delay 15 /home/john/bin/systemtrayfix.sh
    where delay is

    Code:
    #!/bin/sh
    sleep $1
    shift
    exec $@
    and systemtrayfix.sh is

    Code:
    killall kupdateapplet
    This works for me. "john" is my user name, so you would need to adjust the pat appropriately. It does mean that I kill the update applet, but I don't use it anyway.

  9. #9
    Join Date
    Sep 2008
    Location
    Earl Shilton UK
    Posts
    298

    Default Re: KDE 4.5.1

    Finally, someone has found a use for the update applet
    Happily using Linux since 1998
    Share & Enjoy

  10. #10

    Default Re: KDE 4.5.1

    Quote Originally Posted by weighty_foe View Post
    Finally, someone has found a use for the update applet
    Lol. Yup. Thanks to the devs.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •