Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Startverzögerung wegen NFS Client

  1. #1

    Question Startverzögerung wegen NFS Client

    Hallo,

    ich betreibe in meinem Heimnetzwerk eine Netzwerkplatte als NFS Server. Ich greife mit 3 openSUSE Rechnern drauf zu. 1 x LAN openSUSE 11.2 und 2 x per WLAN openSUSE 11.3 . Die beiden Laptops mit openSUSE 11.3 (WLAN) machen beim Starten eine lange Pause ( ca. 30 - 60 Sek. ) bei dem Punkt:

    starting NFS clientservice: sm-notify idmapd

    Der Rechner der per LAN dranhängt macht das nicht. Auch die beiden Laptops machen das erst seit openSUSE 11.3. Vorher ging das ohne Verzögerung über die Bühne.
    Hat jemand einen Tipp für mich, welchen Schalter ich umlegen muss, um diese Verzögerung zu verhindern.

    Gruß tuxilla

  2. #2
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: Startverzögerung wegen NFS Client

    Hallo zusammen,

    stell bitte /var/log/boot.msg hier rein. Bitte lösche vorher alle Zeilen bis einschließlich "Kernel log daemon terminating."

    [edit]Ganz vergessen: Bitte auch /etc/fstab[/edit]

    Liebe Grüße

    Erik

  3. #3

    Default AW: Startverzögerung wegen NFS Client

    Hallo,

    das verstehe ich jetzt nicht. (Hoffentlich sollte es kein Witz sein )
    Die /var/log/boot.msg einzustellen wäre kein Problem. Aber warum soll ich alle Zeilen bis einschließlich "Kernel log daemon terminating" löschen ??? Das ist die letzte Zeile in dieser Datei ?


    hier meine /etc/fstab

    /dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJF0P809467-part4 swap swap defaults 0 0
    /dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJF0P809467-part1 / ext4 acl,user_xattr 1 1
    /dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJF0P809467-part3 /daten ext4 acl,user_xattr 1 2
    /dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJF0P809467-part2 /home ext4 acl,user_xattr 1 2
    /dev/disk/by-id/ata-SAMSUNG_HM250JI_S15YJF0P809474-part1 /windows/C ntfs-3g users,locale=de_DE.UTF-8 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    192.168.2.11:/mnt/ide4/public /home/tuxilla/Netzwerkspeicher nfs defaults 0 0

    Gruß tuxilla

  4. #4
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: AW: Startverzögerung wegen NFS Client

    Hallo zusammen,

    Quote Originally Posted by tuxilla View Post
    Hallo,

    das verstehe ich jetzt nicht. (Hoffentlich sollte es kein Witz sein )
    Die /var/log/boot.msg einzustellen wäre kein Problem. Aber warum soll ich alle Zeilen bis einschließlich "Kernel log daemon terminating" löschen ??? Das ist die letzte Zeile in dieser Datei ?
    Ehrlich? Normalerweise kommen da noch so 150 bis 200 Zeilen. Der kernel log daemon ist nur für die ganze Hardwareinitialisierung zuständig. Das interessiert uns aber nicht wirklich, da der Fehler ja erst danach auftritt. Deshalb solltest Du das löschen. Danach kommt normalerweise das, was der syslog daemon so ins boot log schreibt. Bei mir sieht das so aus:

    Code:
    <4>fuse init (API version 7.9)
    Kernel logging (ksyslog) stopped.
    Kernel log daemon terminating.
    
    Boot logging started on /dev/tty1(/dev/console) at Mon Jul  5 18:22:02 2010
    Und danach kommen noch ca. 150 Zeilen.

    Quote Originally Posted by tuxilla View Post


    hier meine /etc/fstab

    192.168.2.11:/mnt/ide4/public /home/tuxilla/Netzwerkspeicher nfs defaults 0 0
    Auf jeden Fall würde ich noch die Option "_netdev" für ein Netzwerklaufwerk setzen.

    Liebe Grüße

    Erik

  5. #5

    Default AW: Re: AW: Startverzögerung wegen NFS Client

    Hallo

    kein Scherz. Die /var/log/boot.msg endet bei mir mit diesen Zeilen.

    Code:
    <6>[    9.805201] fuse init (API version 7.13)
    Kernel logging (ksyslog) stopped.
    Kernel log daemon terminating.
    Ist eventuell in einem anderen Log-File die Information, die du suchst ?


    Die Option _netdev in der fstab werde ich probieren. Muss dafür das "defaults" weg ?

    Gruß Tuxilla

  6. #6
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: Startverzögerung wegen NFS Client

    Quote Originally Posted by tuxilla View Post

    kein Scherz. Die /var/log/boot.msg endet bei mir mit diesen Zeilen.

    Code:
    <6>[    9.805201] fuse init (API version 7.13)
    Kernel logging (ksyslog) stopped.
    Kernel log daemon terminating.
    Ist eventuell in einem anderen Log-File die Information, die du suchst ?
    Das ist ja echt gediegen. Die Information, was beim Booten passiert, sollte in boot.msg sein. Läuft denn der syslog daemon? Ehrlich, das ist das erste Mal, dass ich sowas höre.

    Quote Originally Posted by tuxilla View Post
    Die Option _netdev in der fstab werde ich probieren. Muss dafür das "defaults" weg ?
    So wie ich das Manual verstehe, müsste das kombinierbar sein. Ansonsten, wenn es nicht klappt, die defaults ausschreiben.

    Liebe Grüße

    Erik

  7. #7

    Default AW: Re: Startverzögerung wegen NFS Client

    Hallo,

    und nun der Hammer !
    Ich habe ja eingangs erwähnt, dass ich mehrere openSUSE Rechner bei mir habe. Nun habe ich doch gleich mal bei den anderen die /var/log/boot.msg angesehen.
    Bei meinem Netbook ( ebenfalls openSUSE 11.3 32bit ) und bei meinem Desktop-PC ( openSUSE 11.2 32bit ) ist bei beiden die boot.msg genauso bei der gleichen Zeile beendet.
    Kein Quatsch ! Ich kann sie gerne mal posten oder auch ganz senden.

    Läuft denn der syslog daemon?
    Habe ich kontrolliert. Der läuft !!

    Jetzt werde ich aber langsam unruhig . Stimmt da etwas bei meinem System nicht oder schaue ich nur an der verkehrten Stelle ??? Aber so blöd kann man doch gar nicht sein

    Hast du noch eine Idee?

    Gruß Tuxilla

  8. #8
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: AW: Re: Startverzögerung wegen NFS Client

    Hallo zusammen,

    Quote Originally Posted by tuxilla View Post
    Jetzt werde ich aber langsam unruhig . Stimmt da etwas bei meinem System nicht oder schaue ich nur an der verkehrten Stelle ??? Aber so blöd kann man doch gar nicht sein
    Nee, der Blöde bin ich. Ich habe jetzt nachgesehen. Bei 11.1 ist es so, wie gewohnt. Bei 11.3 bricht das Log auch an der Stelle ab. Ich kläre das und melde mich dann wieder. Hat denn das _netdev was geändert?

    Liebe Grüße

    Erik

  9. #9

    Default AW: Re: AW: Re: Startverzögerung wegen NFS Client

    Hallo,

    Quote Originally Posted by erikro View Post
    Hat denn das _netdev was geändert?
    Nein, das hat leider nichts diesbezüglich gebracht.

    Quote Originally Posted by erikro View Post
    Ich kläre das und melde mich dann wieder.
    Danke, ich versuche es inzwischen auch noch weiter.

    Gruß Tuxilla

  10. #10
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: AW: Re: AW: Re: Startverzögerung wegen NFS Client

    Hallo zusammen,

    guck mal hier:

    boot.msg - Wo sind die Einträge über das Starten der Daemons geblieben?

    und aktiviere doch bitte mal das Loggen des Bootvorgangs.

    Liebe Grüße

    Erik

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •