Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Skype: Aborted

  1. #1
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Unhappy Skype: Aborted

    I have installed skype some time ago and was using it for some while and it was working that time, today when i start it, it throws an error 'Aborted'.
    Yup, that's from terminal. I am on 11.3 64bit KDE4.5.

    Any helping hand will be appreciated.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Skype: Aborted

    One of the 32 bit libraries wanted for Skype may have got updated/replaced.
    Is it saying anything other than "Aborted"? Did this start happening after installing KDE4.5?
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Skype: Aborted

    Nope, nothing more than 'Aborted'.
    I installed KDE4.5 from the day i installed 11.3, so i am pretty sure it was working in KDE4.5 before.
    But yes maybe that is possible if there are some 32bit libraries upgraded or removed. Can't say anything about that.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  4. #4
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Skype: Aborted

    Hmmmm.... That is going to be bit difficult.
    Anyway, see if you get any clues from the shared library dependency.
    Code:
    ldd /usr/bin/skype
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  5. #5
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Skype: Aborted

    Output for shared lib:
    arif@linux:~> ldd /usr/bin/skype
    linux-gate.so.1 => (0xffffe000)
    libasound.so.2 => /usr/lib/libasound.so.2 (0xf7600000)
    libXv.so.1 => /usr/lib/libXv.so.1 (0xf75fa000)
    libXss.so.1 => /usr/lib/libXss.so.1 (0xf75f6000)
    libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0xf757e000)
    libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xf7532000)
    libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xf74ef000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xf6a69000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0xf6a3e000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0xf6a35000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0xf6a1a000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0xf6a09000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf69fe000)
    libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf69f5000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf69ef000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf69e3000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf69de000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf6957000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf6921000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xf690f000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0xf67d4000)
    libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xf66b4000)
    libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xf6437000)
    libz.so.1 => /lib/libz.so.1 (0xf6423000)
    libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xf641d000)
    librt.so.1 => /lib/librt.so.1 (0xf6413000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf632d000)
    libdl.so.2 => /lib/libdl.so.2 (0xf6328000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xf630c000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf621c000)
    libm.so.6 => /lib/libm.so.6 (0xf61f2000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf61d4000)
    libc.so.6 => /lib/libc.so.6 (0xf6069000)
    libpng14.so.14 => /usr/lib/libpng14.so.14 (0xf603c000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf5ff3000)
    libEGL.so.1 => /usr/lib/libEGL.so.1 (0xf5fe3000)
    libuuid.so.1 => /lib/libuuid.so.1 (0xf5fdd000)
    libexpat.so.1 => /lib/libexpat.so.1 (0xf5fb3000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf5f92000)
    /lib/ld-linux.so.2 (0xf7716000)
    libpcre.so.0 => /lib/libpcre.so.0 (0xf5f63000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xf5f5f000)
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  6. #6

    Default Re: Skype: Aborted

    I'm experiencing a similar problem on my dad's pc. Skype was working fine until after we ran an update I think (can't be a 100% sure). Now skype won't start and just closes with Aborted when starting it from the console. I tried removing the ~./skype folder to force it to create a new profile folder but that didn't help. It still aborts the start-up. I then created a new KDE user account and skype doesn't start with the new account either so I believe it's nothing to do with a user setting but seems to be a system problem.

    This is a AMD64 PC running the latest updates of kde4.4.4 from the standard repos on oS11.3.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  7. #7

    Default Re: Skype: Aborted

    Well just a small update. Yesterday evening I tried to roll back all packages to those on the install DVD. I inserted the DVD and disabled all repos apart from the DVD then did a switch all packages to this repo sorted a few dependencies and did the downgrade. I also tried to remove all packages including Skype and the additional 32 bit libraries that were not part of the original install. Then reinstalled Skype but it still didn't start.

    The only other option I can think of now is to do a completely clean install then install Skype before any updates or other packages and take it from there. It's very puzzling as Skype worked fine on this PC with 11.3 and KDE4.4.4. I've found a few other posts of other users experiencing the same problem when googling but no real fixes.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  8. #8
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Skype: Aborted

    I checked the list of libs with mine and couldn't find any differences. I have no problems with Skype.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,663
    Blog Entries
    14

    Default Re: Skype: Aborted

    Skype works here, on my laptop.

    Try this:
    Code:
    mv ~/.Skype ~/.Skype.old
    skype
    If that works, reenter your login data and preferences. Your contacts are at Skype's.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: Skype: Aborted

    Quote Originally Posted by Knurpht View Post
    Skype works here, on my laptop.

    Try this:
    Code:
    mv ~/.Skype ~/.Skype.old
    skype
    If that works, reenter your login data and preferences. Your contacts are at Skype's.
    That doesn't work for me. Nor did creating a completely new user in oS and trying under the new account. I'm sort of resigned to reinstalling oS11.3.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •