Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: mysql Problems

  1. #1
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default mysql Problems

    I'm having proglems with mysql and I think that it has to do with mysqld. Here is the error message when I try to start it......

    etech97@neptune:~> /usr/sbin/mysqld start
    100919 5:56:24 [Warning] Can't create test file /var/lib/mysql/neptune.lower-test
    100919 5:56:24 [Warning] Can't create test file /var/lib/mysql/neptune.lower-test
    /usr/sbin/mysqld: Can't change dir to '/var/lib/mysql/' (Errcode: 13)
    100919 5:56:24 [ERROR] Aborting

    100919 5:56:24 [Note] /usr/sbin/mysqld: Shutdown complete
    Any help would be greatly appreciated

    Cheers!
    etech97

  2. #2
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: mysql Problems

    This is another error message that I'm getting....

    etech97@neptune:~> mysql -p
    Enter password:
    ERROR 1045 (28000): Access denied for user 'etech97'@'localhost' (using password: YES)
    etech97@neptune:~> mysql
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 2
    Server version: 5.1.46-log SUSE MySQL RPM

    Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL v2 license

    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

  3. #3
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: mysql Problems

    I have created the database called civicrm but I cannot connect to it or grant all permissions for any user, I have used Google and there is an unbelievable amount of information, and different syntaxes, and I just don't know what to use...I have tried many......I use mysql version 5.1.30


    Cheers!

  4. #4

    Default Re: mysql Problems

    echo "GRANT ALL PRIVILEGES ON civicrm.* TO etech97@localhost ;" | mysql

  5. #5
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: mysql Problems

    The following details catched my attention:

    etech97@neptune:~> /usr/sbin/mysqld start
    Use (as user root):

    Code:
    # rcmysql start
    to start the mysql daemon or (even better) start/stop it with yast.

    100919 5:56:24 [Warning] Can't create test file /var/lib/mysql/neptune.lower-test
    Do not use the period (.) in database names. You could do it (if you absolutely want) as of MySQL 5.1.6 but you are looking for trouble. Please read the documentation about "identifiers":

    Code:
    etech97@neptune:~> pinfo mysql
    Check ownership and permissions for /var/lib/mysql. It should be:

    Code:
    drwxr-xr-x 35 mysql      mysql       4096 Sep 19 15:14 mysql
    and database directories below /var/lib/mysql should be similar to this:

    Code:
    drwx------ 2 mysql mysql     12288 Jun 14 15:09 test
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  6. #6
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: mysql Problems

    Quote Originally Posted by please_try_again View Post
    echo "GRANT ALL PRIVILEGES ON civicrm.* TO etech97@localhost ;" | mysql
    This is what I get with your command....

    etech97@neptune:~> echo "GRANT ALL PRIVILEGES ON civicrm.* TO etech97@localhost ;" | mysql
    ERROR 1044 (42000) at line 1: Access denied for user 'etech97'@'localhost' to database 'civicrm'
    etech97@neptune:~>
    Thank you for your help

  7. #7
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: mysql Problems

    Quote Originally Posted by vodoo View Post
    The following details catched my attention:



    Use (as user root):

    Code:
    # rcmysql start
    to start the mysql daemon or (even better) start/stop it with yast.



    Do not use the period (.) in database names. You could do it (if you absolutely want) as of MySQL 5.1.6 but you are looking for trouble. Please read the documentation about "identifiers":

    Code:
    etech97@neptune:~> pinfo mysql
    Check ownership and permissions for /var/lib/mysql. It should be:

    Code:
    drwxr-xr-x 35 mysql      mysql       4096 Sep 19 15:14 mysql
    and database directories below /var/lib/mysql should be similar to this:

    Code:
    drwx------ 2 mysql mysql     12288 Jun 14 15:09 test
    The permissions look like they are setup correctly But if you could give me the command line command to check....it would be greatly appreciated

    Thanks!
    Cheers!!!

  8. #8
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: mysql Problems

    What I need to do is create a database for civcrm and grant all privileges for a user; that will be used by the application. The user must have all permissions to the database!

    In the process of using Google...I think that I screwed up mysql !!!!

    So, Thank you to everyone that is helping me out....by the way my other mysql databases are working

    Cheers!

  9. #9
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: mysql Problems

    The permissions look like they are setup correctly But if you could give me the command line command to check..
    Check permissions?

    Code:
    ls -l /var/lib/
    ls -l /var/lib/mysql
    From what I have seen I guess that mysql does not let you in, so you can not grant any further permissions for users. How did you install mysql? I hope you did it with yast. Then a user named 'root' will have initial access with no password. It may be confusing, but this is not the super user named root which you know from the command line, it's just the same name. Try the following (as user etech97):

    Code:
    mysql -h localhost -u root mysql
    When asked for a password just type enter. You should get a prompt like this:

    Code:
    mysql>
    Now type this at the mysql> prompt and hit <enter>

    Code:
    mysql> GRANT ALL ON *.* TO 'etech97'@'localhost' IDENTIFIED BY 'yourpassword' WITH GRANT OPTION;
    When all is well you have just created a user account with GRANT power. Exit with '\q' and login again like this:

    mysql -h localhost -u etech97 -pyourpassword

    When this works, all is well. Read the manual and set a password for mysql user root. Otherwise you are in trouble. To regain control with a lost password you can stop mysql and start it again with the option --skip-grant-tables. Then manually set a new password for mysql user root. The manual describes the procedure.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  10. #10
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: mysql Problems

    From what I have seen I guess that mysql does not let you in, so you can not grant any further permissions for users. How did you install mysql? I hope you did it with yast. Then a user named 'root' will have initial access with no password. It may be confusing, but this is not the super user named root which you know from the command line, it's just the same name. Try the following (as user etech97):

    Code:
    mysql -h localhost -u root mysql
    When asked for a password just type enter. You should get a prompt like this:

    Code:
    mysql>
    This is what I get when I enter this command either with root or etech97
    etech97@neptune:~> mysql -h localhost -u etech97 mysql
    ERROR 1044 (42000): Access denied for user 'etech97'@'localhost' to database 'mysql'
    etech97@neptune:~>
    Thank you for your help!!!
    Cheers!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •