Results 1 to 4 of 4

Thread: Yast Software Managment - Froze during update

  1. #1

    Default Yast Software Managment - Froze during update

    New to linux, and was updating software. I had clicked the link to change system packages to the ones in the packman repo.

    After hitting accept everything went well until it was at least 90% done, and then it froze, mouse stopped moving.

    So I waited a while, and after nothing happened I rebooted my computer. Now the first time I tried to go back into the software update section it gave me an error:

    "cannot read the list of installed packages"

    and kicked me out.

    After trying to go in again this time it worked, however it won't install anything anymore and just gives me the error that whatever I want to install failed, for example trying to install VLC and dependancies gives me:

    Subprocess failed. Error: RPM failed: rpmdb: PANIC: Invalid argument
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db3 error(-30977) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run database recovery

    how do I recover the installed packages database, or rebuild it?


  2. #2

    Default Re: Yast Software Managment - Froze during update

    well i won't hold my breath, but it appears that running

    rpm --rebuilddb

    has fixed my problem.

    Might seem silly but just posting this thread, and analyzing the error helped me figure out what to search for in order to fix the problem. cause "cannot read the list of installed packages" gave me sweet f all.

    so on the bright side the next person who seaches for that string should find this thread.

  3. #3
    Join Date
    Jun 2008
    The English Lake District. UK - GMT/BST
    Blog Entries

    Default Re: Yast Software Managment - Froze during update

    Well done sorting it out
    Guess you read this:
    Multi-media and Restricted Format Installation Guide
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Yast Software Managment - Froze during update

    I did indeed.

    However, fixing my update database didn't really solve the root of my problem. For whatever reason my intel 945GC doesn't seem to be supported; or at least that's what I think is causing my pc to lock up on installs, and why my VLC media player plays everything with a blue hue, and not to mention when connecting to internet sites it takes at least 10 seconds to reply before it starts feeding across information as normal.

    So basically my graphics, network and storage controller are all boinked. Kinda had enough of it and am installing windows 7 as we speak.

    Had kinda hoped to use this little 1.6Ghz intel atom as a test machine for some server development I'm working on, but I'm just not prepared to throw away another night f'ing around with it.

    I'll go go FreeBSD and a different PC when I get the chance, and just use this for my file server and music player as I intended.

    But I learned a lot in my efforts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts