Results 1 to 6 of 6

Thread: Gnome desktop effects stopped working on Nvidia in OpenSUSE 11.3

  1. #1

    Default Gnome desktop effects stopped working on Nvidia in OpenSUSE 11.3

    Hi,

    I have a notebook with an Nvidia Quadro NVS 130M. Desktop effects were
    working on OpenSUSE 11.2. Last week I upgraded to OpenSUSE 11.3, and
    now desktop effects do not work. When I try to enable them, a box pops
    up that says something like "desktop effects are not supported on your
    hardware / configuration. Do you want to try anyway?". If I "try anyway",
    it does NOT work - I get a jumbled screen that is mostly black, but sometimes
    objects appear when I mouse over them.

    I have the proprietary nvidia drivers (version 256.53) loaded and working
    (nvidia kernel module loaded, Nvidia splash screen on X server startup,
    correct lines found in Xorg.0.log).

    The Composite option is enabled:

    (**) Extension "Composite" is enabled
    (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    (II) NVIDIA(0): enabled

    Never-the-less, I still cannot enable the desktop effects.

    Any suggestions as to what I am missing?

    Thanks in advance,

    Eric

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Gnome desktop effects stopped working on Nvidia in OpenSUSE 11.3

    Did you try re-installing the nvidia driver anyway
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,657

    Default Re: Gnome desktop effects stopped working on Nvidia in OpenSUSE 11.3

    Since you upgraded maybe there is something in you user config files that 11.3 does not like. Try creating another user account and see if the problem is there also. It could be you need to upgrade compiz also since you are using Gnome.

  4. #4

    Default Re: Gnome desktop effects stopped working on Nvidia in OpenSUSE 11.3

    Yes, I did try re-installing once. Didn't change anything.

    --
    Eric

  5. #5

    Default Re: Gnome desktop effects stopped working on Nvidia in OpenSUSE 11.3

    I also tried creating a new user account - that user cannot enable desktop effects either.
    I assume that compiz was upgraded together with the OS:

    python-compizconfig-0.8.4-4.1.i586
    compiz-gnome-0.8.6-3.4.i586
    compizconfig-settings-manager-0.8.4-4.1.noarch
    compiz-0.8.6-3.4.i586
    compiz-manager-0.6.0-11.1.noarch
    compiz-branding-openSUSE-0.8.6-3.4.i586
    compiz-plugins-main-0.8.6-1.15.i586
    libcompizconfig-0.8.4-3.1.i586

    --
    Eric

  6. #6

    Default Re: Gnome desktop effects stopped working on Nvidia in OpenSUSE 11.3 [SOLVED]

    SOLVED:

    There were two problems:

    The first problem caused the "desktop effects are not supported on your
    hardware / configuration. Do you want to try anyway?" message:

    Compiz-manager (/usr/bin/compiz-manager) does not recognize drivers loaded from
    /usr/lib/xorg/modules/updates/drivers, which is where the nvidia_drv module is placed.

    I patched compiz-manager as follows:

    --- compiz-manager.dist 2010-07-05 13:27:50.000000000 +0200
    +++ compiz-manager 2010-09-20 12:05:30.000000000 +0200
    @@ -53,7 +53,8 @@
    NVIDIA_SETTINGS="nvidia-settings" # Assume it's in the path by default

    # For detecting what driver is in use, the + is for one or more /'s
    -XORG_DRIVER_PATH="/usr/${LIB}/+xorg/+modules/+drivers/+"
    +#XORG_DRIVER_PATH="/usr/${LIB}/+xorg/+modules/+drivers/+"
    +XORG_DRIVER_PATH="/usr/${LIB}/+xorg/+modules(/+updates)?/+drivers/+"
    FALLBACKWM="xterm"
    if [ x"$KDE_FULL_SESSION" = x"true" ]; then
    FALLBACKWM="${KWIN}";

    The second problem that caused the jumbled mostly-black screen
    when enabling desktop effects turned out to be having an LD_LIBRARY_PATH
    environment variable set. I never did figure out exactly what the problem
    was, what fixed it for me was unsetting the LD_LIBRARY_PATH variable.

    Regards,

    Eric Negaard

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •