Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Downgrade from KDE 4.5?

  1. #1

    Default Downgrade from KDE 4.5?

    Hi all.
    I'm using openSUSE 11.3 and yesterday I upgraded to KDE 4.5 from the KDE 4.5 stable repo. But after upgrading I faced some freeze/lock-up glitches which weren't there before. For example whenever I change the color scheme or style and press apply, the screen freezes although the mouse still moves around. I have to forcefully shut down to recover.
    So, I am thinking of downgrading to KDE 4.4. How do I go about doing that?

    Here are the repos I'm currently using:

    Code:
    #  | Alias                                 | Name                                    | Enabled | Refresh
    ---+---------------------------------------+-----------------------------------------+---------+--------
    1  | KDE:45                                | KDE:45                                  | Yes     | Yes    
    2  | Libdvdcss repository                  | Libdvdcss repository                    | Yes     | Yes    
    3  | Updates for openSUSE 11.3 11.3-1.82   | Updates for openSUSE 11.3 11.3-1.82     | Yes     | Yes    
    4  | X11:lxde                              | X11:lxde                                | Yes     | Yes    
    5  | X11:xfce                              | X11:xfce                                | Yes     | Yes    
    6  | X11:xfce:nilda                        | X11:xfce:nilda                          | Yes     | Yes    
    7  | download.opensuse.org-Apps            | openSUSE BuildService - GNOME:Apps      | Yes     | Yes    
    8  | download.opensuse.org-Banshee         | openSUSE BuildService - Banshee         | Yes     | Yes    
    9  | download.opensuse.org-Extra           | openSUSE BuildService - KDE:Extra       | Yes     | Yes    
    10 | download.opensuse.org-UpdatedApps     | openSUSE BuildService - KDE:UpdatedApps | Yes     | Yes    
    11 | download.opensuse.org-database        | openSUSE BuildService - Database        | Yes     | Yes    
    12 | download.opensuse.org-php             | openSUSE BuildService - PHP             | Yes     | Yes    
    13 | download.opensuse.org-standard        | Main Repository (Contrib)               | Yes     | Yes    
    14 | google-chrome                         | google-chrome                           | Yes     | Yes    
    15 | openSUSE-11.3 11.3-1.82               | openSUSE-11.3 11.3-1.82                 | Yes     | No     
    16 | openSUSE-11.3-NonOSS-Add-on_11.3-1.80 | openSUSE-11.3-NonOSS-Add-on 11.3-1.80   | Yes     | No     
    17 | openSUSE_11.3:_Elementary_Theme       | openSUSE_11.3: Elementary Theme         | No      | Yes    
    18 | packman.inode.at-suse                 | Packman Repository                      | Yes     | Yes    
    19 | repo-debug                            | openSUSE-11.3-Debug                     | No      | Yes    
    20 | repo-non-oss                          | openSUSE-11.3-Non-Oss                   | Yes     | Yes    
    21 | repo-oss                              | openSUSE-11.3-Oss                       | Yes     | Yes    
    22 | repo-source                           | openSUSE-11.3-Source                    | No      | Yes    
    23 | subpixel repository                   | subpixel repository                     | Yes     | Yes
    Thanks.

  2. #2
    Join Date
    Nov 2009
    Location
    Mnchen
    Posts
    295

    Default AW: Downgrade from KDE 4.5?

    Inactivate all repositories you do not need, activate only repo-oss and repo non-oss and then
    Code:
    zypper dup
    .
    This will downgrade your packages to the available versions. Please activate only the repos i told you. Otherwise it can destroy your system.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: AW: Downgrade from KDE 4.5?

    A less aggressive approach would be
    Remove the 4.5 repo/s you added

    add this one
    Index of /repositories/KDE:/Distro:/Stable/openSUSE_11.3

    then do the switch on it
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Nov 2009
    Location
    Mnchen
    Posts
    295

    Default AW: Re: AW: Downgrade from KDE 4.5?

    @caf4926 Do you think my method is aggressive? This doesnt reinstall all packets only downgrade the KDE packets.

  5. #5

    Default Re: AW: Downgrade from KDE 4.5?

    Thanks I removed the 4.5 repo and now I'm switching the packages.....hopefully everything will be okay(fingers crossed)!!

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: AW: Re: AW: Downgrade from KDE 4.5?

    Quote Originally Posted by Pilgervater View Post
    @caf4926 Do you think my method is aggressive? This doesnt reinstall all packets only downgrade the KDE packets.
    zypper dup affects the whole system. I'm not saying you are wrong, far from it. But knowing there are issues out there on various fronts, including a kernel update, just working on the kde repo is safer IMO
    dup will also potentially break some multi-media away from packman
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: AW: Re: AW: Downgrade from KDE 4.5?

    So I disabled the KDE45 repo and switched the packages to the KDE:Stable repo during which yast gave me the following error:

    Code:
    #### YaST2 conflicts list - generated 2010-09-15 16:57:51 ####
    
    NetworkManager-kde4-libs-lang-0.9.svn1161677-2.1.noarch requires NetworkManager-kde4-libs = 0.9.svn1161677, but this requirement cannot be provided
    
        [ ] deinstallation of NetworkManager-kde4-libs-lang-0.9.svn1161677-2.1.noarch
    
        [ ] break NetworkManager-kde4-libs-lang by ignoring some of its dependencies
    
        [ ] Following actions will be done:
    keep obsolete NetworkManager-kde4-libs-0.9.svn1161677-2.1.i586
    keep obsolete kdelibs4-4.5.1-3.3.i586
    keep obsolete libkde4-4.5.1-3.3.i586
    keep obsolete oxygen-icon-theme-4.5.1-2.1.noarch
    keep obsolete kdelibs4-core-4.5.1-3.3.i586
    keep obsolete shared-desktop-ontologies-0.5-2.1.noarch
    keep obsolete soprano-2.5.0-2.1.i586
    keep obsolete kde4-filesystem-4.5.1-3.1.i586
    keep obsolete libkdecore4-4.5.1-3.3.i586
    keep obsolete libsoprano4-2.5.0-2.1.i586
    
    
    
    #### YaST2 conflicts list END ###

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: AW: Re: AW: Downgrade from KDE 4.5?

    Looks like this

    [ ] deinstallation of NetworkManager-kde4-libs-lang-0.9.svn1161677-2.1.noarch
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: AW: Re: AW: Downgrade from KDE 4.5?

    Okay, I'll try that out and report back.

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: AW: Re: AW: Downgrade from KDE 4.5?

    No one said this so far: You have an awful lot of repos, about the appropriate number to guarantee trouble . AFAICS that's where the reason lies for wanting to downgrade from KDE4 4.5. I even think that downgrading KDE4 is not a solution to whatever you're trying to achieve. But......all this IMHO.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •