Results 1 to 4 of 4

Thread: Mouse not working after kernel Update

  1. #1
    Join Date
    Feb 2010
    Location
    Florida,USA
    Posts
    80

    Default Mouse not working after kernel Update

    After the latest kernel update, on the updates repository, I couldn’t loging into X, I was greeted by a console screen and a blinking cursor. Im sort of used to this by now, so I immediately switched to init 3, removed my old fglrx drivers and tried to use the old familiar sax2 to reconfigure my video settings to default options. I was very surprised when sax2 didn’t work, in fact it seems not to be installed, uh ??!!!

    Anyways, I decided to restore an old xorg.conf backup, one before I installed the proprietary ati divers.... That did the trick. I was able to log back into my desktop.
    This is when I noticed my mouse wasn’t working properly. Specifically it would work just fine, but when left alone for 2-3 seconds it would simply become unresponsive and the lights would turn off. To reactivate it was necessary to press any button, then the lights would turn back on and I could move the pointer again. Is the mouse hibernating???!!!!

    I though it was an xorg.conf misconfiguration but after downloading and installing the latest ati drivers and running aticonfig --initial the problem persists. I did take a look at my xorg.conf file and I didn’t notice any “Device Mouse ” sections, not in the new or any of the old xorg.conf backups I had.
    Is this a kernel bug, or is there something.else broken in my system??

    I have a standard USB optical mouse.
    I have booted into debian, sidux and windows after that and the mouse works just fine.

    Does anybody have any idea about what can be causing this??

    Thank you.

  2. #2
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: Mouse not working after kernel Update

    I had the same problems as you with the mouse and also the keyboard both USB. I searched the forums and found a fix at the following link.

    http://forums.opensuse.org/english/get-help-here/hardware/445907-keyboard-mouse-freezes-11.html

    I hope that this works out for you!!!

    Cheers
    etech97

  3. #3
    Join Date
    Feb 2010
    Location
    Florida,USA
    Posts
    80

    Default Re: Mouse not working after kernel Update

    Thank you!!

    The solutions posted there did not solve the problem for me, but in the official bug thread I found this small line that fixed it instantly:

    echo -1 > /sys/bus/usb/devices/?-?/power/autosuspend

    where ? =the bus number and the 2nd ? = the device number of the affected hardware. TO see a list of all current usb devices simply use the lsusb command.

    In my case:
    lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 002: ID 0c45:5308 Microdia
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    so I wrote:
    echo -1 > /sys/bus/usb/devices/5-1/power/autosuspend

    that fixed it instantly!!!
    To avoid doing this every time you reboot is useful to create a start up script in kde/autostart folder

    note that the device number is always one number less than the one listed. If I wrote:

    echo -1 > /sys/bus/usb/devices/5-2/power/autosuspend
    it would return an error.

  4. #4

    Default Re: Mouse not working after kernel Update

    Quote Originally Posted by Hanzdersion View Post
    Thank you!!

    The solutions posted there did not solve the problem for me, but in the official bug thread I found this small line that fixed it instantly:

    echo -1 > /sys/bus/usb/devices/?-?/power/autosuspend
    That was one of the solution posted there.

    So I wrote:
    echo -1 > /sys/bus/usb/devices/5-1/power/autosuspend

    that fixed it instantly!!!
    To avoid doing this every time you reboot is useful to create a start up script in kde/autostart folder
    Yep. It's even better to write that command in /etc/rc.d/boot.local.

    script vs. udev rule

    • The first hack : Keyboard & mouse freezes
      • works instantly
      • works automatically (it's a script which does exactly what you did)
      • is enabled at the very end of the init process
      • stops working when using a kvm switch or unpluging a device

    • The second solution: Keyboard & mouse freezes
      • requires a reboot
      • requires some work (find out and add the vendor and product IDs of your devices in the sample udev rule)
      • is enabled at the beginning of the boot process
      • always works

      * the udev rule I put together is buggy but works (2 bugs cancelling each other). Read the following posts for a cleaner version.
    • and last but not least the third solution: Keyboard & mouse freezes
      recompiling the kernel !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •