Results 1 to 10 of 10

Thread: Software Update wants to update "choqoc" which is not installed

  1. #1

    Default Software Update wants to update "choqoc" which is not installed

    Hi,

    my Software Update wants to update "choqoc". However, it's not installed. What to do?

    Code:
    xxx@linux-9a0h:~> rpm -qa | grep choqok
    xxx@linux-9a0h:~>

  2. #2
    Join Date
    Jan 2009
    Location
    43.009 N, 73.172 W
    Posts
    189

    Default Re: Software Update wants to update "choqoc" which is not installed

    From a root terminal try

    Code:
    zypper info choqok
    It will tell you if it's installed or not. Read the description, and if you think it's OK, then install it with

    Code:
    zypper in choqok
    Box: Home Built | Intel Core2 @2.4 GHz | 6 GB | OpenSUSE 11.4| KDE 4.6.0 r6| nVidia GeForce 7300 GT

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Software Update wants to update "choqoc" which is not installed

    Quote Originally Posted by brian_j View Post
    Hi,

    my Software Update wants to update "choqoc". However, it's not installed. What to do?

    Code:
    xxx@linux-9a0h:~> rpm -qa | grep choqok
    xxx@linux-9a0h:~>
    If it's not installed the update shouldn't come up for installation! It's a bad update. I had trouble with this one, but I am not on that system at the moment so can't tell if it has been corrected or gone away. It didn't actually update anything, just sat there continually saying it was updating.

    You could take a look at what is going on by going to Yast>Software>Online Update. (I didnt have time).

  4. #4

    Default Re: Software Update wants to update "choqoc" which is not installed

    Quote Originally Posted by udaman View Post
    From a root terminal try

    Code:
    zypper info choqok
    well, like i said, its not installed.

    Code:
    linux:~ # zypper info choqok
    Loading repository data...
    Reading installed packages...
    
    
    Information for package choqok:
    
    Repository: openSUSE-11.3-Update
    Name: choqok
    Version: 0.9.90+svn1171227-1.2.1
    Arch: x86_64
    Vendor: openSUSE
    Installed: No
    Status: not installed
    Installed Size: 3.3 MiB
    Summary: Micro-Blogging Client for KDE
    Description: 
    A Free/Open Source micro-blogging client for the K Desktop Environment.
    The name comes from an ancient Persian word which means Sparrow.
    It currently supports twitter.com and identi.ca services.
    It will tell you if it's installed or not. Read the description, and if you think it's OK, then install it with

    Code:
    zypper in choqok
    but i do not want to install it. thats the point, its not installed and Software Update wants to update it...

  5. #5

    Default Re: Software Update wants to update "choqoc" which is not installed

    Quote Originally Posted by consused View Post
    You could take a look at what is going on by going to Yast>Software>Online Update. (I didnt have time).
    that shows this conflict:

    Code:
    patch:choqok-3320.noarch conflicts
    with libqoauth1.x86_64 < 1.0.1-2.1.1 provided by
    libqoauth1-1.01-0.pm.3.1.x86_64
    
    - install libqoauth1-1.0.1-2.1.1.x86_64 (with vendor change)
    - do not install patch:choqok-3320.noarch
    here is a screenshot: screen.png
    that shows, that this patch applies NOT to the package "choqok", but actually to libqoauth1. so updating libqoauth1 from the opensuse update repo solved this... thx!

  6. #6
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Software Update wants to update "choqoc" which is not installed

    On Mon, 25 Oct 2010 21:36:02 +0530, consused <consused@no-mx.forums.opensuse.org> wrote:

    > If it's not installed the update shouldn't come up for installation!
    > It's a bad update. I had trouble with this one, but I am not on that
    > system at the moment so can't tell if it has been corrected or gone
    > away. It didn't actually update anything, just sat there continually
    > saying it was updating.
    >You could take a look at what is going on by going to
    > Yast>Software>Online Update. (I didnt have time).


    probably a good idea to find out what's going on and report it to whoever is responsible (?). in the meantime you should be able to lock the package in it's not-installed state, preventing zypper & yast to consider it for updates.

    --
    phani.

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Software Update wants to update "choqoc" which is not installed

    brian_j, well done and thanks for the useful feedback.

  8. #8
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Software Update wants to update "choqoc" which is not installed

    please disregard my next message, which will come in via the NNTP interface shortly. didn't know that the problem had been solved already.

    --
    phani.

  9. #9

    Default Re: Software Update wants to update "choqoc" which is not installed

    Quote Originally Posted by consused View Post
    thanks for the useful feedback.
    thats what i always try, but neverless too often fail...well anyway thanks for your help!

  10. #10
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Software Update wants to update "choqoc" which is not installed

    Quote Originally Posted by phanisvara View Post
    please disregard my next message, which will come in via the NNTP interface shortly. didn't know that the problem had been solved already.

    --
    phani.
    No worries. This type of update problem has happened before, so I guess the packagers know about this problem. It seems to occur when a dependency of another package is the target of the update, but the package itself isn't to be updated and isn't installed by default.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •