Results 1 to 5 of 5

Thread: KDE fails after zypper up

  1. #1
    Kevin Miller NNTP User

    Default KDE fails after zypper up

    Yesterday I performed a zypper up on my system. Stock KDE4 that comes
    with 11.3. After I restarted the computer, it would get about 4/5 the
    way through the progress bar that displays when first starting then lock
    up hard.

    Starting in safe mode works. With a little experimenting I found that
    typing x11failsafe to the boot up options line let me start without a
    problem also.

    The sleazy workaround would be to add that parameter to the grub menu,
    but I'd rather have a real fix. Has anyone else seen this issue? Is
    there a fix for it?

    In /var/log/warn I see this message:
    "Sep 14 08:16:49 orca kdm_config[1279]: Multiple occurrences of key
    'UseTheme' in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc"
    but when I look there I don't see multiple occurrences.

    orca:/usr/share/kde4/config/kdm # grep UseTheme kdmrc
    UseTheme=true
    orca:/usr/share/kde4/config/kdm #

    Repos look thus:
    orca:/usr/share/kde4/config/kdm # zypper lr -d
    # | Alias |
    Name | Enabled | Refresh | Priority |
    Type |
    URI | Service
    ---+-------------------------------------+-------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------+--------
    1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3
    11.3-1.82 | Yes | Yes | 99 | rpm-md |
    http://download.opensuse.org/update/11.3/ |
    2 | download.opensuse.org-mozilla | openSUSE BuildService -
    Mozilla | Yes | Yes | 99 | rpm-md |
    http://download.opensuse.org/reposit...openSUSE_11.3/ |
    3 | download.videolan.org-SuSE | VideoLan
    Repository | No | Yes | 99 | rpm-md |
    http://download.videolan.org/pub/vid...vlc/SuSE/11.3/ |
    4 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3
    11.3-1.82 | Yes | No | 99 | yast2 |
    cd:///?devices=/dev/sr0,/dev/sr1 |
    5 | packman.inode.at-suse | Packman
    Repository | Yes | Yes | 99 | rpm-md |
    http://packman.inode.at/suse/11.3/ |
    6 | repo-debug |
    openSUSE-11.3-Debug | No | Yes | 99 |
    NONE | http://download.opensuse.org/debug/d...11.3/repo/oss/ |
    7 | repo-non-oss |
    openSUSE-11.3-Non-Oss | Yes | Yes | 99 |
    yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    8 | repo-oss |
    openSUSE-11.3-Oss | Yes | Yes | 99 |
    yast2 | http://download.opensuse.org/distrib...11.3/repo/oss/ |
    9 | repo-source |
    openSUSE-11.3-Source | Yes | Yes | 99 |
    yast2 | http://download.opensuse.org/source/...11.3/repo/oss/ |
    10 | virtualbox | VirtualBox for openSUSE
    11.3 | Yes | Yes | 120 | rpm-md |
    http://download.virtualbox.org/virtu.../opensuse/11.3 |

    TIA...

    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org



  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,528

    Default Re: KDE fails after zypper up

    1) please use the CODE tags to keep the original format the above is very hard to read. You will find them in the advanced mode of the online editor the # on the bar.
    2) I'd disable #4 it is rhe install media and unless you explicitly want something off the diskit is no longer needed
    3) this appears to be a video problem so what video card do you have? It may alos help to read this
    openSUSE Graphic Card Practical Theory Guide for Users

  3. #3
    Kevin Miller NNTP User

    Default Re: KDE fails after zypper up

    On 09/14/2010 09:36 AM, gogalthorp wrote:
    >
    > 1) please use the CODE tags to keep the original format the above is
    > very hard to read. You will find them in the advanced mode of the online
    > editor the # on the bar.


    Sorry - posting from nntp, not web forums.

    > 2) I'd disable #4 it is the install media and unless you explicitly
    > want something off the disk it is no longer needed


    Yeah, good idea. Usually do that, just spaced it out.

    > 3) this appears to be a video problem so what video card do you have?


    On board (Dell GX280).

    Vendor: Intel Corporation
    Model: 915 G
    2D driver: fbdev
    3D driver: swrast (No 3D Acceleration) (7.8.2))

    > It may also help to read this
    > 'openSUSE Graphic Card Practical Theory Guide for Users'
    > (http://tinyurl.com/2vsv4rh)


    Browsed through it. Looking at the Xorg.0.log it seems I'm running the
    fbdev driver. Not a gamer so don't mind too much, but better video
    would be nice. Not sure why the "intel" driver isn't loading.

    The page indicates that running xorg -configure may help, but since it's
    deprecated I'd rather the actual problem be fixed (if possible).
    Possibly using the intel driver rather than fbdev would help. How do I
    go about loading that?

    ....Kevin
    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,528

    Default Re: KDE fails after zypper up

    You might try renaming the /etc/X11/xorg.conf file It should not be needed anymore and may be the root of the problem. The intel driver is now built into the kernel. Note there have been issues with some intel chips

    You can just type the code tags. Put CODE in square brackets [] before the text and /CODE in square brackets [] after the text

  5. #5
    Kevin Miller NNTP User

    Default Re: KDE fails after zypper up

    On 09/14/2010 03:06 PM, gogalthorp wrote:
    >
    > You might try renaming the /etc/X11/xorg.conf file It should not be
    > needed anymore and may be the root of the problem. The intel driver is
    > now built into the kernel. Note there have been issues with some intel
    > chips


    There is no xorg.conf file. Just an xorg.conf.d directory and an
    xorg.conf.install file (which doesn't mention the intel driver).

    There's not much of interest in there - everything just says "Default
    this or that" such as:

    > cat 50-monitor.conf

    Section "Monitor"
    Identifier "Default Monitor"

    ## If your monitor doesn't support DDC you may override the
    ## defaults here
    #HorizSync 28-85
    #VertRefresh 50-100

    ## Add your mode lines here, use e.g the cvt tool



    EndSection

    I'm wondering if the intel driver isn't active because I'm starting with
    the x11failsafe parameter. Maybe that forces it to remain in frame
    buffer mode. lsmod shows:
    intel_agp 27995 2 i915
    so I expect it's in there somewhere.

    I had to recompile my VirtualBox module - wonder if I need to do that
    also for the video? Part of the update was a new kernel.

    > You can just type the code tags. Put CODE in square brackets [] before
    > the text and /CODE in square brackets [] after the text


    Oh. That's great - thanks for the tip. I'll try to make a note of it
    if/when I need it again.

    ....Kevin
    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •