Results 1 to 7 of 7

Thread: Desktop shortcut won't start my app

  1. #1
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Question Desktop shortcut won't start my app

    This will be very stupid, however....
    I installed matlab for linux via the installer. When I type into the terminal as normal user:
    Code:
    matlab
    the program starts perfectly fine.
    I want now a click-able icon on the desktop (KDE3.5). So when I produce the application shortcut, no matter how I do define the command, it will not start.
    I did put
    Command: matlab (tried also matlab glnx86)
    I joined in advanced: start in terminal (but it does not work either)
    I did join the complete and correct path......
    Somehow....I do not understand why it starts from the console in user-mode without problems with the command but not while using a shortcut.
    Any suggestion?
    Thanks

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Desktop shortcut won't start my app

    Is there an application launcher in /usr/share/applications?

  3. #3
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Desktop shortcut won't start my app

    Can you launch any other application from desktop? Is it only that one?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,654

    Default Re: Desktop shortcut won't start my app

    Where did matlab get installed? You may need to provide the complete path.

  5. #5
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Desktop shortcut won't start my app

    @chief-sealth: no there isn't any.

    @ah7013: yes it is the only shortcut where I encounter the problem. All others run fine.

    @gogalthorp: I did give the full install path until the program itself, either with the command or with the path, none worked. The funny thing is: when I am in yakuake (console) and I type in the normal command "matlab" without anything else, it starts immediately. It does so by building a shell /bin/sh and then starts up the application. The install is is /usr/local/share/mathworks. I have as user read and write access (limited to this directory), that's why it does start from terminal and works flawlessly. File permissions in Yast are set to secure. I have also STATA in /usr/local/STATA and it does have a shortcut on the desktop. No problem at all.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,527
    Blog Entries
    15

    Default Re: Desktop shortcut won't start my app

    Hi
    Can you look at the desktop entry via the command line (maybe it needs to start in a terminal?)
    Code:
    ls ~/Desktop
    cat ~/Desktop/<shortcut_name>.desktop
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Apr 2010
    Location
    Dallas, TX
    Posts
    8

    Default Re: Desktop shortcut won't start my app

    Hi Stakanov,

    I believe what you are looking for is the -desktop option.

    Here is my desktop entry in /usr/share/applications

    [Desktop Entry]
    X-SuSE-translate=true
    GenericName=Mathworks Matlab R2010a
    Encoding=UTF-8
    Name=Matlab
    Exec=matlab -desktop
    Icon=matlab
    Terminal=false
    Type=Application
    Categories=Application;Development;
    StartupNotify=true

    PerfectSine

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •