Results 1 to 7 of 7

Thread: Konqueror crash using webkit

  1. #1
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Konqueror crash using webkit

    Hello,

    I sometimes use webkit in Konqueror to view certain sites, but lately I haven't been able to since Konqueror crash everytime I activate webkit. I searched for this issue on the web and found among others this: https://bugs.kde.org/show_bug.cgi?id=241702

    I downgraded Flash to 10.0.45xxx and it seems like Konqueror runs fine with webkit now. However I now got this message browsing Hattrick.org:
    icedteanp plugin error: Failed to run /etc/alternatives/../../bin/java. For more detail rerun "firefox -g" in a terminal window.
    This error only occur when using webkit, not with KHTML.

    Anyone who know what this means?
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  2. #2
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Konqueror crash using webkit

    I followed this thread: Java Plugin for firefox I Installed Java and removed javajdk and everything seems fine.

    PS
    Having crashed Konqueror several times lately I notice that I am unable to restart the crashed application within the KCrash dialogue. Is this a "normal" flaw?
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,443

    Default Re: Konqueror crash using webkit

    It's https://bugs.kde.org/show_bug.cgi?id=241702 for which there are many duplicate bug reports.

    It only happens on Javascript heavy sites.

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Konqueror crash using webkit

    Hei John,

    I suppose it is in conjunction with flash then, the downgrade of the flash player as well as using the Sun Java packages instead of the Java_openjdk packages seems to work fine.

    Olav
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,443

    Default Re: Konqueror crash using webkit

    Not as I understand. I have no problem using flash in Konqueror - the problems affect, for me at least, only a very small number of sites which make very heavy use of Javascript (which is nothing to do with Sun Java).

  6. #6
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Konqueror crash using webkit

    Ok

    Do you know what cause good or bad java-script performance, I thought it was related to Java runtime env. But I haven't got a clue really.

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,443

    Default Re: Konqueror crash using webkit

    Javascript and Java are two totally different things - Java is irrelevant to this problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •