Results 1 to 8 of 8

Thread: Initial keypresses lost after a pause or when starting to type into a text field

  1. #1

    Default Initial keypresses lost after a pause or when starting to type into a text field

    I have just done a fresh install of OpenSuse 11.3 I am using KDE4.

    When I move my mouse and click on a text field, I start typing and the first few keypresses are ignored. Or if I stop typing and pause for a bit without moving the mouse or doing anything, then when I press the next key it is ignored again.

    If I go to System settings -> accessibility, neither slow keys, bounce keys or sticky keys are ticked.

    The effect of this is that if I momentarily pause for thought in the middle of writing then sometimes half a word can go missing. Unfortunately this makes the desktop extremely difficult to use as I am always having to check that all my key presses have been accepted. I am relatively fast at typing.

    Thanks

  2. #2

    Default Re: Initial keypresses lost after a pause or when starting to type into a text field

    Actually I think I may have just found a bug.

    In ~/.kde4/share/config/kaccessrc, even though SlowKeys=false, changing SlowKeysDelay=500 to SlowKeysDelay=0 seems to solve the problem.

    In System settings -> accessibility the slider only goes down to 50msec. Changing it in the config file effectively disables it even though it's not supposed to be on. (I was on the verge of moving to Gnome even though I prefer KDE)

    This means that there is a bug, My slow keys are on when they shouldn't be.

    This is my config file as it currently stands

    [Bell]
    ArtsBell=false
    SystemBell=true
    VisibleBell=false
    VisibleBellColor=255,0,0
    VisibleBellInvert=true
    VisibleBellPause=500

    [Keyboard]
    AccessXBeep=true
    AccessXTimeout=false
    AccessXTimeoutDelay=30
    BounceKeys=false
    BounceKeysDelay=500
    BounceKeysRejectBeep=true
    GestureConfirmation=false
    Gestures=false
    SlowKeys=false
    SlowKeysAcceptBeep=true
    SlowKeysDelay=0
    SlowKeysPressBeep=true
    SlowKeysRejectBeep=true
    StickyKeys=false
    StickyKeysAutoOff=false
    StickyKeysBeep=true
    StickyKeysLatch=true
    ToggleKeysBeep=true
    kNotifyAccessX=true
    kNotifyModifiers=true

  3. #3
    Join Date
    Mar 2009
    Location
    Romania
    Posts
    33

    Default Re: Initial keypresses lost after a pause or when starting to type into a text field

    If you have a usb mouse/keyboard look at Keyboard & mouse freezes

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Initial keypresses lost after a pause or when starting to type into a text field

    If you think you've found a bug, report it on the bug tracker.

    https://bugzilla.novell.com/index.cgi

  5. #5

    Default Re: Initial keypresses lost after a pause or when starting to type into a text field

    Hmm, now that I have switched the computer on from cold the next day the problem seems to be back in full force even though the config file is unchanged. Because my solution seems to have stopped working I haven't submitted a bug yet.

    It's not a problem with the mouse freezing, only the key presses being accepted for a few milliseconds when I first start typing. Which suggests that slow keys is activated.

    Apologies for missing information, it's actually difficult to type fluidly. I initially tried updating from 11.2 to 11.3 but because of this bug did a fresh install. I kept the /home partition so the config files are probably from previous versions of KDE.

    If I can't solve this problem I'll install Gnome instead because my computer is pretty much unusable like this. I much prefer KDE though.

    EDIT: OK, after submitting this post, I logged out and immediately logged back in again. The problem is gone. This means that it occurs when I first boot up but not when I log in from the splash screen.

    I am using a USB keyboard and mouse.

  6. #6

    Default Re: Initial keypresses lost after a pause or when starting to type into a text field

    It seems to be an issue with automatic login.

    If I disable automatic login, kdm still has the problem of slow keys when I type in my password. But when I log in into my user account I don't have a problem, even if I set SlowKeysDelay=500 in my kaccessrc file.

    If I can find out how to reproduce this error then I can submit a bug report (if it is a bug). Anyone know where KDM config files are?

  7. #7

    Default Re: Initial keypresses lost after a pause or when starting to type into a text field

    Hello there!

    I have the same trouble after upgrading my system from 11.2 to 11.3.
    I think the problem is in USB keyboard (or its driver), because if I type on laptop's keyboard there is no such issue.
    And one more... it is not just a KDM/X11 bug - if you go to virtual console (e.g. Ctrl+Alt+F1) here you can still experience this strange bug.

    So.. the bug must be fixed.. weird bug.

    PS. same problem: Problem after test kernel update ?

  8. #8

    Default Re: Initial keypresses lost after a pause or when starting to type into a text field

    Well..

    This advice doesn't work for me, but this manipulations works fine! Thank you please_try_again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •