Results 1 to 4 of 4

Thread: Can't start Banshee application after upgrade it

  1. #1
    Join Date
    Jan 2009
    Location
    China
    Posts
    40

    Default Can't start Banshee application after upgrade it

    Hi,

    After I upgrade the Banshee to 1.7.5-91 version, I can't start it.
    When try to start it, the window of it appears and close immediately.

    Following is information I run it from console:
    $banshee-1
    [Info 18:48:29.169] Running Banshee 1.7.5: [Banshee / openSUSE_11.3 (linux-gnu, x86_64) @ 2010-09-07 20:06:10 UTC]
    [Warn 18:48:31.955] Hardware manager extension failed to load - System.InvalidOperationException: Type 'Banshee.Hardware.Gio.HardwareManager' not found in add-in 'Banshee.Gio,1.0' (in `Mono.Addins')
    at Mono.Addins.RuntimeAddin.GetType (System.String typeName, Boolean throwIfNotFound) [0x00000] in <filename unknown>:0
    at Mono.Addins.TypeExtensionNode.get_Type () [0x00000] in <filename unknown>:0
    at Mono.Addins.TypeExtensionNode.CreateInstance () [0x00000] in <filename unknown>:0
    at Mono.Addins.InstanceExtensionNode.CreateInstance (System.Type expectedType) [0x00000] in <filename unknown>:0
    at Banshee.Hardware.HardwareManager..ctor () [0x00000] in <filename unknown>:0
    [Warn 18:48:37.849] Caught an exception - GLib.GException: 图标process-working未出现在主题中 (in `gtk-sharp')
    at Gtk.IconTheme.LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags) [0x00000] in <filename unknown>:0
    at Banshee.Gui.Widgets.TaskStatusIcon..ctor () [0x00000] in <filename unknown>:0
    [Warn 18:48:39.404] Caught an exception - System.ApplicationException: No support GNOME Settings Daemon could be reached. (in `Banshee.MultimediaKeys')
    at Banshee.MultimediaKeys.MultimediaKeysService.Banshee.ServiceStack.IExtensionService.Initialize () [0x00000] in <filename unknown>:0
    at Banshee.ServiceStack.ServiceManager.StartExtension (Mono.Addins.TypeExtensionNode node) [0x00000] in <filename unknown>:0
    [Warn 18:48:39.404] Extension `Banshee.MultimediaKeys.MultimediaKeysService' not started: No support GNOME Settings Daemon could be reached.
    [Info 18:48:39.460] Updating web proxy from GConf
    [Warn 18:48:39.868] Caught an exception - System.ApplicationException: No support GNOME Settings Daemon could be reached. (in `Banshee.MultimediaKeys')
    at Banshee.MultimediaKeys.MultimediaKeysService.Banshee.ServiceStack.IExtensionService.Initialize () [0x00000] in <filename unknown>:0
    at Banshee.ServiceStack.ServiceManager.StartExtension (Mono.Addins.TypeExtensionNode node) [0x00000] in <filename unknown>:0
    [Warn 18:48:39.868] Extension `Banshee.MultimediaKeys.MultimediaKeysService' not started: No support GNOME Settings Daemon could be reached.
    [Info 18:48:39.871] All services are started 8.889569
    The program 'Banshee' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadMatch (invalid parameter attributes)'.
    (Details: serial 377 error_code 8 request_code 2 minor_code 0)
    (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error() function.)
    My system is openSUSE 11.3 x86_64 .
    Help you can help me, thanks!

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Can't start Banshee application after upgrade it

    If you have an option to drop back to Banshee 1.6.1 I would do it. I found that after going to KDE 4.5 and Banshee 1.7, Banshee would not work, ever. Later I dropped back to KDE 4.4 and Banshee 1.6.1 and now everything works properly. I don't know what to say, but newer is not better. To make such a downgrade I had to reload openSUSE 11.3 from scratch, but did not reformat my separate /home area. In a couple of hours I had everything back to normal. This is just a thought for you to think about as you did not mention your KDE version.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jan 2009
    Location
    China
    Posts
    40

    Default Re: Can't start Banshee application after upgrade it

    Thank you very much!
    My KDE version is 4.4.4.
    Maybe you are right, I will rollback to the before version.
    Thanks!

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Can't start Banshee application after upgrade it

    See if this fixes the problem:

    Code:
    mkdir ~/banshee-icon
    sudo mv /usr/lib/banshee-1/Extensions/Banshee.Notification* ~/banshee-icon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •