Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Repository initialization error on suse 11.3 kde

  1. #1
    Join Date
    Sep 2010
    Location
    Antananarivo, Madagascar
    Posts
    103

    Question Repository initialization error on suse 11.3 kde

    Whenever I open software repositories or management via YaST I get an error message about a Repository initialization error

    From Software Repositories
    There were errors while restoring the repository configuration.
    Error refreshing service service_4 (http://download.opensuse.org/distrib...epo/non-oss/): File './repo/repoindex.xml' not found on medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/?cookies=0' History: - [AbstractCommand.cc:224] URI=http://download.opensuse.org/distribution/11.3/repo/non-oss/repo/repoindex.xml?cookies=0
    From Software management
    There was an error in the repository initialization.
    Error refreshing service service_4 (http://download.opensuse.org/distrib...epo/non-oss/):

    File './repo/repoindex.xml' not found on medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URI=http://download.opensuse.org/distribution/11.3/repo/non-oss/repo/repoindex.xml?cookies=0
    The repos seem to work and I can install software

    What did I do wrong? And how do I fix it?

    Thank you in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Repository initialization error on suse 11.3 kde

    Did you try removing them and adding them again, perhaps use a mirror nearer to you
    openSUSE Download Mirrors - 11.3
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Sep 2010
    Location
    Antananarivo, Madagascar
    Posts
    103

    Default Re: Repository initialization error on suse 11.3 kde

    Quote Originally Posted by caf4926 View Post
    Did you try removing them and adding them again, perhaps use a mirror nearer to you
    openSUSE Download Mirrors - 11.3
    Yes I did

    I moved it too servers in South Africa.

    The one is ftp.up.ac.za if I am not mistaken.
    thanks

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Repository initialization error on suse 11.3 kde

    Please post result of

    zypper lr -d
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Sep 2010
    Location
    Antananarivo, Madagascar
    Posts
    103

    Default Re: Repository initialization error on suse 11.3 kde

    jandre@linux-nogw:~> zypper lr -d

    1 | 11.3 | 11.3 | Yes | No | 99 | rpm-md | ftp://ftp.up.ac.za/mirrors/opensuse/...e/update/11.3/ |
    2 | 11.3_1 | Nvidia | Yes | No | 99 | rpm-md | http://download.nvidia.com/opensuse/11.3/ |
    3 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 98 | yast2 | cd:///?devices=/dev/sr0 |
    4 | openSUSE-11.3-NonOSS-Add-on_11.3-1.80_1 | openSUSE-11.3-NonOSS-Add-on 11.3-1.80 | Yes | No | 99 | yast2 | ftp://opensuse.mirror.ac.za/%2fopens.../repo/non-oss/ |
    5 | openSUSE-11.3_11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 98 | yast2 | dvd:/// |
    6 | openSUSE-11.3_11.3-1.82_1 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | ftp://ftp.up.ac.za/%2fmirrors/opensu...11.3/repo/oss/ |
    7 | packman | packman | Yes | No | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/11.3 |
    8 | reddwarf_1 | reddwarf | Yes | No | 99 | rpm-md | Index of /repositories/home:/RedDwarf/openSUSE_11.3 |
    9 | repo-source | openSUSE-11.3-Source | No | No | 99 | NONE | Index of /source/distribution/11.3/repo/oss |

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Repository initialization error on suse 11.3 kde

    Quote Originally Posted by ClrScr View Post
    jandre@linux-nogw:~> zypper lr -d

    1 | 11.3 | 11.3 | Yes | Yes | 99 | rpm-md | ftp://ftp.up.ac.za/mirrors/opensuse/...e/update/11.3/ |
    2 | 11.3_1 | Nvidia | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.3/ |
    3 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | No | No | 98 | yast2 | cd:///?devices=/dev/sr0 |
    4 | openSUSE-11.3-NonOSS-Add-on_11.3-1.80_1 | openSUSE-11.3-NonOSS-Add-on 11.3-1.80 | Yes | Yes | 99 | yast2 | ftp://opensuse.mirror.ac.za/%2fopens.../repo/non-oss/ |
    5 | openSUSE-11.3_11.3-1.82 | openSUSE-11.3 11.3-1.82 | No | No | 98 | yast2 | dvd:/// |
    6 | openSUSE-11.3_11.3-1.82_1 | openSUSE-11.3 11.3-1.82 | Yes | Yes | 99 | yast2 | ftp://ftp.up.ac.za/%2fmirrors/opensu...11.3/repo/oss/ |
    7 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/11.3 |
    8 | reddwarf_1 | reddwarf | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/RedDwarf/openSUSE_11.3 |
    9 | repo-source | openSUSE-11.3-Source | No | No | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    I have edited the above
    Look carefully how I have put them all to Yes | Yes in the enable/refresh
    Except the cd and dvd (not sure why you have both) #3 and 5 they are both No | No
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Sep 2010
    Location
    Antananarivo, Madagascar
    Posts
    103

    Default Re: Repository initialization error on suse 11.3 kde

    I changed the enable/refresh to yes/yes as you suggested except for 3,5,9 as per above
    Still no change

    Error 1
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://download.opensuse.org/distribution/11.3/repo/oss/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://download.opensuse.org/distribution/11.3/repo/oss/repo/repoindex.xml?cookies=0
    Above error occurs 2 times

    Error 2
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://download.opensuse.org/update/11.3/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://download.opensuse.org/update/11.3/repo/repoindex.xml?cookies=0
    Above occurs 1

    Error 3
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://ftp.gwdg.de/pub/linux/packman/suse/11.3/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://ftp.gwdg.de/pub/linux/packman/suse/11.3/?cookies=0
    Above occurs 1 time

    Error 4
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://download.opensuse.org/distribution/11.3/repo/non-oss/repo/repoindex.xml?cookies=0
    Above occurs 1 time

    Then I get the final error message just as the repo's page appears

    There were errors while restoring the repository configuration.
    Error refreshing service service_4 (http://download.opensuse.org/distrib...epo/non-oss/): File './repo/repoindex.xml' not found on medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/?cookies=0' History: - [AbstractCommand.cc:224] URI=http://download.opensuse.org/distribution/11.3/repo/non-oss/repo/repoindex.xml?cookies=
    Same error as before

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    18,913
    Blog Entries
    14

    Default Re: Repository initialization error on suse 11.3 kde

    There's something wrong with one of the URLs. In the post, click the URL for 'nvidia' and you will see that it errors out, due to a "http://http://" sequence. Remove the error causing repo, and re-add with correct data.
    Last edited by Knurpht; 09-Sep-2010 at 00:39. Reason: Mistaken first, corrected
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Repository initialization error on suse 11.3 kde

    Nvidia should be

    ftp://download.nvidia.com/opensuse/11.3

    Well spotted @knurpht
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Sep 2010
    Location
    Antananarivo, Madagascar
    Posts
    103

    Default Re: Repository initialization error on suse 11.3 kde

    Quote Originally Posted by caf4926 View Post
    Nvidia should be

    ftp://download.nvidia.com/opensuse/11.3

    Well spotted @knurpht
    thanks I fixed the nvidia one but still get the same
    problem

    Result of zypper lr -d

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

    1 | 11.3 | 11.3 | Yes | Yes | 99 | rpm-md | ftp://ftp.up.ac.za/mirrors/opensuse/...e/update/11.3/ |
    2 | Nvidia | Nvidia | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.3/ |
    3 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 98 | yast2 | cd:///?devices=/dev/sr0 |
    4 | openSUSE-11.3-NonOSS-Add-on_11.3-1.80 | openSUSE-11.3-NonOSS-Add-on 11.3-1.80 | Yes | Yes | 99 | yast2 | ftp://opensuse.mirror.ac.za/opensuse.../repo/non-oss/ |
    5 | openSUSE-11.3_11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 98 | yast2 | dvd:/// |
    6 | openSUSE-11.3_11.3-1.82_2 | openSUSE-11.3 11.3-1.82 | Yes | Yes | 99 | yast2 | ftp://ftp.up.ac.za/mirrors/opensuse/...11.3/repo/oss/ |
    7 | packman_1 | packman | Yes | Yes | 99 | rpm-md | ftp://ftp.gwdg.de/pub/linux/misc/packman/suse/11.3/ |
    8 | reddwarf_1 | reddwarf | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/RedDwarf/openSUSE_11.3 |
    9 | repo-source openSUSE-11.3-Source | No | No | 99 | NONE | Index of /source/distribution/11.3/repo/oss |


    Error messages
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://download.opensuse.org/distribution/11.3/repo/oss/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://download.opensuse.org/distribution/11.3/repo/oss/repo/repoindex.xml?cookies=0
    Error 2
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://download.opensuse.org/update/11.3/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://download.opensuse.org/update/11.3/repo/repoindex.xml?cookies=0
    Above occurs 1

    Error 3
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://ftp.gwdg.de/pub/linux/packman/suse/11.3/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://ftp.gwdg.de/pub/linux/packman/suse/11.3/?cookies=0
    Above occurs 1 time

    Error 4
    Error
    Download failed:
    File './repo/repoindex.x.xml' not found of medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/?cookies=0'

    History:
    - [AbstractCommand.cc:224] URL=http://download.opensuse.org/distribution/11.3/repo/non-oss/repo/repoindex.xml?cookies=0
    Above occurs 1 time

    There were errors while restoring the repository configuration.
    Error refreshing service service_4 (http://download.opensuse.org/distrib...epo/non-oss/): File './repo/repoindex.xml' not found on medium 'http://download.opensuse.org/distribution/11.3/repo/non-oss/?cookies=0' History: - [AbstractCommand.cc:224] URI=http://download.opensuse.org/distribution/11.3/repo/non-oss/repo/repoindex.xml?cookies=
    Basically nothing changed!



    What do I do next?

    Thank you!

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •