Hi everyone,

I recently upgraded from a working 11.2 to 11.3, using x86_64 for both, and it worked fine for the most part except my firefox is unbearably glitchy. What happens is that part of the display in the web viewer (though it has happened in the search bar as well) will go black, and it will stay black until there is a redraw event, i.e. until I scroll the window a bit or move the window around. I can't take a screenshot of it, it always looks fine (but I promise I'm not going crazy!).

Anyway, I have often had a minor struggle with my ati 2400 pro, it is currently working fine, I just checked the 3d acceleration and it is definitely rocking. But basically what I did (though there have been more steps now but these are the ones I think worked) is I installed the ATI driver with the one-click install, and then I ran "aticonfig --initial" as root from the command line. I'm not so sure whether that helps or not.

The problem persists when firefox is run in KDE, and I think I may have seen screen glitches here and there, just not to such a usability breaking degree.

Unfortunately I've been really busy lately, and I am going to a movie tomorrow after work, so I am having a hard time getting enough time in front of this to try to fix it, but I would definitely appreciate any help I can get. Let me know if you need to know more info about my system, I will certainly respond as soon as I can.