Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Boot speed issues in KDE LiveCD

  1. #1

    Default Boot speed issues in KDE LiveCD

    I'm having very strange issues with OpenSUSE 11.3 KDE LiveCD, mainly performance-wise. Most noticeably, it takes 10-30 minutes to actually boot the system, and it doesn't matter whether the LiveCD is booted from the USB or if it's install into the hard disk. There aren't any noticeable errors during boot, though, except a few "timeout" errors and not being able to lauch VirtualBox Guest Additions (which I don't need since it's not run from VirtualBox anyway).

    It takes the most time during the "scanning USB devices" section if I boot from the USB, and during the state where it detects the network card/assigns an IP. In both cases, every dot that appears there takes around 2 minutes.

    During the boot, the PC seems to be mostly idle, and appears to do something only occasinally, when certain parts of the boot sequence are passed, so that makes boot up feel "jumpy" - nothing happens for 10 minutes, then the PC starts accessing the HDD, then nothing happens for 10 more minutes.

    There are other performance problems, noticeably during installation to HDD (through the Install option from the CD startup menu - it's quite a bit faster when started from the running LiveCD). For instance, it takes around 5-10 minutes to make the screen where you need to choose the language and keyboard layout responsive. The performance, in both cases, seems to be inconsistent - sometimes it starts booting and responding quickly, the other times it's really slow, up to the point of outright hanging.

    System specs:
    CPU: AMD Phenom II X4 925
    4GB RAM
    HDD: WD Caviar Black 640 GB
    GPU: ATI Radeon HD 4890

    I'll probably add the /var/log/boot.log later.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,814

    Default Re: Boot speed issues in KDE LiveCD

    Were did you get the disk? There should be no reference to Virtualbox in any way from a normal CD. Is this one that may have been optimized to install to a VM????

  3. #3

    Default Re: Boot speed issues in KDE LiveCD

    I've got it from the OpenSUSE website itself, KDE x64 LiveCD, Torrent download type.

  4. #4

    Default Re: Boot speed issues in KDE LiveCD

    It could be your CD download. My experience with torrents, the downloads were off in size and never passed checksums. Try downloading your ISO from Kernel.org mirror

    http://mirrors2.kernel.org/opensuse/...iveCD-i686.iso
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,814

    Default Re: Boot speed issues in KDE LiveCD

    "except a few "timeout" errors and not being able to lauch VirtualBox Guest Additions "

    A default CD knows nothing about VirtualBox or it's additions. So why would it complain about loading them? There is something fishy here.

    1) check the checksums
    2) run the media check option.

    Be sure you got the image from this page.
    software.opensuse.org: Download openSUSE 11.3

  6. #6

    Default Re: Boot speed issues in KDE LiveCD

    I've downloaded the Net Install package now and put it on another USB. It seems that it solved most of the problems - the installation was responsive now, and there are no more references to VirtualBox anywhere. However, slow boot times remain, but this time they seem to be isolated to one specific case - the network card. Both boot up and shut down procedures are very slow when it handles the network card, both on setting up the local network and the remote one as well as when shutting them down. It seems that it doesn't matter if it uses NetworkManager or the classic method.

    My network card is integrated Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC, and the slowdowns weren't present in OpenSUSE 11.2.

  7. #7

    Default Re: Boot speed issues in KDE LiveCD

    Hmm, second boot and it did boot faster, but now it slowed down in a different area after all. This is my boot.msg right now:
    klogd 1.4.1, log source = ksys - GreatEmerald - VNiX03Z8 - Pastebin.com
    Somehow it took a long while to activate swap, around 2 minutes, but that's a whole lot better than I've experienced before.

  8. #8

    Default Re: Boot speed issues in KDE LiveCD

    Off hand I'm thinking a hardware problem. most likely the harddrive.
    How old is this drive? if it is older than two years and has a lot of hours on it then i would suspect the drive.
    I'd run some disk checks to make sure.


    Quote Originally Posted by GreatEmerald View Post
    Hmm, second boot and it did boot faster, but now it slowed down in a different area after all. This is my boot.msg right now:
    klogd 1.4.1, log source = ksys - GreatEmerald - VNiX03Z8 - Pastebin.com
    Somehow it took a long while to activate swap, around 2 minutes, but that's a whole lot better than I've experienced before.

  9. #9

    Default Re: Boot speed issues in KDE LiveCD

    It's one year old now. Could do some diagnostics, but nothing like this has ever happened in OpenSUSE 11.2.
    After some more testing, I noticed that now the system is slower at shutting down and booting up, and the speed of boot up and shut down is varying between boots. Sometimes it shuts down normally, the others - takes up to 30 minutes. It seems that it spends the most time at the "Sending all processes the TERM/KILL signal..." step, quite often 5 minutes.
    So yea, it does seem quite random...

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Boot speed issues in KDE LiveCD

    You have tried the 11.2 cd as it stands now?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •