Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: No gui after installation

  1. #1

    Default No gui after installation

    Hi, I just installed 11.3 64 bit, installation went fine (though I went to sleep during package downloading), and now the system boots into a terminal (yellow/black) with automatic login.

    I'd like to boot into the usual login manager (I chose Kde for desktop), thanks for the help.

  2. #2
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: No gui after installation

    Put the installation disk and when you get to the first menu(Boot from hard disk, Installation, etc) press F3 which will give you a choice of resolution, choose let's say 800x600) and then do choose to start from your hard disk. I have this problem always when I first install a new version. Then I don't have to tweak it.
    or you can try in the terminal to type init 5 which will try to boot to the GUI.

  3. #3

    Default Re: No gui after installation

    I doubt the setup did change the default runlevel (which is 5) while you were sleeping. (But you can check that in /etc/inittab). If your system doesn't boot into GUI, Xorg is propably incomplete or misconfigured, most likely the video driver is missing or wrong. Check /var/log/Xorg.0.log to see what happended.

  4. #4

    Default Re: No gui after installation

    I tried a second install, same result, I stepped away while the installer was downloading packets with 1h40 left, but I came back after an hour to check, and it was in that terminal I talked about, yellow with black font in the upper left corner of the screen, with mouse still active a moving across the entire screen. It's not the no-gui state which I'm familiar with, it's more a broken gui stuck in a terminal.

    I checked the xorg log, looks like the driver is loading, there is a FATAL though, but I can't understand it all, I'll try to paste the log here, though I'm not sure how I can recover it.

    By the way I have dual screens (dvi+vga) on a HD4670 if that helps.

  5. #5

    Default Re: No gui after installation

    Can't find the edit button, so here's the xorg log: [ 27.160] X.Org X Server - Xorg log - mwEjPSQh - Pastebin.com

    Hope it helps to find whatever my problem is

    Do I have to login in the novell page every time I come to the forums?

  6. #6
    Join Date
    Nov 2009
    Location
    Australia
    Posts
    1,391

    Default Re: No gui after installation

    Code:
    #
    [    27.230] (EE) FATAL: RadeonHD presently does not work with kernel modesetting (KMS).
    #
    Please disable KMS in your kernel.
    #
    [    27.230] (II) [KMS] Kernel modesetting enabled.
    Add 'nomodesetting' as a boot optoin, also try setting up the second monitor after install

  7. #7

    Default Re: No gui after installation

    Thanks for the tip, I already suspected the dual monitor had something to do with it, so I'm reinstalling with one monitor only, and I'll try nomodesetting.

    Curious though how KMS is enabled by default considering the number of people with Radeon HD cards

  8. #8

    Default Re: No gui after installation

    I did an install with an HD card on a dual monitor system and the setup must have disabled KMS since it was using radeonhd at the end.
    I did an install on an iMac with an HD card, and it ended up using radeon (not radeonhd) because KMS was enable.
    I finally installed the latest ATI proprietary driver on both machines.

  9. #9

    Default Re: No gui after installation

    Using nomodesetting doesn't solve the problem, though there's no more fatal error in the xorg log. Dual monitors isn't the problem either since I installed with only one monitor plugged.

    Would installing the ATI Driver in init 3 solve something?

    Also, I just found out in the boot screen, that nscd service doesn't start, but I doubt that has anything to do with display.

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,818

    Default Re: No gui after installation

    The parameter is not nomodesetting it is nomodeset

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •