Results 1 to 6 of 6

Thread: Screensaver continuously coming on during VNC session

  1. #1

    Default Screensaver continuously coming on during VNC session

    When I login to my computer over VNC (using x11vnc) the screen saver is continuously restarting. In other words I every couple of seconds it goes back to screen saver, even if I'm in the middle of typing or moving the mouse.

    This didn't happen on opensuse 11.2 but is now happening on 11.3. Anyone know why this could be? I'd prefer not to have to turn off my screensaver.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Screensaver continuously coming on during VNC session

    Just turn the darn thing off.
    They are nothing but a pain in the rear. And they save nothing!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Screensaver continuously coming on during VNC session

    ok I've done so now, I'll have to wait until I'm at work again to test it as I don't have a 2nd computer at home. I'll post how it goes.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,523
    Blog Entries
    37

    Default Re: Screensaver continuously coming on during VNC session

    Quote Originally Posted by tk83 View Post
    When I login to my computer over VNC (using x11vnc) the screen saver is continuously restarting. In other words I every couple of seconds it goes back to screen saver, even if I'm in the middle of typing or moving the mouse.

    This didn't happen on opensuse 11.2 but is now happening on 11.3. Anyone know why this could be? I'd prefer not to have to turn off my screensaver.
    I've had this happen to me with 11.1 (w/KDE-3.5.10) on my Mother's PC in North America (which I maintain here from Europe). I'd turn the screen saver off, but she likes it. This only happens occasionally ... and what seems to set it off is if I log on to her PC with vnc, and then don't do anything for a long time (say 45 minutes or so).

    The only cure I found (short of disabling her screen saver, which she does not want) is to reboot the PC remotely and log on again in a few minutes after her PC has rebooted.

    I find if I do not have an excessively long pause (which seems to 'kick off the screeen saver' in to this extra annoying mode) but only have gaps of 10 minute or so when I do nothing, then nominal screen saver behaviour takes place, and the 'extra annoying mode' does not occur.

    Again, suspending the screen saver is the ultimate solution (as caf4926 pointed out) if you have that luxury.

  5. #5

    Default Re: Screensaver continuously coming on during VNC session

    Yeah I'm hoping simply suspending it will fix it, however the screen saver was coming on once every 1 or 2 seconds, whereas in the KDE settings it was set to only come on every 5 minutes. So I'm not sure what's going on - it could have something to do with this being a laptop and the lid being closed, however I didn't have this problem with 11.2 on the exact same laptop.

  6. #6

    Default Re: Screensaver continuously coming on during VNC session

    Yep, disabling the screensaver in the normal KDE settings worked. Now I just have to get the firewall rules right, but I'll start another thread for that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •