Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Kontact google calendar sync always says 'invalid password'

  1. #1

    Default Kontact google calendar sync always says 'invalid password'

    I'm trying to use Akonadi to sync kontact with my google kalendar on opensuse 11.3.

    I've installed the akonadi-googledata and libgcal0 packages from KDE:Extras and followed these instructions: stealthcopter.com Setting up google calendar with Kontact (or korganiser) using akonadi

    The problem is that the Akonadi Google Calendar resource keeps saying I've entered an invalid password. I've tried logging into gmail with a browser and confirmed I'm putting in the right password and username.

    Anyone have any ideas? The only thing I can think of is that here in Germany gmail.com gets redirected to mail.google.com due to some trademark dispute, could this be tripping up Akonadi?

  2. #2
    Join Date
    Oct 2009
    Location
    Slovakia
    Posts
    38

    Default Re: Kontact google calendar sync always says 'invalid password'

    I have the same problem. Somebody please help.

  3. #3
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Kontact google calendar sync always says 'invalid password'

    I have the same problem (Invalid password) when tried akonadi-googledata to sync my contacts with google mail. I have my email address ending with @gmail.com but still, I am not able to use it.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  4. #4

    Default Re: Kontact google calendar sync always says 'invalid password'

    I've opened a bug: https://bugzilla.novell.com/show_bug.cgi?id=642813

    Let's see if they can do anything to help

  5. #5
    Join Date
    Jun 2010
    Location
    Bedfordshire, United Kingdom
    Posts
    116

    Default Re: Kontact google calendar sync always says 'invalid password'

    Go to Start|System Settings|Network Settings|Proxy and select Connect to the Internet directly.

    Things should work now.

  6. #6

    Default Re: Kontact google calendar sync always says 'invalid password'

    No luck for me, now it says 'Failed getting last updated event'

  7. #7
    Join Date
    Jun 2010
    Location
    Bedfordshire, United Kingdom
    Posts
    116

    Default Re: Kontact google calendar sync always says 'invalid password'

    That seems to be another issue. It appears authentication has succeeded though.

  8. #8

    Default Re: Kontact google calendar sync always says 'invalid password'

    Yeah although it's still a bug that the authentication didn't work at first - I'm not using any proxies and no other KDE apps have any connectivity problems. I'll update the bug with this FWIW.

    Now I need to try solving this 'Failed getting last updated event'. Anyone have any ideas how to debug Anokadi stuff? Does it create log files anywhere?

  9. #9
    Join Date
    Jun 2010
    Location
    Bedfordshire, United Kingdom
    Posts
    116

    Default Re: Kontact google calendar sync always says 'invalid password'

    I set all this stuff up yesterday. Can you check the following:

    1) Is Akonadi Server running? - try starting Kontact or do "akonadictl start"
    2) Have you added the Google Calendar resource to Calendar in "KDE Resources"?
    3) Have you added a Google Calendar Akonadi resource in Kontact?

    After I did these, I have sync between my Android Phone/Google Calendar/Kontact on openSUSE-11.3.

  10. #10
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Kontact google calendar sync always says 'invalid password'

    I am not able to authenticate. However, I am able to authenticate from a C program using the libgcal library.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •