Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Cannot get SSH to work

  1. #1

    Unhappy Cannot get SSH to work

    Hi

    I just did a fresh install of OPENSUSE 11.3. And I can't connect to the machine via ssh.

    I get the folowing error in /var/log/messages:
    Sep 4 08:04:11 OSUSE sshd[10589]: Accepted keyboard-interactive/pam for primzy from 192.168.4.222 port 1042 ssh2
    Sep 4 08:04:11 OSUSE sshd[10589]: syslogin_perform_logout: logout() returned an error

    I found some ideas how to solve this but nothing seams to work.
    One of the links was this one: link .
    From this link I found out that I'm missins /etc/ttys file, But creating it did'n make any difference.

    Here are some information on my system:
    OSUSE:/etc # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-------------------------------------+-------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    2 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    3 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    4 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    5 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    6 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    OSUSE:/etc # uname -a
    Linux OSUSE 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686 athlon i386 GNU/Linux
    OSUSE:/etc # rpm -qa | grep openssh
    openssh-5.4p1-8.2.i586
    openssh-askpass-5.4p1-8.2.i586

    I hope someone knows a solution to this problem.

    Regards,
    Primzy

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Cannot get SSH to work

    Don't forget to turn on the ssh daemon and open port #22.

    ssh daemon can be turned on under:
    yast > system > system services (run level) > simple mode and change sshd to YES.

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Cannot get SSH to work

    This may be a silly question, did you start ssh server.
    /etc/init.d/sshd start

    Edit: i am slow in typing, credit goes to oldcpu.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  4. #4

    Default Re: Cannot get SSH to work

    I forget to add this part:
    OSUSE:/etc # netstat -anp|grep ssh
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 11916/sshd
    tcp 0 0 :::22 :::* LISTEN 11916/sshd

    When I try to connect and I give wrong password I get another canse to put in the password. But when I put in the correct password, I get disconected.
    root@Router2:/tmp/home/root# ssh primzy@192.168.xxx.xxx
    Login for primzy@192.168.xxx.xxx
    Password:
    Login for primzy@192.168.xxx.xxx
    Password:
    login: Too many arguments
    Try `login --help' or `login --usage' for more information.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Cannot get SSH to work

    Are you trying to login as root ? If so, do not try to login as root

  6. #6

    Default Re: Cannot get SSH to work

    no, I'm not trying to log in as root

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Cannot get SSH to work

    Quote Originally Posted by primzy82 View Post
    no, I'm not trying to log in as root
    Did you start the daemon as suggested? and open a port in your firewall as suggested?

  8. #8

    Default Re: Cannot get SSH to work

    What do you see if you type the following command on the server :
    service sshd restart
    ?
    Is port 22 blocked by the firewall ?
    What's in the files /etc/hosts.deny and /etc/hosts.allow ?

  9. #9

    Default Re: Cannot get SSH to work

    I disabled firewall. And SSH is answering at another computer, but it doesn't let me pass password.

    OSUSE:/etc # service sshd restart
    Shutting down SSH daemon done
    Starting SSH daemon done

    /etc/hosts.deny
    # /etc/hosts.deny
    # See 'man tcpd' and 'man 5 hosts_access' as well as /etc/hosts.allow
    # for a detailed description.

    http-rman : ALL EXCEPT LOCAL


    In /etc/hosts.allow there are only comments. I have't changed this files.

  10. #10

    Default Re: Cannot get SSH to work

    Did you try as a different user ?
    (the user needs to have an account on the server running the ssh daemon).
    If the user on the client has a file named ~/.ssh/known_hosts, rename this file for testing purpose and try to ssh again to the server.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •