Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: How Do You Disable the System Bell for all Applications?

  1. #1
    Join Date
    Sep 2010
    Location
    Woodstock, GA
    Posts
    13

    Default How Do You Disable the System Bell for all Applications?

    Hey guys, brand new to the forums here, and I wanna say whats up before I posted my first thread!

    Anyways, on to my question. I've searched all over Google and searched the forums and I have not been successful in finding out how to disable the System Bell (Beep) computer-wide.

    It's annoying hearing this extremely loud "BEEP" when I hit backspace one too many times, even when my sound is muted. People look at me like I'm crazy. Even if I try to backspace a non-existent character in my Google Chrome browser, I am struck with a crazy Error Beep.

    Long story short, how do I disable the System-wide "System Bell" ("BEEP") permanently? I'm on OpenSuse 11.3 using the KDE 4.4.4 Desktop.

    Thanks for any responses! If you don't have an answer, feel free to post something!

    PS. Sorry if this thread has a more proper Forum.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How Do You Disable the System Bell for all Applications?

    If you open up the menu / Personnel Settings / General Tab / Look & Feel / Notifications and Select System Bell on the left is the option "Use system bell instead of system notifications" checked? If so, uncheck it and see what you get.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Sep 2010
    Location
    Woodstock, GA
    Posts
    13

    Default Re: How Do You Disable the System Bell for all Applications?

    I looked where you suggested and my System Bell is actually unchecked, so I checked if Chrome was still giving me the Beep and it was. I turned on the System Bell, turned the volume to 0%, Tested it with a positive result, applied the setting and checked Chrome again; still yelled at me. Chrome doesn't even appear in the System Notification's Event Source list.

    So it appears that your solution works for everything except for Applications not listed, or just Chrome lol. Anyone have any other ideas?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,701

    Default Re: How Do You Disable the System Bell for all Applications?

    Anything in the chrome preference/settings screens? I don't use it myself.

  5. #5
    Join Date
    Sep 2010
    Location
    Woodstock, GA
    Posts
    13

    Default Re: How Do You Disable the System Bell for all Applications?

    No I haven't been able to find anything there either. Even when I "Use System Title Bar and Borders" it doesn't properly display the System Title Bar, it doesn't even show it actually. I also just found another System Beep. It happens when I'm in Eclipse IDE and hit Backspace one too many times.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,701

    Default Re: How Do You Disable the System Bell for all Applications?

    Well you could just unplug the internal speaker

    This appears to be in only non-kde programs.

  7. #7
    Join Date
    Sep 2010
    Location
    Woodstock, GA
    Posts
    13

    Default Re: How Do You Disable the System Bell for all Applications?

    Lol I've seen that response to some other threads too. I'd rather not just cuz this problem is occurring on my work laptop. I wonder if there's anything in the BIOS to turn it off...

  8. #8
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: How Do You Disable the System Bell for all Applications?

    Can't you turn down or even mute the volume of the beeps in KMix? Or in YaST's Volume module?

    In KMix look if there is a channel called 'Beep' and if muting it has the desired effect. If it is not there, try the menu 'Settings' > 'Channels' in order to add it.

  9. #9

    Default Re: How Do You Disable the System Bell for all Applications?

    I wrote this script a while ago. I call it "tagueule", which means "shut up" in french:

    Code:
    #! /bin/sh
    
    xset -b 2>/dev/null && exit
    case `uname -s | tr "[:upper:]" "[:lower:]"` in
            openbsd)        /sbin/wsconsctl keyboard.bell.period=0 ;;       
            netbsd)         /sbin/wsconsctl -w keyboard.bell.period=0 ;;
            freebsd)        /usr/sbin/kbdcontrol -b off ;;
            linux)          setterm -blength 0 ;;
    esac
    So when I sit on a new system the first thing I type in a terminal, even before 'uname' is just 'tagueule'

    Under Linux, you can add/uncomment "set bell-style none" in /etc/inputrc for bash and
    write 'xset -b' in your profile or Xsession/xinitrc (for X) . However Gnome tends to ignore that. For Gnome, you should set /apps/metacity/general/audible_bell to false with gconf-editor or gconftool-2.

    Hope it helps (I just hate the system bell ... and bells in general).

  10. #10

    Default Re: How Do You Disable the System Bell for all Applications?

    Quote Originally Posted by Lord_Emsworth View Post
    Can't you turn down or even mute the volume of the beeps in KMix? Or in YaST's Volume module?

    In KMix look if there is a channel called 'Beep' and if muting it has the desired effect. If it is not there, try the menu 'Settings' > 'Channels' in order to add it.
    That worked for me thanks!

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •