Dear 6tr6tr,
I know this thread is old but thought that a solution would be nice to have so here it is
I had the exact same problem and yes apache is cacheing the images !
I would delete the file from the vboxsf then clear the cache from the browser then check in the server directory that the file was not there
then reload the page and it was still there. How i know it was in the server well i was able to download it from the browser to my desktop.
What was mind boggling was that updates to the php html or any other parsed file format worked just fine.
I looked further into the issus and found that apache has a glitch with network mounted folders of NTSF format. Something to the effect that non-parsed elements are sent to the browser and since the file format and permissions on the network drive were incapatible makes apache cache some how. So we want apache to stop processing these elements and force it to read them each time they are requested.
--->add this to the bottom of the file /etc/apache2/apache.conf

#Disable image serving for network mounted drive
EnableSendfile off

Hope that helps