Page 2 of 18 FirstFirst 123412 ... LastLast
Results 11 to 20 of 171

Thread: Nvidia Treiber und Erfahrungen Thread

  1. #11
    Join Date
    Aug 2010
    Location
    Austria
    Posts
    170

    Default Re: Nvidia Treiber und Erfahrungen Thread

    vdpauinfo zeigt eine Fülle an Informationen an:

    Code:
    display: :0.0   screen: 0
    API version: 1
    Information string: NVIDIA VDPAU Driver Shared Library  256.53  Fri Aug 27 21:32:59 PDT 2010
    
    Video surface:
    
    name   width height types
    -------------------------------------------
    420     4096  4096  NV12 YV12 
    422     4096  4096  UYVY YUYV 
    
    Decoder capabilities:
    
    name               level macbs width height
    -------------------------------------------
    MPEG1                 0  8192  2048  2048
    MPEG2_SIMPLE          3  8192  2048  2048
    MPEG2_MAIN            3  8192  2048  2048
    H264_MAIN            41  8192  2048  2048
    H264_HIGH            41  8192  2048  2048
    VC1_SIMPLE            1  8190  2048  2048
    VC1_MAIN              2  8190  2048  2048
    VC1_ADVANCED          4  8190  2048  2048
    MPEG4_PART2_SP        3  8192  2048  2048
    MPEG4_PART2_ASP       5  8192  2048  2048
    DIVX4_QMOBILE         0  8192  2048  2048
    DIVX4_MOBILE          0  8192  2048  2048
    DIVX4_HOME_THEATER    0  8192  2048  2048
    DIVX4_HD_1080P        0  8192  2048  2048
    DIVX5_QMOBILE         0  8192  2048  2048
    DIVX5_MOBILE          0  8192  2048  2048
    DIVX5_HOME_THEATER    0  8192  2048  2048
    DIVX5_HD_1080P        0  8192  2048  2048
    
    Output surface:
    
    name              width height nat types
    ----------------------------------------------------
    B8G8R8A8         16384 16384    y  Y8U8V8A8 V8U8Y8A8 
    R10G10B10A2      16384 16384    y  Y8U8V8A8 V8U8Y8A8 
    
    Bitmap surface:
    
    name              width height
    ------------------------------
    B8G8R8A8         16384 16384
    R8G8B8A8         16384 16384
    R10G10B10A2      16384 16384
    B10G10R10A2      16384 16384
    A8               16384 16384
    
    Video mixer:
    
    feature name                    sup
    ------------------------------------
    DEINTERLACE_TEMPORAL             y
    DEINTERLACE_TEMPORAL_SPATIAL     y
    INVERSE_TELECINE                 y
    NOISE_REDUCTION                  y
    SHARPNESS                        y
    LUMA_KEY                         y
    HIGH QUALITY SCALING - L1        y
    HIGH QUALITY SCALING - L2        -
    HIGH QUALITY SCALING - L3        -
    HIGH QUALITY SCALING - L4        -
    HIGH QUALITY SCALING - L5        -
    HIGH QUALITY SCALING - L6        -
    HIGH QUALITY SCALING - L7        -
    HIGH QUALITY SCALING - L8        -
    HIGH QUALITY SCALING - L9        -
    
    parameter name                  sup      min      max
    -----------------------------------------------------
    VIDEO_SURFACE_WIDTH              y         1     4096
    VIDEO_SURFACE_HEIGHT             y         1     4096
    CHROMA_TYPE                      y  
    LAYERS                           y         0        4
    
    attribute name                  sup      min      max
    -----------------------------------------------------
    BACKGROUND_COLOR                 y  
    CSC_MATRIX                       y  
    NOISE_REDUCTION_LEVEL            y      0.00     1.00
    SHARPNESS_LEVEL                  y     -1.00     1.00
    LUMA_KEY_MIN_LUMA                y  
    LUMA_KEY_MAX_LUMA                y
    Schaut für mich soweit normal aus...
    Vielleicht mag VDPAU den x264 Codec im mkv Container nicht.


    Mal schaun was das VDPAU testing tool für Ergebnisse liefert.

  2. #12
    Join Date
    Aug 2010
    Location
    Austria
    Posts
    170

    Default Re: Nvidia Treiber und Erfahrungen Thread

    Das VDPAU testing tool läuft bei mir extrem langsam, der Mauszeiger lässt sich während den Tests zeitweise nicht mehr bewegen.
    Schon beim 1. Test (Basketball Spiel) hängt die Maus, beim Swiss HD Test musste ich sogar in tty1 wechseln und den qvdpautest Prozess killen, da nichts mehr reagiert hat...

  3. #13
    Join Date
    Jun 2008
    Location
    Munich
    Posts
    355

    Default Re: Nvidia Treiber und Erfahrungen Thread

    Compositing ausgeschaltet? Hatte ich beim ersten Lauf auch
    my rig: intel i7 6700, 16GB RAM, ASUS Z170-K, NVIDIA Geforce 1060GTX, Opensuse 42.3, Windows 10 1803

  4. #14
    Join Date
    Aug 2010
    Location
    Austria
    Posts
    170

    Default Re: Nvidia Treiber und Erfahrungen Thread

    komisch... nach dem aus- und wieder einschalten der KWin Effekte läuft der Benchmark fehlerfrei.

    Ergebnis:

    Code:
    qvdpautest 0.5.1
    AMD Phenom(tm) II X6 1055T Processor
    NVIDIA GPU GeForce GTX 460 (GF104) at PCI:1:0:0 (GPU-0)
    
    VDPAU API version : 1
    VDPAU implementation : NVIDIA VDPAU Driver Shared Library  256.53  Fri Aug 27 21:32:59 PDT 2010
    
    SURFACE GET BITS: 1398.24 M/s
    SURFACE PUT BITS: 1258.51 M/s
    
    MPEG DECODING (1920x1080): 102 frames/s
    MPEG DECODING (1280x720): 229 frames/s
    H264 DECODING (1920x1080): 65 frames/s
    H264 DECODING (1280x720): 135 frames/s
    VC1 DECODING (1440x1080): 83 frames/s
    MPEG4 DECODING (1920x1080): 71 frames/s
    
    MIXER WEAVE (1920x1080): 254 frames/s
    MIXER BOB (1920x1080): 355 fields/s
    MIXER TEMPORAL (1920x1080): 166 fields/s
    MIXER TEMPORAL + IVTC (1920x1080): 144 fields/s
    MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 208 fields/s
    MIXER TEMPORAL_SPATIAL (1920x1080): 86 fields/s
    MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 78 fields/s
    MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 96 fields/s
    MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 243 fields/s
    MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 159 fields/s
    
    MULTITHREADED MPEG DECODING (1920x1080): 106 frames/s
    MULTITHREADED MIXER TEMPORAL (1920x1080): 159 fields/s
    Der SMPlayer will trotzdem nicht so Richtig. Xvid Filme in SD-Auflösung laufen, außer im Vollbild hängt es wieder.
    Manche x264 Filme laufen, andere sind nur Schwarz, Vollbild hängt bei allen.

    Aber Gut, die xv Ausgabe genügt mir, da alles flüssig läuft.

    Vielen Dank für die Tipps!

  5. #15
    Join Date
    Jun 2008
    Location
    Munich
    Posts
    355

    Default Re: Nvidia Treiber und Erfahrungen Thread

    Das klingt nach ein paar Inkompatibilitäten. Wichtig ist nur zu wissen, dass es grundsätzlich bei Dir läuft (was auch der Fall ist )
    my rig: intel i7 6700, 16GB RAM, ASUS Z170-K, NVIDIA Geforce 1060GTX, Opensuse 42.3, Windows 10 1803

  6. #16
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Nvidia Treiber und Erfahrungen Thread

    [tschuldigung für die englischen ausdrücke; bei mir läuft alles auf engl. und ich weiß nicht, wie die deutsche übersetzung genau aussieht.]

    vor kurzem habe ich etwas herausgefunden, was für andere vermutlich selbstverständlich ist: wenn man in nVidia-settings mehrere monitore als "separate X screen" konfiguriert, multipliziert das den CPU verbrauch von Xorg. ist ja klar, "separate X..." bedeutet vermutlich, daß für jeden monitor ein eigener X-server läuft.

    seitdem ich meine beiden monitore auf "twin view" umgestellt habe, sind die CPU werte durchweg im 'grünen bereich'.

    und nochwas: als ich noch mit "separate X..." und eingeschalteter "panoramaview" lief, konnte ich keine "window effects" einschalten. mit hilfe von google fand ich heraus, daß diese mit "twin view" funktionieren.

    --
    phani.


    PS: was ist eigentlich der unterschied, oder der nutzen, für jeden monitor einen eigenen X-server zu starten? für mich sieht alles genauso aus, mit "twin view" oder "separate X..." + "panoramaview". kann man die X-server dann unterschiedlich konfigurieren um sie in SSH mit X-forwardng oder virtuellen maschinen zu verwenden, oder was?

  7. #17
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Nvidia Treiber und Erfahrungen Thread

    on the openSUSE mailing list (Re: [opensuse] Re: kernel 2.6.36 speeds things up) Philipp Thomas posted the patch below, which makes a small change to one file in the nvidia driver source (the ~.run file, extracted with "sh ~.run -x").

    for me---openSUSE 11.3 (x86_64) Kernel: 2.6.36-rc3-10-default, KDE Development Platform: 4.5.1 (KDE 4.5.1)---this patch works great. the patched driver compiles & works well--until now; have been using it only for a few hours.

    Code:
    Re: [opensuse] Re: kernel 2.6.36 speeds things up
    From: Philipp Thomas <pth@xxxxxxx>
    Date: Tue, 7 Sep 2010 14:11:13 +0200
    Message-id: <20100907121113.GC6529@xxxxxxxxxxxxxxxx>
    * phanisvara das (phani00@xxxxxxxxx) [20100905 20:50]:
    
    > didn't work for me. "kernelmodule could not be built," or similar. in the log 
    > file, it suggests doing things to the kernel source configuration. 
    
    The patch I used is attached.
    
    Philipp
    
    --- kernel/nv.c.original 2010-09-07 13:55:25.770456446 +0200
    +++ kernel/nv.c 2010-09-07 14:08:34.681351694 +0200
    @@ -423,7 +423,9 @@ static struct pci_driver nv_pci_driver =
    static struct file_operations nv_fops = {
    .owner = THIS_MODULE,
    .poll = nv_kern_poll,
    +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,36)
    .ioctl = nv_kern_ioctl,
    +#endif
    #if defined(HAVE_UNLOCKED_IOCTL)
    .unlocked_ioctl = nv_kern_unlocked_ioctl,
    #endif
    --
    phani.

  8. #18
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Nvidia Treiber und Erfahrungen Thread

    ach du käse, jetzt habe ich hier auf englisch geschrieben. hier ist die deutsche übersetzung des oberen teils; die untere hälfte ist ja ein patch:

    auf der openSUSE mailing-list (?) ist ein beitrag von Philipp Thomas (Re: [opensuse] Re: kernel 2.6.36 speeds things up), dem er ein patch für den nvidia-driver 256.53 beifügte. damit kann man diesen treiber auch mit kernel 2.6.36 kompilieren und benutzen.

    (um das patch anzuwenden, muß die ~.run datei extrahiert werden: "sh ~.run -x". dann im verzeichnis kernel/ patchen.)

    für mich funktioniert das ausgezeichnet--allerdings erst seit ein paar stunden. meine konfiguration:

    openSUSE 11.3 (x86_64), Kernel: 2.6.36-rc3-10-default, KDE 4.5.1

    --
    phani.

  9. #19
    Join Date
    Aug 2010
    Location
    Austria
    Posts
    170

    Default AW: Re: Nvidia Treiber und Erfahrungen Thread

    Ich würde sehr gerne den neuen Kernel 2.6.36-rc3 oder 2.6.35.4 testen (u.a. auch wegen meiner AMD X6 CPU).

    Ich hatte letzte Woche testweise das Index of /repositories/Kernel:/HEAD/openSUSE_11.3 Repo eingebunden und den Kernel mit einem zypper dup aktualisiert.

    Der neue Kernel wollte leider nicht starten, aber zum Glück war der 2.6.34 Kernel noch vorhanden.
    (Ich werde in Zukunft Kernel-Updates in einer VM testen... Sicher ist Sicher)


    Welches Kernel Repo ist für openSUSE 11.3 und Kernel 2.6.35.4 oder 2.6.36-rc3 empfehlenswert?
    Index of /repositories/Kernel:

    Gibt es eine empfohlene/sichere Vorgehensweise für die Installation?

  10. #20
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: AW: Re: Nvidia Treiber und Erfahrungen Thread

    ich habe das gleiche repo verwendet.

    würde das nicht mit "zypper dup" machen. je nachdem welche repos du eingebunden hast, können da viele unangenehme sachen passieren--falls du nicht den "zypper dup" befehl mit --from oder --repo weiter qualifizierst. ich finde es am einfachsten, yast dafür zu verwenden, doch vorsicht: auf diese weise wird der vorige kernel vermutlich gelöscht. es gibt eine möglichkeit, .rpm pakete zu verwenden und das zu verhindern, habe ich aber noch nicht genau nachgelesen. war immer recht zuversichtlich, daß der neue kernel funktionieren würde--und hab' natürlich noch eine andere laufende oS installation auf einem anderen HDD.

    in yast kannst du sehr schön auswählen, welche paket-versionen du installieren willst, und die auswahl auch wieder rückgängig machen, wenn fehler oder zu viele warnungen auftauchen. suche einfach nach deinem kernel (kernel-desktop oder -default, nehme ich an), dann sieh unten unter "versionen" nach und wähle die neueste aus, wenn du das willst. oben dann das kernel paket auf "update" stellen (weiß nicht, wie das auf deutsch heißt), und dann sollten die anderen pakete automatisch ausgewählt werden. wenn probleme auftauchen, sind da meistens lösungsvorschläge dabei; wenn einer davon funktioniert, fein, wenn nicht, dann die sache abblasen & nochmal von vorne anfangen.

    das hat für mich einige male gut funktioniert. vermutlich solltest du aber auf sachkundigeren rat als meinen warten...

    --
    phani.

Page 2 of 18 FirstFirst 123412 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •