Results 1 to 10 of 10

Thread: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

  1. #1

    Default Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    I have a fresh OpenSuSE 11.3 install on an Acer Aspire 5740-6491. I installed the latest qt-sdk package, and qtcreator and qmake seem to work fine. Designer does not work when I run the "designer" command. I get an error saying:

    kniles@ClownCar:~> designer
    designer: symbol lookup error: /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so: undefined symbol: _ZN6Phonon12PulseSupport11getInstanceEv
    kniles@ClownCar:~>

    When I run this command and get this error nothing happens. The program does not open or hang. It simply exits. Does anyone else have this problem or know how I might be able to work around it. We have Qt-4.6.3 installed on OpenSuSE 11.2 and designer works fine. Any advice is welcome. I am considering reporting this as a kde bug. Thank you in advance for any help.

    -Kisron

  2. #2

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    starts OK here : libqt4-devel-4.6.3-1.5.x86_64 / openSUSE 11.3

  3. #3

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    Do you have phonon-backend-xine-4.4.2-1.6.x86_64 installed ? (as I do and designer doesn't complain)

  4. #4

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    In Yast it shows that I have all phonon packages installed including phonon-backend-xine-4.4.2-1.6.x86+64. So I don't know what to try.

  5. #5

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    There has been report of this same issue on the Qt bug page at

    [#QTBUG-7207] qmediaplayer demo fails to launch - Qt Bug Tracker

    In reading the other day, Qt discarded this bug as a kde issue since it is a kde4 lib issue. This seems strange to me and I don't understand why this could be happening. Thanks again.

  6. #6

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    I'm afraid I cannot help further.
    All I can tell is that I can start QT4 designer (/usr/bin/designer) either in KDE or Gnome. I don't know what I have installed that you dont' have.
    I don't know what is qmediaplayer demo. I can start qtdemo and launch some demos. Some others are apparently not built in.
    If it helps :

    rpm -qa | grep qt | sort

    google-gadgets-qt-0.11.2-3.1.x86_64
    libavahi-qt4-1-0.6.25-14.1.x86_64
    libavahi-qt4-devel-0.6.25-14.1.x86_64
    libpackagekit-qt14-0.6.3-5.4.x86_64
    libpolkit-qt-1-0-0.95.1-5.2.x86_64
    libpolkit-qt-1-devel-0.95.1-5.2.x86_64
    libpoppler-qt4-3-0.12.3-4.1.x86_64
    libpoppler-qt4-devel-0.12.3-4.1.x86_64
    libqt4-32bit-4.6.3-1.5.x86_64
    libqt4-4.6.3-1.5.x86_64
    libqt4-devel-4.6.3-1.5.x86_64
    libqt4-devel-doc-4.6.3-1.4.x86_64
    libqt4-devel-doc-data-4.6.3-1.3.noarch
    libqt4-qt3support-32bit-4.6.3-1.5.x86_64
    libqt4-qt3support-4.6.3-1.5.x86_64
    libqt4-sql-32bit-4.6.3-1.5.x86_64
    libqt4-sql-4.6.3-1.5.x86_64
    libqt4-sql-mysql-32bit-4.6.3-1.3.x86_64
    libqt4-sql-mysql-4.6.3-1.3.x86_64
    libqt4-sql-sqlite-32bit-4.6.3-1.5.x86_64
    libqt4-sql-sqlite-4.6.3-1.5.x86_64
    libqt4-x11-32bit-4.6.3-1.5.x86_64
    libqt4-x11-4.6.3-1.5.x86_64
    libsvnqt6-1.5.3-1.20.x86_64
    patterns-openSUSE-devel_qt4-11.3-22.1.x86_64
    pinentry-qt4-0.8.0-3.2.x86_64
    python-qt4-4.7.3-1.9.x86_64
    qt3-3.3.8b-103.1.x86_64
    qt4-qtscript-0.1.0-7.1.x86_64
    vlc-qt-1.1.4-1.pm.1.1.x86_64
    yast2-control-center-qt-2.19.1-3.2.x86_64
    yast2-qt-2.19.1-1.9.x86_64
    yast2-qt-graph-2.19.0-1.12.x86_64
    yast2-qt-pkg-2.19.2-1.10.x86_64

  7. #7

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    Thank you for the package information. I am still troubleshooting the problem. I believe there could be a mismatch of repositories even though I couldn't tell you why. The package repositories initialized themselves when I ran yast for the first time and they look like the same repositories that OpenSuSE always uses. The same person who posted the qmediaplayer issue also reported the same error when running designer. It is a second post on that same bug page. I will post my findings when I figure it out. Thanks again for the help.
    Last edited by kizbot777; 01-Sep-2010 at 09:44. Reason: add more information

  8. #8

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    I checked my installation media and the checksum is fine. i reinstalled OpenSuSE 11.3 and included all development packages upon install. I then installed qt-4.6.3 for x86_64 Linux that was downloaded directly from the Qt Nokia website. There is no possible way that I mismatched repositories when I installed all of the kde, phonon, and qt libraries from the OpenSuSE 11.3 DVD. The only outside program I ran was the Qt-4.6.3 binary which is provided by Qt. There is a problem somewhere here and nobody seems to think it exists when it clearly does. I copied over /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so from an OpenSuSE 11.2 install to my 11.3 install and I no longer receive this error. Somehow the phonon_xine.so that is being installed by default by the package manager or whoever installs that library is wrong. This was the default phonon_xine.so that was installed by OpenSuSE 11.3

    Who can help me locate a permanent fix for this? I have already reported it to the kde bug site.

    Thanks for your time.

  9. #9

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    KDE developers are telling me this is a Qt issue and Qt is claiming it is a kde issue. Does anyone know what OpenSuSE repository has a Qt installer? I have been getting it directly from Qt and KDE folks say I should be pulling it from a repository. What repository might that be? Thanks.

  10. #10

    Default Re: Designer in Qt 4.6.3 won't start in OpenSuSE 11.3

    hmm ... I don't know. I had OpenSUSE:KDE:Community enabled for a while (but I don't remember for what). I disabled it yesterday because it seemed to be done as I got packagekit errors. That would be the only repo I can think of.
    Here's the md5 checksum of my phonon_xine.so :
    2d6d934551c6815337607193d32b5362
    I didn't borrow that one from 11.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •