Results 1 to 2 of 2

Thread: Help rolling KDE back to 11.3 distributed version

  1. #1

    Default Help rolling KDE back to 11.3 distributed version

    Hi all,

    Am running Opensuse 11.3 64-bit - I was trying to get digikam to work (a few weeks after installing 11.3) and it wouldn't - in looking around I saw references to upgrading kdcraw, kexiv etc. etc. which I did and then upgraded to digikam 1.4 - but still got some problem about marble widget. Then did the KDE 4.5 full upgrade - however, this has resulting in Gwenview not working, Dolphin crashes when previewing images and is slow and videos now run a bit funny...

    I'd like to get right back to the distributed version of KDE and these apps for 11.3 to have a proper working system - but I'm not quite sure how to do a rollback like this - I've looked around for info but can't find anything that gives me detail on what to do.

    Any help would be greatly appreciated...

    Thanks,

    John

  2. #2
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Help rolling KDE back to 11.3 distributed version

    Quote Originally Posted by funkymuppet View Post
    Hi all,

    Am running Opensuse 11.3 64-bit - I was trying to get digikam to work (a few weeks after installing 11.3) and it wouldn't - in looking around I saw references to upgrading kdcraw, kexiv etc. etc. which I did and then upgraded to digikam 1.4 - but still got some problem about marble widget. Then did the KDE 4.5 full upgrade - however, this has resulting in Gwenview not working, Dolphin crashes when previewing images and is slow and videos now run a bit funny...

    I'd like to get right back to the distributed version of KDE and these apps for 11.3 to have a proper working system - but I'm not quite sure how to do a rollback like this - I've looked around for info but can't find anything that gives me detail on what to do.

    Any help would be greatly appreciated...

    Thanks,

    John
    In principle it is fairly easy. You just would need to disable/remove the KDE4-Factoy repositories, and then switch system packages back to the 11.3-OSS repositories.


    In practice though, you will likely have more repositories enabled than just those KDE4-Factory and the default 11.3-OSS ones. Packman for instance, or Mozilla OBS.

    What you would need to do in such a situation would be to first disable/remove the KDE4-Factoy repositories. Then switch system packages first to the 11.3-OSS repositories. Then to Packman (for Kaffeine, K3B etc). Then to Mozilla (for FF 3.6.8.). In that order. And only then accept and install.

    If you have yet more repositories, it might be a little bit more complicated yet, but in principle analogous.



    As an alternative to the KDE4 packages from the 11.3-OSS repositories, there are the KDE4-Stable repositories, which you could use instead:
    KDE repositories - openSUSE
    You would need to disable/remove the KDE4-Factory repositories, and instead enable the KDE4-Stable repositories. Then switch system packages to those repositories. (And afterwards, back to Packman.)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •