Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: RaLink RT2860 not working out of thebox in opensuse 11.3

  1. #1

    Question RaLink RT2860 not working out of thebox in opensuse 11.3

    Hi,

    Desktop PC with Trendnet TEW-642 PCI wireless N adapter (Ralink 2860 STA driver). Running openSUSE 11.3 X8_64 with KDE 4.4.4. Software Management and KNetwork Manager both identified rt2860STA as installed. However, KNetwork Manager's authentication window keeps popping up every few seconds and I cannot get wireless.

    1) uname -r:

    Code:
    2.6.34-12-desktop
    2) /sbin/lspci -nnk:

    Code:
    03:06.0 Network controller [0280]: RaLink RT2800 802.11n PCI [1814:0601]
            Subsystem: RaLink Device [1814:2860]
            Kernel driver in use: rt2860
    3) dmesg:

    Code:
    [    6.270671] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
    [    6.275290]   alloc irq_desc for 21 on node 0
    [    6.275294]   alloc kstat_irqs on node 0
    [    6.275348] rt2860 0000:03:06.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
     <snip>
    
    [   59.681444] rt2860 0000:03:06.0: firmware: requesting rt2860.bin
    [   59.691653] RX DESC ffff880037b3b000  size = 2048
    [   59.692519] <-- RTMPAllocTxRxRingMemory, Status=0
    [   59.695622] 1. Phy Mode = 0
    [   59.695627] 2. Phy Mode = 0
    [   59.716180] RTMPSetPhyMode: channel is out of range, use first channel=1 
    [   59.721324] 3. Phy Mode = 0
    [   59.724113] MCS Set = 00 00 00 00 00
    [   59.725742] <==== rt28xx_init, Status=0
    I have downloaded and extracted the latest rt2860.bin file from the Ralinktech website to Desktop but even as root I cannot copy it to /lib/firmware or replace the existing rt2860.bin file in /lib/firmware.

    Can you help me? Thanks a lot for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    On 08/10/2010 04:36 PM, taytong888 wrote:
    >
    > Hi,
    >
    > Desktop PC with Trendnet TEW-642 PCI wireless N adapter (Ralink 2860
    > STA driver). Running openSUSE 11.3 X8_64 with KDE 4.4.4. Software
    > Management and KNetwork Manager both identified rt2860STA as installed.
    > However, KNetwork Manager's authentication window keeps popping up every
    > few seconds and I cannot get wireless.
    >
    > 1) uname -r:
    >
    >
    > Code:
    > --------------------
    > 2.6.34-12-desktop
    > --------------------
    >
    >
    > 2) /sbin/lspci -nnk:
    >
    >
    > Code:
    > --------------------
    > 03:06.0 Network controller [0280]: RaLink RT2800 802.11n PCI [1814:0601]
    > Subsystem: RaLink Device [1814:2860]
    > Kernel driver in use: rt2860
    >
    > --------------------
    >
    >
    > 3) dmesg:
    >
    >
    > Code:
    > --------------------
    > [ 6.270671] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
    > [ 6.275290] alloc irq_desc for 21 on node 0
    > [ 6.275294] alloc kstat_irqs on node 0
    > [ 6.275348] rt2860 0000:03:06.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
    > <snip>
    >
    > [ 59.681444] rt2860 0000:03:06.0: *firmware: requesting rt2860.bin*
    > [ 59.691653] RX DESC ffff880037b3b000 size = 2048
    > [ 59.692519] <-- RTMPAllocTxRxRingMemory, Status=0
    > [ 59.695622] 1. Phy Mode = 0
    > [ 59.695627] 2. Phy Mode = 0
    > [ 59.716180] RTMPSetPhyMode: channel is out of range, use first channel=1
    > [ 59.721324] 3. Phy Mode = 0
    > [ 59.724113] MCS Set = 00 00 00 00 00
    > [ 59.725742] <==== rt28xx_init, Status=0
    >
    >
    > --------------------
    >
    >
    > I have downloaded and extracted the latest rt2860.bin file from the
    > Ralinktech website to Desktop but even as root I cannot copy it to
    > /lib/firmware or replace the existing rt2860.bin file in
    > /lib/firmware.
    >
    > Can you help me? Thanks a lot for your help.


    Please post the output from

    Code:
    ls -l /lib/firmware/rt2860.bin
    I have no idea why root cannot modify that file.

  3. #3

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    Quote Originally Posted by lwfinger View Post
    On 08/10/2010 04:36 PM, taytong888 wrote:
    >
    > Hi,
    >
    > Desktop PC with Trendnet TEW-642 PCI wireless N adapter (Ralink 2860
    > STA driver). Running openSUSE 11.3 X8_64 with KDE 4.4.4. Software
    > Management and KNetwork Manager both identified rt2860STA as installed.
    > However, KNetwork Manager's authentication window keeps popping up every
    > few seconds and I cannot get wireless.
    >
    > 1) uname -r:
    >
    >
    > Code:
    > --------------------
    > 2.6.34-12-desktop
    > --------------------
    >
    >
    > 2) /sbin/lspci -nnk:
    >
    >
    > Code:
    > --------------------
    > 03:06.0 Network controller [0280]: RaLink RT2800 802.11n PCI [1814:0601]
    > Subsystem: RaLink Device [1814:2860]
    > Kernel driver in use: rt2860
    >
    > --------------------
    >
    >
    > 3) dmesg:
    >
    >
    > Code:
    > --------------------
    > [ 6.270671] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
    > [ 6.275290] alloc irq_desc for 21 on node 0
    > [ 6.275294] alloc kstat_irqs on node 0
    > [ 6.275348] rt2860 0000:03:06.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
    > <snip>
    >
    > [ 59.681444] rt2860 0000:03:06.0: *firmware: requesting rt2860.bin*
    > [ 59.691653] RX DESC ffff880037b3b000 size = 2048
    > [ 59.692519] <-- RTMPAllocTxRxRingMemory, Status=0
    > [ 59.695622] 1. Phy Mode = 0
    > [ 59.695627] 2. Phy Mode = 0
    > [ 59.716180] RTMPSetPhyMode: channel is out of range, use first channel=1
    > [ 59.721324] 3. Phy Mode = 0
    > [ 59.724113] MCS Set = 00 00 00 00 00
    > [ 59.725742] <==== rt28xx_init, Status=0
    >
    >
    > --------------------
    >
    >
    > I have downloaded and extracted the latest rt2860.bin file from the
    > Ralinktech website to Desktop but even as root I cannot copy it to
    > /lib/firmware or replace the existing rt2860.bin file in
    > /lib/firmware.
    >
    > Can you help me? Thanks a lot for your help.


    Please post the output from

    Code:
    ls -l /lib/firmware/rt2860.bin
    I have no idea why root cannot modify that file.
    Hi Larry,

    ls -l /lib/firmware/rt2860.bin gives:
    Code:
    -rw-r--r-- 1 root root 8192 2010-06-16 09:07 /lib/firmware/rt2860.bin
    This is the existing rt2860.bin file

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    On 08/10/2010 07:36 PM, taytong888 wrote:
    > --------------------
    > -rw-r--r-- 1 root root 8192 2010-06-16 09:07 /lib/firmware/rt2860.bin
    >
    > --------------------
    >
    >
    > This is the existing rt2860.bin file


    This file can be overwritten by root. Try it again.

  5. #5

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    Hi Larry,

    I still cannot copy the latest driver to /lib/firmware/rt2860.bin. However, when I clicked to the left of rt2860 in Software Management I was able to download and update to the latest version. KNetworkManager now shows wlan0 as the interface for wirelessN, etc.

    1) /sbin/lspci -nnk:

    Code:
    03:06.0 Network controller [0280]: RaLink RT2800 802.11n PCI [1814:0601]
            Subsystem: RaLink Device [1814:2860]
            Kernel driver in use: rt2860
    2)sudo /usr/sbin/iwlist scan:

    Code:
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    eth1      Interface doesn't support scanning.
    
    wlan0     Scan completed :
              Cell 01 - Address: 00:1F:33:B4:E1:D8
                        Protocol:802.11b/g/n
                        ESSID:"snynhatrang"
                        Mode:Managed
                        Channel:1
                        Quality:100/100  Signal level:-19 dBm  Noise level:-87 dBm
                        Encryption key:on
                        Bit Rates:130 Mb/s
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
    3) dmesg:
    Code:
       21.070299] rt2860 0000:03:06.0: firmware: requesting rt2860.bin
    [   21.080354] RX DESC ffff880005816000  size = 2048
    [   21.081740] <-- RTMPAllocTxRxRingMemory, Status=0
    [   21.084816] 1. Phy Mode = 0
    [   21.084821] 2. Phy Mode = 0
    [   21.107540] RTMPSetPhyMode: channel is out of range, use first channel=1 
    [   21.112551] 3. Phy Mode = 0
    [   21.115350] MCS Set = 00 00 00 00 00
    [   21.116977] <==== rt28xx_init, Status=0
    Still no wireless connection!

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    If the device can scan, then it is only a configuration problem.


  7. #7

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    Hi Larry,

    KNetworkManager icon says: "configuring interface". Left-clicking it shows my SSID, a green checkmark and a full bar.

    Clicking on the SSID, I saw the following:

    Type: 802.11n wireless
    Interface: wlan0
    Hardware address: xxxxx
    Driver: rt2860
    Status: Preparing to connect
    IP address: <blank>
    Name servers: <blank>
    Domain: <blank>

    So I went backto ifup and added IP address, genmask or subnet mask and default gateway to the Routing Table and rebooted without the CAT5 cable. End result: still no IP address, etc. as before and no wireless connection!

  8. #8

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    Hi,

    I decided to compile the firmware from source.

    1) After downloading and extracting the latest file 2010_07_16_RT2860_Linux_STA_v2.4.0.0 from Ralink corp. | Home site, initially I was not able to copy or move NEW rt2860.bin to /lib/firmware because the EXISTING rt2860.bin file there has the following permission:

    Code:
    ls -l /lib/firmware/rt2860.bin 
    -rw-r--r-- 1 root root 8192 2010-06-16 09:07 /lib/firmware/rt2860.bin
    Since the existing file only has read and write permissions, I had to give it execution permission (as root):
    Code:
    ls -l /lib/firmware/rt2860.bin 
    -rw-r--r-- 1 root root 8192 2010-06-16 09:07 /lib/firmware/rt2860.bin
    Having found out that the NEW rt2860.bin file has myself as owner and users as group. I then changed owner and group both to root, and added execution permission to this new file:

    Code:
    chown root:root /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/common/rt2860.bin
    
    chmod g+x /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/common/rt2860.bin
    After the above steps, I was able to copy the NEW rt2860.bin file to /lib/firmware, thus replacing the existing file there.

    2) Next, I went to the directory 2010_07_16_RT2860_Linux_STA_v2.4.0.0 , accessed its os/linux subfolder, and opened the config.mk file in order to enable support (y) for both WPA_SUPPLICANTS:

    Code:
    # Support Wpa_Supplicant
    HAS_WPA_SUPPLICANT=y
    
    # Support Native WpaSupplicant for Network Maganger
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    3) Compiling and installing the driver:

    Code:
    #sudo su
    # make
    Code:
    make -C tools
    make[1]: Entering directory `/home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/tools'
    gcc -g bin2h.c -o bin2h
    make[1]: Leaving directory `/home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/tools'
    /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/tools/bin2h
    cp -f os/linux/Makefile.6 /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/Makefile
    make -C /lib/modules/2.6.34-12-desktop/build SUBDIRS=/home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux modules
    make[1]: Entering directory `/usr/src/linux-2.6.34-12-obj/x86_64/desktop'
    make -C ../../../linux-2.6.34-12 O=/usr/src/linux-2.6.34-12-obj/x86_64/desktop/. modules
      CC [M]  /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/../../common/crypt_md5.o
      
    <snip>
    
      Building modules, stage 2.
      MODPOST 1 modules
      CC      /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/rt2860sta.mod.o
      LD [M]  /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/rt2860sta.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.34-12-obj/x86_64/desktop'
    4) #make install:

    Code:
    make -C /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux -f Makefile.6 install
    mkdir: cannot create directory `/etc/Wireless': File exists
    make[1]: Entering directory `/home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux'
    rm -rf /etc/Wireless/RT2860STA
    mkdir /etc/Wireless/RT2860STA
    cp /home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/RT2860STA.dat /etc/Wireless/RT2860STA/.
    install -d /lib/modules/2.6.34-12-desktop/kernel/drivers/net/wireless/
    install -m 644 -c rt2860sta.ko /lib/modules/2.6.34-12-desktop/kernel/drivers/net/wireless/
    /sbin/depmod -a 2.6.34-12-desktop
    make[1]: Leaving directory `/home/tt888/Desktop/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux'
    5) modprobe the drivermodule "rt2860sta":
    Code:
    # modprobe rt2860sta
    6) Stopped being root and verified that the module was probed correctly by checking the output of lsmod:

    Code:
    exit
    lsmod | grep rt2860sta
    Code:
    rt2860sta             578113  1 
    crc_ccitt               1707  1 rt2860sta
    7) To make sure ra0 is up and running:
    Code:
    iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      no wireless extensions.
    
    wlan0     Ralink STA  ESSID:""  Nickname:"RT2860STA"
              Mode:Auto  Frequency=2.412 GHz  Access Point: 00:1F:33:B4:E1:D8   
              Bit Rate=1 Mb/s   
              RTS thr:off   Fragment thr:off
              Encryption key:off
              Link Quality=10/100  Signal level:-21 dBm  Noise level:-87 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Note that I will need to change some wireless configurations in ifup before I am done.

    8) Add the module to /etc/modules file to make sure it is loaded when reboot:

    Code:
    sudo echo rt2860sta >> /etc/modules
    Stay tuned. Sorry for the long post but I felt this is necessary in case I need to go back or if this helps some one. I have spent lots of time reviewing different and random posts regarding RT2860 Linux driver, but one of the few valuable HOWTO document is "Setting up RT61 or RT2500Wireless Cards" by Kamatsu in http://susewiki.org.

  9. #9

    Default Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    Hello everyone,

    a y est ! a marche !
    There you go! It's working!


    After reconfiguring with ifup and booting without the CAT5 cable, I saw the red heart icon next to my SSID and connection strength symbols. I saw LOVE! I have wireless connection!


    PROBLEM SOLVED!
    Last edited by taytong888; 12-Aug-2010 at 00:26. Reason: Add info

  10. #10

    Talking Re: RaLink RT2860 not working out of thebox in opensuse 11.3

    Quote Originally Posted by taytong888 View Post
    Hello everyone,

    a y est ! a marche !
    There you go! It's working!


    After reconfiguring with ifup and booting without the CAT5 cable, I saw the red heart icon next to my SSID and connection strength symbols. I saw LOVE! I have wireless connection!


    PROBLEM SOLVED!
    Update:
    Code:
    # sudo /usr/sbin/iwlist scan
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    eth1      Interface doesn't support scanning.
    
    ra0       Scan completed :
              Cell 01 - Address: 00:1F:33:B4:E1:D8
                        Protocol:802.11b/g/n
                        ESSID:"snynhatrang"
                        Mode:Managed
                        Frequency:2.412 GHz (Channel 1)
                        Quality:100/100  Signal level:-23 dBm  Noise level:-92 dBm
                        Encryption key:on
                        Bit Rates:130 Mb/s
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
              Cell 02 - Address: 00:14:D1:5A:95:29
                        Protocol:802.11g/n
                        ESSID:"dlink"
                        Mode:Managed
                        Frequency:2.437 GHz (Channel 6)
                        Quality:24/100  Signal level:-80 dBm  Noise level:-75 dBm
                        Encryption key:on
                        Bit Rates:54 Mb/s
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •