Results 1 to 4 of 4

Thread: System stalls at Restart

  1. #1

    Default System stalls at Restart

    I have 11.3 Gnome installed on a Dell Optiplex380, and I can fully shutdown, but the system hangs when I try to Restart. The Geeko logo is there and the white bar retracts, once it hits all gray it stays there until I force a hard-shutdown holding the computer power-button.
    What steps can I take to fix this or start troubleshooting?
    Thank you!

  2. #2
    Carlos E. R. NNTP User

    Default Re: System stalls at Restart

    On 2010-09-01 02:06, kahu wrote:
    >
    > I have 11.3 Gnome installed on a Dell Optiplex380, and I can fully
    > shutdown, but the system hangs when I try to Restart. The Geeko logo is
    > there and the white bar retracts, once it hits all gray it stays there
    > until I force a hard-shutdown holding the computer power-button.
    > What steps can I take to fix this or start troubleshooting?
    > Thank you!


    Switch to verbose boot (and halt). This way you should be able to see at what message it stops.

    Open a terminal (xterm, konsole, gnome-terminal). Write "su -" to become root. Then type:

    mcedit /boot/grub/menu.lst

    This is an editor in text mode, it has a menu and is easy to use. If you prefer a graphical one,
    well... it is not a bad idea to know some text mode tools, so I will not tell how to use a graphical
    one :-P

    Ok, find the line where the kernel is loaded. It will be something _similar_ to this:

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,2)
    kernel /vmlinuz-2.6.31.12-0.2-desktop root=/dev/sda9 resume=/dev/disk/by-label/b_swap
    splash=quiet quiet showopts vga=0x31a
    initrd /initrd-2.6.31.12-0.2-desktop


    Just change this: "splash=verbose".

    Save it. You will notice the effect on next boot, and hopefully, when you halt it next time. If
    perchance during halt you don't see a lot of text, press "esc".

    Just take a note when it stop - or a photo if you can, which you can post on a pastebin or similar.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Elessar))

  3. #3

    Default Re: System stalls at Restart

    After I changed to verbose and restarted I then restarted again from GDM. GDM disappeared the only new line I saw was
    Code:
    [ 47.044694] Restarting System

  4. #4
    JosephKK NNTP User

    Default Re: System stalls at Restart

    On Thu, 02 Sep 2010 23:06:02 GMT, kahu
    <kahu@no-mx.forums.opensuse.org> wrote:

    >
    >After I changed to verbose and restarted I then restarted again from
    >GDM. GDM disappeared the only new line I saw was
    >
    >Code:
    >--------------------
    > [ 47.044694] Restarting System
    >--------------------


    Poor Carlos, he still hasn't quite wrapped his head around the idea
    that it is not booting properly.

    In fact you have not told us which version of Linux, Display manager,
    desktop environment or much of anything to work with

    That message is not really helpful either.

    Try booting from a live CD and listing your installed oS /bootlog.txt
    in your next post.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •