Results 1 to 6 of 6

Thread: Getting error message in VirtualBox about Ext4.

  1. #1

    Default Getting error message in VirtualBox about Ext4.

    The virtual machine execution may run into an error condition as described below. We suggest that you take an appropriate action to avert the error.
    The host I/O cache for at least one controller is disabled and the medium '/home/MyUserName/.VirtualBox/HardDisks/Ubuntu_LAMP.vdi' for this VM is located on an ext4 partition. There is a known Linux kernel bug which can lead to the corruption of the virtual disk image under these conditions.
    Either enable the host I/O cache permanently in the VM settings or put the disk image and the snapshot folder onto a different file system.
    The host I/O cache will now be enabled for this medium.
    Any idea what this is and how to fix this safely?

  2. #2
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Getting error message in VirtualBox about Ext4.

    What you have to do is run VirtualBox, click on the Ubuntu_LAMP VM you created and click the "Settings" butting at the top (DO NOT run the VM, otherwise you will not be able to change the settings). once the Settings dialog open goto Storage. Now click on IDE Controller and SATA Controller, and see if you have a "Use host I/O cache" option check box available. If yes, check it. save the settings and run the VM. that should do the trick.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  3. #3

    Default Re: Getting error message in VirtualBox about Ext4.

    Quote Originally Posted by Argoson View Post
    What you have to do is run VirtualBox, click on the Ubuntu_LAMP VM you created and click the "Settings" butting at the top (DO NOT run the VM, otherwise you will not be able to change the settings). once the Settings dialog open goto Storage. Now click on IDE Controller and SATA Controller, and see if you have a "Use host I/O cache" option check box available. If yes, check it. save the settings and run the VM. that should do the trick.
    Hmmm, that already is checked.

  4. #4

    Default Re: Getting error message in VirtualBox about Ext4.

    Can this error ever lead to ruining the actual hard drive? I mean can it ruin the physical hard drive of the host OS?

  5. #5

    Default Re: Getting error message in VirtualBox about Ext4.

    I'm still getting this error despite having "use host I/O cache" checked.

  6. #6

    Default Re: Getting error message in VirtualBox about Ext4.

    I simply unticked this checkbox and now it works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •