Results 1 to 9 of 9

Thread: Zypper upgrade question

  1. #1
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Zypper upgrade question

    Hi

    I have "switched to system packages" on packman, to get some goodies, and KDE factory to get KDE 4.5.

    Now, when I use upgrade option from Zypper, I get this:

    Code:
    laptux:/home/ebeli # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      apache2-mod_php5 audacity autofs bea-stax-api bind-libs bind-utils curl drm-nouveau-kmp-desktop e2fsprogs e2fsprogs-devel faac faad2 
      ffmpeg freeglut fuse gstreamer-0_10-fluendo-mp3 jakarta-commons-logging java-1_6_0-openjdk java-1_6_0-openjdk-devel 
      java-1_6_0-openjdk-plugin jgoodies-forms jline jpackage-utils ladspa libavcodec52 libavdevice52 libavfilter1 libavformat52 libavutil50 
      libcom_err2 libcom_err-devel libcurl4 libcurl-devel libdca0 libdirac_decoder0 libdirac_encoder0 libdrm libdrm-devel libext2fs2 
      libext2fs-devel libfaac0 libfaad2 libfreebl3 libfuse2 libgphoto2 libgphoto2-devel libkate1 libmad0 libmad-devel libmpeg2-0 
      libmusicbrainz3-6 libmysqlclient16 libmysqlclient-devel libmysqlclient_r16 libmysqlcppconn1 libmysqld0 libopenobex1 libpostproc51 
      libschroedinger-1_0-0 libscintilla1 libsoftokn3 libSoundTouch0 libsqlite3-0 libssh2-1 libstlport_gcc4 libswscale0 libvpx0 licenses Mesa 
      Mesa-devel MozillaFirefox MozillaFirefox-branding-upstream MozillaFirefox-theme-oxygen mozilla-js192 mozilla-kde4-integration mozilla-nspr 
      mozilla-nspr-devel mozilla-nss mozilla-nss-certs mozilla-nss-devel mozilla-xulrunner191 mozilla-xulrunner191-devel 
      mozilla-xulrunner191-gnomevfs mozilla-xulrunner192 mozilla-xulrunner192-gnome myspell-american mysql-administrator mysql-community-server 
      mysql-community-server-client mysql-gui-tools mysql-query-browser ntfsprogs OpenOffice_org-hyphen OpenOffice_org-templates-en 
      OpenOffice_org-templates-labels-a4 OpenOffice_org-templates-labels-letter OpenOffice_org-templates-presentation-layouts 
      OpenOffice_org-thesaurus-en-US parted php5 php5-bz2 php5-ctype php5-dom php5-gd php5-hash php5-iconv php5-json php5-mysql php5-odbc 
      php5-pdo php5-pgsql php5-sqlite php5-tidy php5-tokenizer php5-xmlreader php5-xmlwriter php5-zip php5-zlib plasmoid-yawp qeven 
      recordmydesktop reiserfs rhino saxon servletapi4 servletapi5 smplayer soundtouch sox sqlite3 sqlite3-devel update-alternatives wine 
      wine-32bit wine-gecko x264 xalan-j2 xerces-j2 xerces-j2-xml-apis xmlbeans xorg-x11-driver-video xorg-x11-driver-video-nouveau 
      xorg-x11-proto-devel xvidenc 
    
    The following packages are going to be upgraded:
      desktop-translations libopensc2 release-notes-openSUSE xorg-x11-server xorg-x11-Xvnc yast2-trans-en_US 
    
    6 packages to upgrade.
    I reckon that is because I switched sys packages to above two, but now, how to get those upgrades, and not replace KDE or some like Amarok and other things that I got from pacman?
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Zypper upgrade question

    Please post the output of

    Code:
    zypper lr -uP
    I suppose something is wrong with the combination of your repositories.

  3. #3
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default AW: Re: Zypper upgrade question

    Looks like you have some other BuildService repos to which you haven't "switched" the packages yet.

  4. #4
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: AW: Re: Zypper upgrade question

    here it is:

    Code:
    laptux:/home/ebeli # zypper lr -uP
    #  | Alias                             | Name                                        | Enabled | Refresh | Priority | URI                                                                                   
    ---+-----------------------------------+---------------------------------------------+---------+---------+----------+---------------------------------------------------------------------------------------
    1  | Jobermayr_1                       | Jobermayr                                   | Yes     | No      |   99     | http://download.opensuse.org/repositories/home%3a/jobermayr/openSUSE_11.3/            
    2  | KDE_Factory                       | KDE Factory                                 | Yes     | No      |   99     | http://download.opensuse.org/repositories/KDE:/Distro:/Factory/openSUSE_11.3/         
    3  | KDE_Factory_Extras                | KDE Factory Extras                          | Yes     | No      |   99     | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3_KDE_Distro_Factory/
    4  | Sax                               | Sax                                         | Yes     | No      |   99     | http://download.opensuse.org/repositories/home:/flacco/openSUSE_11.3/                 
    5  | download.opensuse.org-Extra       | openSUSE BuildService - KDE:Extra           | Yes     | No      |   99     | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.3/                   
    6  | download.opensuse.org-STABLE_1    | openSUSE BuildService - OpenOffice.org      | Yes     | No      |   99     | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.3/       
    7  | download.opensuse.org-UpdatedApps | openSUSE BuildService - KDE:UpdatedApps     | Yes     | No      |   99     | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.3/             
    8  | download.opensuse.org-Wine_1      | openSUSE BuildService - Wine CVS Builds     | Yes     | No      |   99     | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.3/              
    9  | download.opensuse.org-database_1  | openSUSE BuildService - Database            | Yes     | No      |   99     | http://download.opensuse.org/repositories/server:/database/openSUSE_11.3/             
    10 | download.opensuse.org-filesystems | openSUSE BuildService - filesystems         | Yes     | No      |   99     | http://download.opensuse.org/repositories/filesystems/openSUSE_11.3/                  
    11 | download.opensuse.org-mozilla_1   | openSUSE BuildService - Mozilla             | Yes     | No      |   99     | http://download.opensuse.org/repositories/mozilla/openSUSE_11.3/                      
    12 | download.opensuse.org-non-oss     | Main Repository (NON-OSS)                   | Yes     | No      |   99     | http://download.opensuse.org/distribution/11.3/repo/non-oss/                          
    13 | download.opensuse.org-oss         | Main Repository (OSS)                       | Yes     | No      |   99     | http://download.opensuse.org/distribution/11.3/repo/oss/                              
    14 | download.opensuse.org-packages    | openSUSE BuildService - Java:packages       | Yes     | No      |   99     | http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.3/               
    15 | download.opensuse.org-php_1       | openSUSE BuildService - PHP                 | Yes     | No      |   99     | http://download.opensuse.org/repositories/server:/php/openSUSE_11.3/                  
    16 | download.opensuse.org-standard    | Main Repository (Contrib)                   | Yes     | No      |   99     | http://download.opensuse.org/repositories/openSUSE:/11.3:/Contrib/standard/           
    17 | download.opensuse.org-update      | Main Update Repository                      | Yes     | No      |   99     | http://download.opensuse.org/update/11.3/                                             
    18 | download.opensuse.org-webcam_1    | openSUSE BuildService - Drivers for webcams | Yes     | No      |   99     | http://download.opensuse.org/repositories/drivers:/webcam/openSUSE_11.3/              
    19 | download.videolan.org-SuSE_1      | VideoLan Repository                         | Yes     | No      |   99     | http://download.videolan.org/pub/videolan/vlc/SuSE/11.3/                              
    20 | microchip8_1                      | microchip8                                  | Yes     | No      |   99     | http://download.opensuse.org/repositories/home%3a/microchip8/openSUSE_11.3            
    21 | packman.inode.at-suse             | Packman Repository                          | Yes     | No      |   99     | http://packman.inode.at/suse/11.3/                                                    
    22 | repo-11.3-non-oss                 | openSUSE-11.3 Non-OSS                       | Yes     | No      |   99     | http://download.opensuse.org/distribution/11.3/repo/non-oss/                          
    23 | repo-11.3-oss                     | openSUSE-11.3 OSS                           | Yes     | No      |   99     | http://download.opensuse.org/distribution/11.3/repo/oss/                              
    24 | repo-11.3-update                  | openSUSE-11.3 Updates                       | Yes     | No      |   99     | http://download.opensuse.org/update/11.3/
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  5. #5
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Zypper upgrade question

    You should do some cleaning up. It looks like you have two OSS repos (#s 13 and 23). Same with non-OSS. VLC is only needed for libdvdcss. Once you have installed this, there is no need for the repo. What's "Jobermayr?"

  6. #6
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Zypper upgrade question

    Jobermayr, I forgot, I have something installed that I needed. Ok, removed it, removed double non-oss, but I still have the same problem.

    Code:
    laptux:/home/ebeli # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      akonadi-googledata akregator apache2-mod_php5 ark audacity autofs bea-stax-api bind-libs bind-utils cervisia crystal curl digikam dolphin 
      e2fsprogs e2fsprogs-devel faac faad2 ffmpeg fuse ggz ggz-client-libs ggz-client-libs-devel gstreamer-0_10-fluendo-mp3 gwenview 
      jakarta-commons-logging java-1_6_0-openjdk java-1_6_0-openjdk-devel java-1_6_0-openjdk-plugin jgoodies-forms jline jpackage-utils juk 
      kaddressbook kalarm kate kcachegrind kcalc kcharselect kcolorchooser kcron kde4-kapptemplate kde4-kgreeter-plugins kde4-l10n-devel 
      kde4-printer-applet kdeartwork4 kdeartwork4-screensaver kdebase4 kdebase4-libkonq kdebase4-nsplugin kdebase4-runtime kdebase4-session 
      kdebase4-workspace kdebase4-workspace-devel kdebase4-workspace-google-gadgets kdebase4-workspace-ksysguardd kdeedu4 kdegames4 
      kdegames4-carddecks-default kdegames4-carddecks-other kdegraphics4 kdelibs4 kdelibs4-core kdelibs4-doc kdemultimedia4 
      kdenetwork4-filesharing kdepasswd kdepim4 kdepim4-runtime kdepim4-wizards kdepimlibs4 kdesdk4 kdialog kdm kdnssd keditbookmarks kfind 
      kgamma kget kgpg kio_audiocd kio_kamera kio_svn kio_sysinfo kipi-plugins kmag kmahjongg kmail kmines kmix kmousetool knode knotes 
      kolourpaint kompare konqueror konqueror-plugins konsole kontact kopete korganizer kpat krdc kreversi krfb kruler kscd ksnapshot kstars 
      kstars-data ksudoku ksystemlog ktimer ktorrent ktorrent-lang kwalletmanager kwin kwrite ladspa libakonadi4 libavcodec52 libavdevice52 
      libavfilter1 libavformat52 libavutil50 libcom_err2 libcom_err-devel libcurl4 libcurl-devel libdca0 libdirac_decoder0 libdirac_encoder0 
      libext2fs2 libext2fs-devel libfaac0 libfaad2 libfreebl3 libfuse2 libggz2 libggz2-devel libgphoto2 libgphoto2-devel libkate1 libkcddb4 
      libkcompactdisc4 libkdcraw8 libkde4 libkde4-devel libkdecore4 libkdecore4-devel libkdeedu4 libkdegames4 libkdepimlibs4 libkexiv2-8 
      libkexiv2-devel libkipi7 libkonq5 libmad0 libmad-devel libmpeg2-0 libmusicbrainz3-6 libmysqlclient16 libmysqlclient-devel 
      libmysqlclient_r16 libmysqlcppconn1 libmysqld0 libopenobex1 libpostproc51 libschroedinger-1_0-0 libscintilla1 libsoftokn3 libSoundTouch0 
      libsqlite3-0 libssh2-1 libstlport_gcc4 libswscale0 libvpx0 licenses lokalize marble marble-data MozillaFirefox 
      MozillaFirefox-branding-upstream MozillaFirefox-theme-oxygen mozilla-js192 mozilla-kde4-integration mozilla-nspr mozilla-nspr-devel 
      mozilla-nss mozilla-nss-certs mozilla-nss-devel mozilla-xulrunner191 mozilla-xulrunner191-devel mozilla-xulrunner191-gnomevfs 
      mozilla-xulrunner192 mozilla-xulrunner192-gnome myspell-american mysql-administrator mysql-community-server mysql-community-server-client 
      mysql-gui-tools mysql-query-browser NetworkManager-kde4 NetworkManager-kde4-libs NetworkManager-openvpn-kde4 NetworkManager-pptp-kde4 
      NetworkManager-vpnc-kde4 ntfsprogs okteta okular OpenOffice_org-hyphen OpenOffice_org-templates-en OpenOffice_org-templates-labels-a4 
      OpenOffice_org-templates-labels-letter OpenOffice_org-templates-presentation-layouts OpenOffice_org-thesaurus-en-US parted php5 php5-bz2 
      php5-ctype php5-dom php5-gd php5-hash php5-iconv php5-json php5-mysql php5-odbc php5-pdo php5-pgsql php5-sqlite php5-tidy php5-tokenizer 
      php5-xmlreader php5-xmlwriter php5-zip php5-zlib plasma-addons plasmoid-cwp plasmoid-yawp python-kde4 python-kdebase4 qeven 
      recordmydesktop reiserfs rhino saxon servletapi4 servletapi5 skrooge smplayer soundtouch sox sqlite3 sqlite3-devel sweeper umbrello 
      update-alternatives wine wine-32bit wine-gecko x264 xalan-j2 xerces-j2 xerces-j2-xml-apis xmlbeans xvidenc 
    
    The following packages are going to be upgraded:
      akonadi-runtime desktop-translations digikam-lang kde4-filesystem kdeartwork4-weatherwallpapers kdebase4-openSUSE 
      kdebase4-runtime-branding-openSUSE kdebase4-runtime-xine kdebase4-workspace-branding-openSUSE kdelibs4-branding-openSUSE 
      kdm-branding-openSUSE kio_sysinfo-branding-openSUSE kipi-plugins-acquireimage kipi-plugins-lang konqueror-plugins-lang 
      libakonadi4-debuginfo libakonadiprotocolinternals1 libattica0 libattica-devel libkdepim4 libksane0 libksuseinstall1 libktorrent2 
      libktorrent2-lang liblastfm0 libopensc2 libphonon4 libpolkit-qt-1-0 libpolkit-qt-1-devel libqimageblitz4 libqimageblitz-devel libqjson0 
      libsmoke2 libsoprano4 libsoprano-devel libstrigi0 luckybackup luckybackup-doc NetworkManager-kde4-libs-lang oxygen-icon-theme 
      oxygen-icon-theme-large oxygen-icon-theme-scalable phonon phonon-backend-gstreamer-0_10 phonon-backend-xine phonon-devel 
      plasma-addons-marble plasma-theme-aya polkit-kde-1 polyester recordmydesktop release-notes-openSUSE ruby-kde4 skrooge-lang soprano 
      soprano-backend-redland soprano-backend-sesame soprano-backend-virtuoso strigi strigi-devel timezone timezone-java xorg-x11-server 
      xorg-x11-Xvnc yast2-control-center yast2-control-center-qt yast2-trans-en_US 
    
    67 packages to upgrade.
    Overall download size: 64.2 MiB. After the operation, 166.0 KiB will be freed.
    Continue? [y/n/?] (y): n
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  7. #7
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Zypper upgrade question

    Well, 67 packages now! Consider removing all your repositories except OSS, non-OSS, updates, Packman and KDE-Factory. Make notes of the ones you want to have later. Try doing an update after that.

  8. #8
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default AW: Re: Zypper upgrade question

    As I said...those "not to be installed" packages are very likely from OBS-repos and you haven't "switched" to those repos yet. That's why they are available as upgrades. But since a vendor change is not allowed per default, they won't be installed.

    And you should set all repos (except OSS, Non-OSS) to autorefresh. Or do you run zypper refresh before every update?

  9. #9
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: AW: Re: Zypper upgrade question

    Resolved.. seems that the problem was in some repos that were enabled, like KDE:Extra (using factory already), Opensuse Build (java, drivers for webcams and videolan).
    Removing those and updating resolved the problem.

    @lOtz1009, yes, running zypper ref first always. I do not like autorefresh, because everytime I open software manager to see some info, it starts downloading and slowing me down.
    I actually made a script for it, and does evertything necessary.

    thanks to all of you
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •