Results 1 to 6 of 6

Thread: Screen not properly refreshed

  1. #1

    Default Screen not properly refreshed

    Hi,

    I actually don't know what was the cause of this.

    Because of some display problems such as openSUSE freezes with external monitors, I have included xorg repository and updated relevant packages.

    A couple of days ago, suddenly my system started not refreshing the screen properly. For example, when I change a folder in Nautilus, the file pane is blank even though there are lots of files. The files appear when I move mouse cursor around or I activate some other window with alt-tab, and get back. Or in OpenOffice Witer, if I press arrow keys, there are lots of residual image of the cursor.

    So the screen is not properly refreshed right now, and I wonder what I should do to fix this. Please let me know.

    -Joon

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Screen not properly refreshed

    I suspect your solution to one problem might have caused the other
    You need to give more detail on your setup
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Screen not properly refreshed

    Sorry. I keep forgetting giving the setup. So I'm using openSUSE 11.3 64bit, with Gnome. Intel Graphics. Please let me know what else do you need.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Screen not properly refreshed

    I have 2 machines with Intel Graphics and they work perfectly.
    I know some issues exist, particularly in KDE
    So I'm wondering what caused you to use/add xorg
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Screen not properly refreshed

    Quote Originally Posted by caf4926 View Post
    I have 2 machines with Intel Graphics and they work perfectly.
    I know some issues exist, particularly in KDE
    So I'm wondering what caused you to use/add xorg
    First of all it was crashing when I change desktop background.
    Then plugging in/out external monitors caused my system to freeze (mouse cursor moves, but black screens)
    And coming out from the suspension often caused system crash or freeze.

    I found using xorg at least enabled me to change desktop background.

    And other problems seems to be somewhat mitigated after I turned off the screensaver. It is strange because I didn't have this problem in 11.2

    The following thread is related: openSUSE freezing & crashing


    Anyway, I just downgraded to xorg-x11-server stuff to updates repository, and the problem of this thread (refreshing) was solved. I deleted xorg repository.

    Thanks.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Screen not properly refreshed

    Anyway, I just downgraded to xorg-x11-server stuff to updates repository, and the problem of this thread (refreshing) was solved. I deleted xorg repository.
    Which is what I wanted to say but didn't.
    Thanks for filling us in.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •