Results 1 to 8 of 8

Thread: Skype in 11.3

  1. #1

    Default Skype in 11.3

    Hi,

    I'm trying to get Skype 2.1.0.81 working, but the terminal printout indicates that I need libQtDBus.so.4. (It was missing something before that one, but I found it. Can't remember what it was.)

    However, I can't find it in YaST, despite having OSS, Non-OSS, Update and Packman repos installed.

    So....what should I do? Anyone, suggestions please?

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Skype in 11.3

    what does:

    zypper wp libQtDBus.so.4

    show in the terminal?

    Also are you using a 64 bit system? I got skype working on my 64 bit openSUSE 11.3 by installing the 32 bit libraries for QT
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3

    Default Re: Skype in 11.3

    Try reading this thread.

  4. #4

    Default Re: Skype in 11.3

    Quote Originally Posted by ah7013 View Post
    what does:

    zypper wp libQtDBus.so.4

    show in the terminal?

    Also are you using a 64 bit system? I got skype working on my 64 bit openSUSE 11.3 by installing the 32 bit libraries for QT
    Thanks! Got it solved. I just went from one package to the next and it worked. Installing the 32-bit versions didn't interfere with any of my 64-bit packages. Glad about that, 'cause I hate deinstalling stuff when I don't know what else depends on it.

    Code:
    ~@linux:~> zypper wp libQtDBus.so.4
    Loading repository data...
    Reading installed packages...
    S | Name         | Type    | Version   | Arch   | Repository             
    --+--------------+---------+-----------+--------+------------------------
    i | libqt4       | package | 4.6.3-1.5 | x86_64 | OSS                    
    i | libqt4       | package | 4.6.3-1.5 | x86_64 | openSUSE-11.3 11.3-1.82
    v | libqt4       | package | 4.6.3-1.5 | i586   | OSS                    
      | libqt4-32bit | package | 4.6.3-1.5 | x86_64 | OSS                    
      | libqt4-32bit | package | 4.6.3-1.5 | x86_64 | openSUSE-11.3 11.3-1.82

    Quote Originally Posted by JJMT View Post
    Try reading this thread.
    Thanks to you, too!

  5. #5
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    45

    Default Re: Skype in 11.3

    Quote Originally Posted by JJMT View Post
    Try reading this thread.
    That 64 bit Skype works and is simple to install. But it crashes when I start a conference call. Anybody got any ideas about that?

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,697

    Default Re: Skype in 11.3

    Use the 32 bit version. just be sure you have the 32bit versions of the libraries.

  7. #7

    Default Re: Skype in 11.3

    Hello

    Also upgraded from 64-bit 11.2 to 64-bit 11.3 and Skype did not work anymore. Googled it (a seg fault) and found this blog post. This fixed the problem for me:
    zypper in libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-32bit libqt4-x11-32bit libpng12-0-32bit
    Office: 64-bit OpenSuse 12.1 KDE 4.7 nvidia with nouveau driver
    Home: 64-bit OpenSuse 12.1 KDE 4.7 ATI Audiophile2496

  8. #8
    Join Date
    Dec 2008
    Location
    Pennsylvania, USA
    Posts
    9

    Default Re: Skype in 11.3

    Let's establish this now: yes, I am a noob. My question, however, is this. If it takes the 32-bit libraries to make Skype work, why not just the 32-bit build of openSUSE?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •