Results 1 to 9 of 9

Thread: Weird printer problem with 11.3

  1. #1
    Join Date
    Apr 2009
    Location
    London, UK
    Posts
    27

    Default Weird printer problem with 11.3

    Hi

    I'm running 64 bit 11.3 with KDE and CUPS printer support. I have an HP Photosmart 3210 printer. Since upgrading from 11.2, I have been able to print the first page of any document out fine - but the subsequent pages are filled with repetitive printing of single lines which tends to end up with huge black blocks.

    I looked at the CUPS website, found that a guy called Reiner had reported a similar problem with a different HP printer and received the rather dismissive response - "We do not support or develop the software/driver you are using. Please contact the developer for assistance." What on earth does this mean? HP is not exactly an obscure make of printer - and it's not that old. I can't see support for any Photosmart printer on the CUPS site. Where do I go from here?

    Philip Timms

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Weird printer problem with 11.3

    Have you tried the HP drivers? HP is one of the few that at least attempt to support Linux

  3. #3

    Default Re: Weird printer problem with 11.3

    Quote Originally Posted by PhilipTimms View Post
    Hi

    I'm running 64 bit 11.3 with KDE and CUPS printer support. I have an HP Photosmart 3210 printer. Since upgrading from 11.2, I have been able to print the first page of any document out fine - but the subsequent pages are filled with repetitive printing of single lines which tends to end up with huge black blocks.

    I looked at the CUPS website, found that a guy called Reiner had reported a similar problem with a different HP printer and received the rather dismissive response - "We do not support or develop the software/driver you are using. Please contact the developer for assistance." What on earth does this mean? HP is not exactly an obscure make of printer - and it's not that old. I can't see support for any Photosmart printer on the CUPS site. Where do I go from here?

    Philip Timms
    As gogalthorp says, the hpijs driver?
    I've also recommend uninstall/reinstall the HP printer. Several times in the past an upgrade to CUPS caused printing problems, resolved by uninstall/reinstall the printers.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  4. #4
    Join Date
    Apr 2009
    Location
    London, UK
    Posts
    27

    Default Re: Weird printer problem with 11.3

    No joy with uninstalling and re-installing printer - may have to wait for a version of HPLIP for 11.3 - it only goes up to 11.2.

  5. #5

    Default Re: Weird printer problem with 11.3

    Once you have the ppd driver, it's not very complicated, either from command line (man lpadmin), using the cups web interface ( http://localhost:631) or with YaST. I don't see why you could not borrow the ppd file from 11.2 and copy it in /etc/cups/ppd.

  6. #6
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Weird printer problem with 11.3

    It's either cups or gutenprint. A bug report has not been filed yet.

  7. #7
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Weird printer problem with 11.3

    I just updated cups, gutenprint, and the hp drivers from Index of /repositories/Printing and the problem is resolved.

  8. #8
    Join Date
    Apr 2009
    Location
    London, UK
    Posts
    27

    Default Re: Weird printer problem with 11.3

    Hi

    This seems to have resolved for me by using the latest hpijs driver rather than the cups driver - they both have the same version numbers

  9. #9
    Join Date
    Jul 2008
    Location
    Nisserwaard Nederland
    Posts
    348

    Default Re: Weird printer problem with 11.3

    I also upgraded cups and hplib

    PROBLEMS SOLVED

    now the black pages after the first one in normal print are gone

    Hplib works better then the stock version which had trouble with the cups-backend

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •