Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: KDE 4.5 hangs up while logging in

  1. #1

    Default KDE 4.5 hangs up while logging in

    Hi everybody,

    maybe this problem is already posted somewhere. If yes, please excuse.
    I have an ACER TravelMate 6003LMI with openSUSE 11.3 and I updated now to KDE 4.5. So far, the update went fine, but now I cannot login anymore. openSUSE 11.3 boots up to the login prompt, I'm logging in, the KDE progress bar reaches about 75% and then it hangs up.
    My looks like this and I must confess, that at the moment I have no idea what's going wrong:

    /etc/X11/xim: Checking whether an input method should be started.
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale de_DE.UTF-8 ...
    There is no default input method for the current locale.
    Dummy input method "none" (do not use any fancy input method by default)
    startkde: Starting up...
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    kbuildsycoca4 running...
    Fetched layout groups from X server: layouts: ("de") variants: ("nodeadkeys")
    Invalid D-BUS member name 'idle-hint' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'is-local' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'x11-display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'x11-display' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'remote-host-name' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'session-type' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'unix-user' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    <unknown program name>(3184)/ KStartupInfo::createNewStartupId: creating: "kronos.bioinf.uni-jena.de;1283084164;783523;3184_TIME0" : "unnamed app"
    QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.5'
    kwin(3240) KWin::CompositingPrefs::detectDriverAndVersion: GL vendor is "Tungsten Graphics, Inc"
    kwin(3240) KWin::CompositingPrefs::detectDriverAndVersion: GL renderer is "Mesa DRI Intel(R) 852GM/855GM GEM 20100328 2010Q1 x86/MMX/SSE2"
    kwin(3240) KWin::CompositingPrefs::detectDriverAndVersion: GL version is "1.3 Mesa 7.8.2"
    kwin(3240) KWin::CompositingPrefs::detectDriverAndVersion: Detected driver "intel" , version "20100328"
    kwin(3240) KWin::EffectsHandlerImpl::loadEffect: EffectsHandler::loadEffect : Effect "kwin4_effect_blur" is not supported
    QFont::setPointSize: Point size <= 0 (0), must be greater than 0
    klauncher(3185) KConfigGroup::readXdgListEntry: List entry OnlyShowIn in "/etc/xdg/autostart/ksmolt-autostart.desktop" is not compliant with XDG standard (missing trailing semicolon).
    <unknown program name>(3267)/ kdemain: !!{} STARTUP TIME 51369012 START (line: 48 )
    QDBusObjectPath: invalid path ""
    QFont::setPointSize: Point size <= 0 (0), must be greater than 0
    plasma-desktop(3267): Communication problem with "plasma-desktop" , it probably crashed.
    Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "

    <unknown program name>(3184)/ KStartupInfo::createNewStartupId: creating: "kronos.bioinf.uni-jena.de;1283084223;630424;3184_TIME0" : "unnamed app"
    kcminit(3193): "Error launching kaccess. Either KLauncher is not running anymore, or it failed to start the application."

    QProcess: Destroyed while process is still running.
    kbuildsycoca4 running...
    kbuildsycoca4(4937) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/krename_all_nonrec.desktop" is not compliant with XDG standard (missing trailing semicolon).
    kbuildsycoca4(4937) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/krename_dir_rec.desktop" is not compliant with XDG standard (missing trailing semicolon).
    kbuildsycoca4(4937)/kdecore (services) KServicePrivate::init: The desktop entry file "/usr/share/applications/YaST2/groups/apparmor.desktop" has Type= "Application" but no Exec line

    kbuildsycoca4(4937) KBuildServiceFactory::createEntry: Invalid Service : "/usr/share/applications/YaST2/groups/apparmor.desktop"
    kbuildsycoca4(4937) parseLayoutNode: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file.
    kdeinit4: Fatal IO error: client killed
    kdeinit4: sending SIGHUP to children.
    kded4: Fatal IO error: client killed
    kglobalaccel: Fatal IO error: client killed
    QProcess: Destroyed while process is still running.
    Qt-subapplication: Fatal IO error: client killed
    kdeinit4: sending SIGTERM to children.
    kdeinit4: Exit.
    kdeinit4: Fatal IO error: client killed
    kdeinit4: sending SIGHUP to children.
    kdeinit4: sending SIGTERM to children.
    kdeinit4: Exit.
    Does anyone have an idea what's wrong?

    Thanks in advance
    Joern Behre

  2. #2

    Default Re: KDE 4.5 hangs up while logging in

    Small typo:

    My .xsession-errors looks like this ...
    ^^^^^^^^^

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.5 hangs up while logging in

    Do this
    At the login screen select console login
    http://lh4.ggpht.com/_hOiUsWwC6VQ/TC...sole.login.png

    Login at the CLI with your username and password

    Now do this:

    Code:
    mv .kde4 .kde4-backup
    Now type: startx

    If it works, all your old settings are in the folder .kde4-backup
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: KDE 4.5 hangs up while logging in

    Unfortunately it doesn't work. The KDE session begins to start but does not finish...

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.5 hangs up while logging in

    Login to the console
    Become su -
    Do: zypper ref

    then
    zypper dup
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: KDE 4.5 hangs up while logging in

    Thanks for all your suggestions.
    Unfortunately, it didn't succeed again.
    zypper worked well, so far, but after typing in my user name and password KDE 4.5 hangs up after about 80% progress and that's it (see picture):


    My .xsession-errors now looks the following:
    Code:
    /etc/X11/xim: Checking whether an input method should be started.
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale de_DE.UTF-8 ...
    There is no default input method for the current locale.
    Dummy input method "none" (do not use any fancy input method by default)
    startkde: Starting up...
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    kbuildsycoca4 running...
    Fetched layout groups from X server: 	layouts: ("de") 	variants: ("nodeadkeys") 
    Invalid D-BUS member name 'idle-hint' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'is-local' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'x11-display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'x11-display' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'remote-host-name' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'session-type' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    Invalid D-BUS member name 'unix-user' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
    <unknown program name>(4777)/ KStartupInfo::createNewStartupId: creating:  "kronos.bioinf.uni-jena.de;1283171582;909239;4777_TIME0" : "unnamed app"
    QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.5'
    kwin(4855) KWin::CompositingPrefs::detectDriverAndVersion: GL vendor is "Tungsten Graphics, Inc" 
    kwin(4855) KWin::CompositingPrefs::detectDriverAndVersion: GL renderer is "Mesa DRI Intel(R) 852GM/855GM GEM 20100328 2010Q1 x86/MMX/SSE2" 
    kwin(4855) KWin::CompositingPrefs::detectDriverAndVersion: GL version is "1.3 Mesa 7.8.2" 
    kwin(4855) KWin::CompositingPrefs::detectDriverAndVersion: Detected driver "intel" , version "20100328" 
    kwin(4855) KWin::EffectsHandlerImpl::loadEffect: EffectsHandler::loadEffect : Effect  "kwin4_effect_blur"  is not supported 
    QFont::setPointSize: Point size <= 0 (0), must be greater than 0
    klauncher(4778) KConfigGroup::readXdgListEntry: List entry OnlyShowIn in "/etc/xdg/autostart/ksmolt-autostart.desktop" is not compliant with XDG standard (missing trailing semicolon). 
    <unknown program name>(4858)/ kdemain: !!{} STARTUP TIME 52385635 START (line: 48 )
    QDBusObjectPath: invalid path ""
    QFont::setPointSize: Point size <= 0 (0), must be greater than 0
    plasma-desktop(4858): Communication problem with  "plasma-desktop" , it probably crashed. 
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." " 
    
    <unknown program name>(4777)/ KStartupInfo::createNewStartupId: creating:  "kronos.bioinf.uni-jena.de;1283171642;394416;4777_TIME0" : "unnamed app"
    kcminit(4786): "Error launching kaccess. Either KLauncher is not running anymore, or it failed to start the application." 
    
    QProcess: Destroyed while process is still running.
    kded4: Fatal IO error: client killed
    plasma-desktop: Fatal IO error: client killed
    kglobalaccel: Fatal IO error: client killed
    QProcess: Destroyed while process is still running.
    Qt-subapplication: Fatal IO error: client killed
    kdeinit4: Fatal IO error: client killed
    kdeinit4: sending SIGHUP to children.
    kdeinit4: sending SIGTERM to children.
    kdeinit4: Exit.
    The last lines are from an "shutdown -r now" that I did by remotely logging in.

    What else can I do?

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.5 hangs up while logging in

    Have you tried a failsafe boot
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: KDE 4.5 hangs up while logging in

    I have tried it now and it works! I should have done this earlier.
    But what does it mean? What it is switch off (or different) in a failsafe boot compared to a normal boot?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.5 hangs up while logging in

    You can see from that error you reported earlier that it was having trouble with X

    Please post result of

    /sbin/lspci -nnk
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.5 hangs up while logging in

    Now that you are able to log in
    Make sure desktop effects is OFF
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •