Results 1 to 5 of 5

Thread: cluster: ocfs2, pacemaker, clvm.. disaster

  1. #1

    Default cluster: ocfs2, pacemaker, clvm.. disaster

    Hi all,

    I'm trying to create a cluster with ocfs2 on openSuse11.2.
    I think to use pacemaker with openais and heartbeat for cluster manager, and clvm as logical volum manager.
    If I install the last version of pacemaker (1.0.9 with openais 1.1.3 and heartbeat 3.0) I cannot use clvm (it needs a old version of openais (0.80) ).
    If I use the old version of pacemaker (1.0.1 with openais 0.80.3 and heartbeat 2.99) I cannot use the gui because the pacemaker-gui is really heartbeat-gui:
    Sep 17 14:24:20 opensuse-master crmd: [3784]: CRIT: is_heartbeat_cluster:
    The installation of Pacemaker only supports OpenAIS but you're trying to run it on Heartbeat. Terminating.
    Somebody can hep me?

  2. #2

    Default Re: cluster: ocfs2, pacemaker, clvm.. disaster

    Can anyone help me?

  3. #3
    Join Date
    Jun 2008
    Location
    Syros, Greece
    Posts
    569

    Default Re: cluster: ocfs2, pacemaker, clvm.. disaster

    Don't use heartbeat as the message says, use openais. I haven't tested on 11.3 but i have several clusters with pacemaker and openais on 11.1 and 11.2.

  4. #4

    Default Re: cluster: ocfs2, pacemaker, clvm.. disaster

    Ok, thanks.

    But for clvm? which version do you use for pacemaker and openais?

  5. #5
    Join Date
    Jun 2008
    Location
    Syros, Greece
    Posts
    569

    Default Re: cluster: ocfs2, pacemaker, clvm.. disaster

    Quote Originally Posted by kiaraston View Post
    Ok, thanks.

    But for clvm? which version do you use for pacemaker and openais?
    I cannot help you with that. I'm using primarly DRBD. Check the following repository for newer packages.

    Index of /repositories/network:/ha-clustering/openSUSE_11.3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •