Results 1 to 7 of 7

Thread: Anyone has old fgltrx before ati cut support for older cards

  1. #1
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Anyone has old fgltrx before ati cut support for older cards

    Anyone knows what is version of proprietaty ati driver and does anyone have it?
    I seem to have problems in 11.3 with open radeon and radeonhd drivers, but I need older as I have rv550 (x2300).
    I would be very much obliged if anyone could pass me the file somehow.
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,697

    Default Re: Anyone has old fgltrx before ati cut support for older cards

    Ouch, ATI dropped support for legacy drivers. Even if you found the driver it would not work with the newer kernels.

  3. #3

    Default Re: Anyone has old fgltrx before ati cut support for older cards

    you are looking at a very serious undertaking to try and use an older ati driver with the 11.3 kernel, it would take someone knowledgeable in kernel development and even then turn out to be unfeasible. For the 11.1 kernel (2.6.27) i have these files.

    drop.io - lhuwo9o

    i have some other ATI .run packages if you require them (i'm a packrat), just figure out what you might need and post back.

  4. #4
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Anyone has old fgltrx before ati cut support for older cards

    I have custom compiled 2.6.32.2 kernel (for 11.2) and taboo-ed its updates, of course I would make backup. Just wondering can I use .run package from ATI, latest one before support was off, and can I somehow install it.
    I don't know should I try with RPM that is for 11.1, or to go with ati .run file... second option seems better, if you have it.

    What are my problems:
    - kernel that came with 11.3 does not work, and I lost many hours unsucessfully making it work with everything I have. I gave up. Using older one
    - Radeon and Radeonhd drivers that worked more-or-less well, got worse in 11.3, not to mention that I cannot find radeon xorg driver, just radeonhd

    I just want my graphics to work as it worked before, without downgrading suse and kernel version. (as in kernels before, Atheros didnt worked well)
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,697

    Default Re: Anyone has old fgltrx before ati cut support for older cards

    Hmm I agree that video in 11.3 is a bit of a mess. It is not clear if this will be fixed before 11.4 since if seems it is a kernel problem for the most part.

    You can not install the legacy ATI driver because it will not work with new kernels and ATI won't update it anymore.

  6. #6

    Default Re: Anyone has old fgltrx before ati cut support for older cards

    Quote Originally Posted by beli0135 View Post
    I have custom compiled 2.6.32.2 kernel (for 11.2) and taboo-ed its updates, of course I would make backup. Just wondering can I use .run package from ATI, latest one before support was off, and can I somehow install it.
    I don't know should I try with RPM that is for 11.1, or to go with ati .run file... second option seems better, if you have it.

    What are my problems:
    - kernel that came with 11.3 does not work, and I lost many hours unsucessfully making it work with everything I have. I gave up. Using older one
    - Radeon and Radeonhd drivers that worked more-or-less well, got worse in 11.3, not to mention that I cannot find radeon xorg driver, just radeonhd

    I just want my graphics to work as it worked before, without downgrading suse and kernel version. (as in kernels before, Atheros didnt worked well)
    per your request.

    ati-driver-installer-8-12-x86.x86_64.run drop.io - 6l0l5og

  7. #7
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Anyone has old fgltrx before ati cut support for older cards

    Thank you J_xavier.
    Now, if something goes wrong, as @gogalthorp said, will recovery procedure will be possible? I will backup xorg.conf, and as I have sax, will sax -r -m 0=radeon in init 3 reslove problem?
    Should I beckup kernel image also?
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •