Results 1 to 6 of 6

Thread: Where find libcrypto and libssl?

  1. #1

    Default Where find libcrypto and libssl?

    I am trying to install the google talk plugin and it fails, saying it needs libcrytpo.0.9.8 and libssl.0.9.8. Anyone know where I can get those?

    NOTE: I have openssl 0.9.8 installed.

    Yet it fails with:
    error: Failed dependencies:
    libcrypto.so.0.9.8(OPENSSL_0.9.8) is needed by google-talkplugin-1.4.1.0-2.i386
    libssl.so.0.9.8(OPENSSL_0.9.8) is needed by google-talkplugin-1.4.1.0-2.i386

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Where find libcrypto and libssl?

    6tr6tr wrote:

    >
    > I am trying to install the google talk plugin and it fails, saying it
    > needs libcrytpo.0.9.8 and libssl.0.9.8. Anyone know where I can get
    > those?
    >
    > NOTE: I HAVE OPENSSL 0.9.8 INSTALLED.
    > Yet it fails with:
    >> error: Failed dependencies:
    >> libcrypto.so.0.9.8(OPENSSL_0.9.8) is needed by
    >> google-talkplugin-1.4.1.0-2.i386
    >> libssl.so.0.9.8(OPENSSL_0.9.8) is needed by
    >> google-talkplugin-1.4.1.0-2.i386
    >>

    >
    >

    I am not completely sure but is it possible that you need
    libopenssl0_9_8-32bit?

    --
    openSUSE 11.2 64 bit | Intel Core2 Quad Q8300@2.50GHz | Gnome 2.28 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | Gnome 2.30 | Quadro
    FX 3600M | 4GB Ram


  3. #3

    Default Re: Where find libcrypto and libssl?

    Quote Originally Posted by 6tr6tr View Post
    I am trying to install the google talk plugin and it fails, saying it needs libcrytpo.0.9.8 and libssl.0.9.8. Anyone know where I can get those?

    NOTE: I have openssl 0.9.8 installed.

    Yet it fails with:
    From where are you trying to install it? And for which distro?

    openSSL is a problematic library because each new version is incompatible with the old one. Whatever it was compiled against, it wasn't openSUSE 11.3 since the libopenssl0_9_8 package doesn't have versioned symbols. IIRC you can still run a program compiled against a library with versioned symbols if at runtime you use a library without them, only getting a warning. So, *supposing the openSSL versions are compatible* you can try to ignore those two dependencies and it may work (with the warning).
    And sure, if you are on x86-64 and want to use that x86-32 plugin you will need to follow martin_helm advice.

  4. #4

    Default Re: Where find libcrypto and libssl?

    Quote Originally Posted by RedDwarf View Post
    From where are you trying to install it? And for which distro?

    openSSL is a problematic library because each new version is incompatible with the old one. Whatever it was compiled against, it wasn't openSUSE 11.3 since the libopenssl0_9_8 package doesn't have versioned symbols. IIRC you can still run a program compiled against a library with versioned symbols if at runtime you use a library without them, only getting a warning. So, *supposing the openSSL versions are compatible* you can try to ignore those two dependencies and it may work (with the warning).
    And sure, if you are on x86-64 and want to use that x86-32 plugin you will need to follow martin_helm advice.
    I have 32-bit so that's not an issue.

    I could try running without the dependencies, but I don't know that I want to take a chance. What I don't get is that it's asking for the exact versions that I have. Any idea why it can't find them? Where in an RPM does it list those needs? Is there a way I could *help* it find those libs by altering the RPM that alien created?

  5. #5

    Default Re: Where find libcrypto and libssl?

    Quote Originally Posted by 6tr6tr View Post
    I have 32-bit so that's not an issue.

    I could try running without the dependencies, but I don't know that I want to take a chance. What I don't get is that it's asking for the exact versions that I have. Any idea why it can't find them? Where in an RPM does it list those needs? Is there a way I could *help* it find those libs by altering the RPM that alien created?
    The explanation is at chapter 3 of http://www.akkadia.org/drepper/dsohowto.pdf... but if you are not a developer you are not going to understand it.

    There is nothing you can do short of substituting your installed openSSL or getting the google talk plugin from another source (but since I think the only source is the DEB from Google that's not an option). Even if your openSSL is the exact same version used to compile that plugin, each openSSL has been created in a different way that exports different version information (the one used by the plugin has additional information).
    It's not a "real" problem. The openSSL from openSUSE just lacks some information that would be good to have, but that isn't really needed.
    Notice that it complains about "libcrypto.so.0.9.8(OPENSSL_0.9.8)", not about "libcrypto.so.0.9.8" (that is *ALSO* a dependency). The dependent library has been found, otherwise you would have an extra line in that error message, it is only complaining about not being able to find the extra information.

  6. #6
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Where find libcrypto and libssl?

    Just to recall these recent threads...hope will give an insight of the problem.

    Google released Linux video chat plugin for Gmail

    Google Video/Audio Chat Plugin
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •