Results 1 to 9 of 9

Thread: Kein Splash-Screen mehr nach Update auf OpenSuSE auf Lenovo Thnikpad T60

  1. #1

    Question Kein Splash-Screen mehr nach Update auf OpenSuSE auf Lenovo Thnikpad T60

    Hallo,

    nachdem ich gerade mein Lenovo Thinkpad auf die aktuelle Version 11.3 gebracht habe, fehlt mir dort beim Booten der Splash-Screen. Beim Hochfahren zeigt er sich ganz kurz und dann wird der Bildschirm schwarz, bis der KDE Login-Manager geladen ist. Beim Herunterfahren bleibt der Bildschirm komplett schwarz. Ist eigentlich bloß ein Schönheitsfehler (abgesehen davon, dass ich die Statusmeldungen über ESC offenbar auch nicht mehr lesen kann). Aber wo könnte man deswegen mal nachschauen?

    --

    Vielen Dank,
    Felix

  2. #2
    Join Date
    Aug 2010
    Location
    Austria
    Posts
    170

    Default Re: Kein Splash-Screen mehr nach Update auf OpenSuSE auf Lenovo Thnikpad T60

    Der T60 hat einen Intel Grafikchip, oder?

    Vermutlich wird beim booten durch udev das Intel KMS aktiviert.
    Dies könnte erklären, weshalb der Splash-Screen ganz kurz angezeigt wird.

    Ich habe jetzt blöderweise die Fedora 14 Alpha auf meinem Test-Notebook mit Intel GPU installiert...

    Bei mir wird der Splash-Screen immer gleich deaktiviert (splash=silent), deshalb ist mir das vermutlich gar nicht aufgefallen

    Im Yast unter Bootloader kann soweit einiges eingestellt werden oder unter /boot/grub/menu.lst bzw. /etc/sysconfig/bootloader (SuSEconfig nicht vergessen.)

    Unter /etc/sysconfig/kernel kann KMS aktiviert bzw. deaktiviert werden (NO_KMS_IN_INITRD="no") bei änderung mkinitrd nicht vergessen.

    Wenn man KMS nutzen möchte oder muss, sollte in der "Grub Kernel Zeile" kein vga= oder gar nomodeset stehen

  3. #3

    Unhappy AW: Re: Kein Splash-Screen mehr nach Update auf OpenSuSE auf Lenovo Thnikpad T60

    Quote Originally Posted by redkiwi View Post
    Der T60 hat einen Intel Grafikchip, oder?

    Vermutlich wird beim booten durch udev das Intel KMS aktiviert.
    Dies könnte erklären, weshalb der Splash-Screen ganz kurz angezeigt wird.

    Ich habe jetzt blöderweise die Fedora 14 Alpha auf meinem Test-Notebook mit Intel GPU installiert...

    Bei mir wird der Splash-Screen immer gleich deaktiviert (splash=silent), deshalb ist mir das vermutlich gar nicht aufgefallen

    Im Yast unter Bootloader kann soweit einiges eingestellt werden oder unter /boot/grub/menu.lst bzw. /etc/sysconfig/bootloader (SuSEconfig nicht vergessen.)

    Unter /etc/sysconfig/kernel kann KMS aktiviert bzw. deaktiviert werden (NO_KMS_IN_INITRD="no") bei änderung mkinitrd nicht vergessen.

    Wenn man KMS nutzen möchte oder muss, sollte in der "Grub Kernel Zeile" kein vga= oder gar nomodeset stehen
    Hallo,

    das klingt für mich alles sehr kryptisch. Meines Wissens verfügt der Laptop in der Tat über einen Intel-Grafikchip und zusätzlich noch ein zweites Grafikmodul (was war dafür wieder der Fachausdruck?).

    Muss mal schauen, wie ich das umsetzen kann, was Du schreibst. Am Ehesten würde ich nochmal auf die VGA-Option achten in den Start-Parametern. Ansonsten melde ich mich wieder hier...

    --

    Gruß,
    Felix

  4. #4

    Unhappy AW: Re: Kein Splash-Screen mehr nach Update auf OpenSuSE 11.3 auf Lenovo Thinkpad T60

    Quote Originally Posted by redkiwi View Post
    Der T60 hat einen Intel Grafikchip, oder?

    Vermutlich wird beim booten durch udev das Intel KMS aktiviert.
    Dies könnte erklären, weshalb der Splash-Screen ganz kurz angezeigt wird.

    Ich habe jetzt blöderweise die Fedora 14 Alpha auf meinem Test-Notebook mit Intel GPU installiert...

    Bei mir wird der Splash-Screen immer gleich deaktiviert (splash=silent), deshalb ist mir das vermutlich gar nicht aufgefallen

    Im Yast unter Bootloader kann soweit einiges eingestellt werden oder unter /boot/grub/menu.lst bzw. /etc/sysconfig/bootloader (SuSEconfig nicht vergessen.)

    Unter /etc/sysconfig/kernel kann KMS aktiviert bzw. deaktiviert werden (NO_KMS_IN_INITRD="no") bei änderung mkinitrd nicht vergessen.

    Wenn man KMS nutzen möchte oder muss, sollte in der "Grub Kernel Zeile" kein vga= oder gar nomodeset stehen
    Hallo,

    das klingt für mich alles sehr kryptisch. Meines Wissens verfügt der Laptop in der Tat über einen Intel-Grafikchip und zusätzlich noch ein zweites Grafikmodul (was war dafür wieder der Fachausdruck?).

    Muss mal schauen, wie ich das alles umsetzen kann, was Du schreibst. Am Ehesten würde ich nochmal auf die VGA-Option achten in den Start-Parametern. Ansonsten melde ich mich wieder hier...

    --

    Gruß,
    Felix

  5. #5
    Join Date
    Nov 2009
    Location
    Sulzbach/Ts., Germany
    Posts
    399

    Default AW: Re: Kein Splash-Screen mehr nach Update auf OpenSuSE 11.3 auf Lenovo Thinkpad T60

    Probier's mal ganz einfach indem du beim Starten als Bootoption nomodeset mitgibst (einfach im GRUB-Menü unten eintippen).

  6. #6

    Default AW: Re: Kein Splash-Screen mehr nach Update auf OpenSuSE 11.3 auf Lenovo Thinkpad T60

    Quote Originally Posted by lOtz1009 View Post
    Probier's mal ganz einfach indem du beim Starten als Bootoption nomodeset mitgibst (einfach im GRUB-Menü unten eintippen).
    Was genau bewirkt die Option nomodeset, wenn ich fragen darf? Inwiefern beeinflusst das die Performance meines Systems?

    F.

  7. #7
    Join Date
    Aug 2010
    Location
    Austria
    Posts
    170

    Default Re: AW: Re: Kein Splash-Screen mehr nach Update auf OpenSuSE 11.3 auf Lenovo Thinkpad T60

    nomodeset soll das aktivieren von KMS verhindern.
    Soweit ich weiß braucht der neue Intel Treiber KMS, außer du nimmst den alten (xorg-x11-driver-video-intel-legacy) Treiber.
    Ich persönlich würde den splash-screen einfach abschalten, die grünen done Meldungen sind doch eh viel cooler *g*

  8. #8

    Question AW: Re: Kein Splash-Screen mehr nach Update auf OpenSuSE 11.3 auf Lenovo Thinkpad T400

    Also...

    Quote Originally Posted by redkiwi View Post
    Der T60 hat einen Intel Grafikchip, oder?
    Zunächst mal muss ich mich korrigieren: es handelt sich nicht um ein T60, sondern um ein T400. In dem System werkelt übrigens zusätzlich noch ein ATI Mobility Radeon-Grafikchip. Das Widescreen Display zeigt das Formt 16:10.

    Sorry, mein Fehler. Scheint allerdings auch nichts wirklich zur Sache zu tun?

    Vermutlich wird beim booten durch udev das Intel KMS aktiviert.
    Dies könnte erklären, weshalb der Splash-Screen ganz kurz angezeigt wird.

    Im Yast unter Bootloader kann soweit einiges eingestellt werden oder unter /boot/grub/menu.lst bzw. /etc/sysconfig/bootloader (SuSEconfig nicht vergessen.)

    Unter /etc/sysconfig/kernel kann KMS aktiviert bzw. deaktiviert werden (NO_KMS_IN_INITRD="no") bei änderung mkinitrd nicht vergessen.
    Komischerweise war es genau andersum: die Einstellung NO_KMS_IN_INITRD="yes" hat mir den Splash-Screen wiedergebracht ("no" war bereits der Default-Wert)! Lässt sich das irgendwie erklären?

    Wenn man KMS nutzen möchte oder muss, sollte in der "Grub Kernel Zeile" kein vga= oder gar nomodeset stehen
    Demnach scheint es auch nichts zur Sache zu tun, dass man über Yast verschiedene Modi der VGA-Auflösung wählen kann? (War eingestellt auf 1280x800).

    Mit der Option nomodeset ist das graphische System übrigens gar nicht mehr hochgefahren (auf der Konsole mit dem Login-Prompt war Schluss)! Init 5 brachte dabei leider auch keine Fehlermeldung...

    --

    Würde mich sehr freuen, wenn ich hierzu noch ein wenig Input bekommen könnte,
    Felix

  9. #9
    Join Date
    Aug 2010
    Location
    Austria
    Posts
    170

    Default Re: Kein Splash-Screen mehr nach Update auf OpenSuSE auf Lenovo Thnikpad T60

    Zunächst mal muss ich mich korrigieren: es handelt sich nicht um ein T60, sondern um ein T400. In dem System werkelt übrigens zusätzlich noch ein ATI Mobility Radeon-Grafikchip. Das Widescreen Display zeigt das Formt 16:10.

    Sorry, mein Fehler. Scheint allerdings auch nichts wirklich zur Sache zu tun?
    Die freien treiber von ati, intel u. nvidia laufen per default ab openSUSE 11.3 mit KMS.
    Das ist mit einer der größten Unterschiede zum Vorgänger 11.2

    Komischerweise war es genau andersum: die Einstellung NO_KMS_IN_INITRD="yes" hat mir den Splash-Screen wiedergebracht ("no" war bereits der Default-Wert)! Lässt sich das irgendwie erklären?
    "no" ist der default Wert bei openSUSE 11.3.
    Mit "yes" wird KMS nicht schon in der initial ramdisk aktiviert, sondern erst später durch udev. Und das hat bei dir den Fehler behoben. KMS läuft noch nicht mit jeder GPU bzw. Hardwarekonstellation Bugfrei. Aber es wird von Kernelversion zu Kernelversion immer stabiler sowie zuverlässiger.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •