Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: YouTube Full Screen Stopped working after ati driver install

  1. #1

    Default YouTube Full Screen Stopped working after ati driver install

    In an effort to improve awful video performance (e.g. in maximized You Tube or simply scrolling the browser) of my new Suse 11.3 install on my new HP workstation with ATI Radeon HD 5770, I added the repository http://www2.ati.com/suse/11.3
    and installed "ATI "fglrx" driver kernel module for ATI Radeon HD 2000 and later."

    But now if I try to go full screen in YouTube, the browser screen gets maximized for an instant but then reverts to its original size with the original video window greyed out.

    This occurs in both Firefox and Chrome.

    After the Firefox failure, I following line appears in dmesg:
    npviewer.bin[15775]: segfault at 4 ip 00000000eec9e8d8 sp 00000000ffaf4110 error 4 in libGL.so.1.2[eec32000+b3000]

    If I run Chrome from the command line, after failure I see the following in the terminal:
    *** NSPlugin Wrapper *** ERROR: NPP_WriteReady() wait for reply: Connection reset by peer
    *** NSPlugin Wrapper *** WARNING/usr/src/packages/BUILD/nspluginwrapper-1.3.0/src/npw-wrapper.c:2394):invoke_NPP_Write: assertion failed: (rpc_method_invoke_possible(plugin->connection))
    *** NSPlugin Wrapper *** WARNING/usr/src/packages/BUILD/nspluginwrapper-1.3.0/src/npw-wrapper.c:2239):invoke_NPP_DestroyStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
    *** NSPlugin Wrapper *** WARNING/usr/src/packages/BUILD/nspluginwrapper-1.3.0/src/npw-wrapper.c:2123):invoke_NPP_URLNotify: assertion failed: (rpc_method_invoke_possible(plugin->connection))
    *** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
    *** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
    *** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
    *** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
    *** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!

    etc.

    I have all the latest Suse updates installed.
    Does anyone have a solution?
    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: YouTube Full Screen Stopped working after ati driver install

    Please confirm that you can run this in a terminal:
    Code:
    glxgears
    And post result of:

    Code:
    /usr/sbin/hwinfo --gfxcard | grep Driver
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: YouTube Full Screen Stopped working after ati driver install

    HPE-270f:~ # glxgears
    Segmentation fault

    HPE-270f:~ # /usr/sbin/hwinfo --gfxcard | grep Driver
    Driver Info #0:
    Driver Info #1:

  4. #4

    Default Re: YouTube Full Screen Stopped working after ati driver install

    Also: dmesg:

    [180747.537683] glxgears[17835]: segfault at 4 ip 00007ffc053b18be sp 00007fff09d1b120 error 4 in libGL.so.1.2[7ffc05357000+ad000]

    Thanks.

  5. #5
    Join Date
    Nov 2009
    Location
    /..
    Posts
    52

    Default Re: YouTube Full Screen Stopped working after ati driver install

    I had problems like this only it was with a Radeon X300. I eventually gave up on installing the proprietary drivers. However, based on your output of hwinfo, you are apparently not running a driver. The top post of this thread might help. It certainly helped when I had issues like this:
    How to downgrade from 11.2 to 11.1
    Linux motto: Here's the computer, just do stuff
    Dell Latitude D630: Core 2 Duo 2.00 GHz, 2GB RAM, 80 GB HDD, openSUSE 11.4, Windows Vista
    Weird people have all the fun

  6. #6

    Default Re: YouTube Full Screen Stopped working after ati driver install

    More Info:
    After my driver installation adventure (on Sunday) I noticed that the number of selections on my boot menu had doubled from two to four.

    Now I see:
    openSUSE 11.3-2.6.34-12 (default)
    Failsafe -- openSUSE 11.3-2.6.34-12 (default)
    Desktop -- openSUSE 11.3-2.6.34-12
    Failsafe -- openSUSE 11.3-2.6.34-12 (desktop)

    The first and third choices boot to a command prompt with no KDE.
    The second and forth choices (the Failsafes) bring up fully functioning KDE.
    The default selection is #3, which I suppose I was using before I started tinkering.

    Strange.

  7. #7
    Join Date
    Nov 2009
    Location
    /..
    Posts
    52

    Default Re: YouTube Full Screen Stopped working after ati driver install

    That's bizarre that the failsafes work but the others don't. Try manually selecting a run-level of 5 with the regular kernels (just type "5" (without the quotes) into the command line at boot).
    Linux motto: Here's the computer, just do stuff
    Dell Latitude D630: Core 2 Duo 2.00 GHz, 2GB RAM, 80 GB HDD, openSUSE 11.4, Windows Vista
    Weird people have all the fun

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,764

    Default Re: YouTube Full Screen Stopped working after ati driver install

    There are several flavors of the kernel. Normally desktop is the default kernel there is also one called default. It is confusing because default is not normally the default kernel for desktop operations and is optimized for servers. Desktop is optimized for desktops. You have managed to install both. That is the reason for the extra selections. There is no real problem other then operator confusion of having multiple kernels. It may cause problems in that different flavors have different source packages which are needed by the proprietary driver to dock itself to the kernel. It is probably best as a beginner to get rid of one of the kernels to reduce confusion.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: YouTube Full Screen Stopped working after ati driver install

    That failsafe works is NOT unusual, it one of the reasons it's there in the first place.
    I suggest you look at Lee's graphics thread:
    openSUSE Graphic Card Practical Theory Guide for Users
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: YouTube Full Screen Stopped working after ati driver install

    Thanks all.

    In YaST2 I see that I have the following installed:
    xorg-x11-driver-video-radeonhd
    ati-fglrxG02-kmp-default
    ati-fglrxG02-kmp-desktop
    x11-video-fglrxG02

    Could they be conflicting? Should some of these be removed?
    How can it appear that I no driver running when I have all of these installed?
    (Assuming "no driver running" is the correct interpretation of the following):

    HPE-270f:~ # /usr/sbin/hwinfo --gfxcard | grep Driver
    Driver Info #0:
    Driver Info #1:

    Leaving out the "grep Driver" I see:
    HPE-270f:~ # /usr/sbin/hwinfo --gfxcard
    34: PCI 700.0: 0300 VGA compatible controller (VGA)
    [Created at pci.318]
    Unique ID: aK5u.jG2WizdxKP9
    Parent ID: 3hqH.nd5a2INC039
    SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:07:00.0
    SysFS BusID: 0000:07:00.0
    Hardware Class: graphics card
    Model: "ATI 0x68B8"
    Vendor: pci 0x1002 "ATI Technologies Inc"
    Device: pci 0x68b8 "0x68B8"
    SubVendor: pci 0x103c "Hewlett-Packard Company"
    SubDevice: pci 0x6880
    Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
    Memory Range: 0xfbec0000-0xfbedffff (rw,non-prefetchable)
    I/O Ports: 0xe000-0xefff (rw)
    Memory Range: 0xfbea0000-0xfbebffff (ro,non-prefetchable,disabled)
    IRQ: 15 (no events)
    I/O Ports: 0x3c0-0x3df (rw)
    Module Alias: "pci:v00001002d000068B8sv0000103Csd00006880bc03sc00i00"
    Driver Info #0:
    XFree86 v4 Server Module: fglrx
    Driver Info #1:
    XFree86 v4 Server Module: fglrx
    3D Support: yes
    Extensions: dri
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #10 (PCI bridge)

    Primary display adapter: #34

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •