Results 1 to 6 of 6

Thread: KMail : Hangs, crashes, failed starts

  1. #1

    Default KMail : Hangs, crashes, failed starts

    I have been plagued by problems with KMail. Sometimes Akonadi server fails to start:

    Code:
     [
     0: akonadiserver(_Z11akBacktracev+0x39) [0x40c5d9]
     1: akonadiserver() [0x40cb42]
     2: /lib64/libc.so.6(+0x32a60) [0x7f2945530a60]
     3: /lib64/libc.so.6(gsignal+0x35) [0x7f29455309e5]
     4: /lib64/libc.so.6(abort+0x186) [0x7f2945531ee6]
     5: /usr/lib64/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x74)  [0x7f294670e984] 
     6: akonadiserver(_ZN15FileDebugStream9writeDataEPKcx+0xab) [0x40e45b]
     7: /usr/lib64/libQtCore.so.4(_ZN9QIODevice5writeEPKcx+0x77) [0x7f2946799c37]
     8: /usr/lib64/libQtCore.so.4(+0x103026) [0x7f29467a2026]
     9: /usr/lib64/libQtCore.so.4(_ZN11QTextStreamD1Ev+0x3b) [0x7f29467aaefb]
     10: /usr/lib64/libakonadiprivate.so.1(_ZN6QDebugD1Ev+0x4b) [0x7f2946b6147b]
     11: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer25startMysqlDatabaseProcessEv+0x33ea) [0x7f2946b6efca]
     12: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0x2e8) [0x7f2946b70288]
     13: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x76) [0x7f2946b706b6]
     14: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x4a) [0x7f2946b71dba]
     15: akonadiserver(main+0x217) [0x406767]
     16: /lib64/libc.so.6(__libc_start_main+0xfd) [0x7f294551cb7d]
     17: akonadiserver() [0x406459]
     ]
    At other points the program simply hangs and becomes unresponsive when sending an email. Then at a few other points it simply crashes out, out which point I submit a bug report.

    I really like KMail when it works. What can I do to improve things? Is there a more up to date Repository? Should I try KDE 4.5? When do the patches in bug reports make their way 'back down'?




    OS Information
    OS: Linux 2.6.34-12-desktop x86_64
    System: openSUSE 11.3 (x86_64)
    KDE: 4.4.4 (KDE 4.4.4) "release 2"

    Display Info
    Vendor: nVidia Corporation
    Model: GeForce GTX 275
    2D driver: nvidia
    3D driver: NVIDIA 256.35

    CPU Information
    Processor (CPU): Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz
    Speed: 2,673.69 MHz
    Cores: 4

    Memory Information
    Total memory (RAM): 11.8 GiB
    Free memory: 109.1 MiB (+ 11.1 GiB Caches)
    Free swap: 36.0 GiB

  2. #2
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: KMail : Hangs, crashes, failed starts


    What repositories are you using ?
    Have you tried updating kmail or maybe kde like you said, with kmail 1.13.5 and kde 4.5 it's running ok here (but translation).
    openSUSE Leap 42.2 , KDE Plasma 5

  3. #3

    Default Re: KMail : Hangs, crashes, failed starts

    I was using the Community Repositories. Running the Factory version of KDE actually prevented KDE from loading so far as the login screen.

    Reverting back and a few reboots seems to have taken care of the Akonadi problem. *fingers crossed*

  4. #4
    Join Date
    Jul 2010
    Location
    Paris, France
    Posts
    24

    Default Re: KMail : Hangs, crashes, failed starts

    I have the same behaviour with a fresh OpenSUSE 11.3 install.

    After thinking about what was happening I have found out that when you send email in KMail, it hangs until the message is sent.

    That means it hangs instead of going in the mail to send box. And then it goes direclty to the sent mail box.

    Pretty strange but I saw a bug opened in the KDE bug tracking system about this problem.

  5. #5
    Join Date
    Jul 2010
    Location
    Paris, France
    Posts
    24

    Default Re: KMail : Hangs, crashes, failed starts

    I can add that this bug is a new one with major status in the KDE bug tracking system :
    https://bugs.kde.org/show_bug.cgi?id=246101

  6. #6

    Default Re: KMail : Hangs, crashes, failed starts

    Akonadi server fails to start.

    If the data base for Akonadi is corrupted thing will not work right , Well, It don't work very good when it does start, Very disappointing. Should have not been release into the wild.That is for another thread.

    To fix the data base. In your home folder you will fined .local folder. In that folder you will see the a share folder. In the share folder delete the akonadi folder. Now start kmail.

    It has been awhile since I have had problems with it. When I first installed 11.3 , It was problematic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •