Results 1 to 3 of 3

Thread: Broken Yast Opensuse 11.3 :(

  1. #1

    Default Broken Yast Opensuse 11.3 :(

    So I have managed to break Yast.
    The last thing I did before breaking it was messing with the QT4 libs to get skype going.

    I have no problem with reinstalling, but I want to fully back up my account so I can retrieve my user and all my settings in the fresh install.

    Here is my output upon trying to launch Yast

    Any suggestions on how to fix, or how to backup my account properly so I can drop it back into a new installation?

    Can't locate Config.pm in @INC (@INC contains: /y2update/modules /root/.yast2/modules /usr/share/YaST2/modules /usr/lib/perl5/site_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.12.1 /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.1 /usr/lib/perl5/5.12.1/i586-linux-thread-multi /usr/lib/perl5/5.12.1 .) at /usr/lib/perl5/5.12.1/diagnostics.pm line 195.
    BEGIN failed--compilation aborted at /usr/lib/perl5/5.12.1/diagnostics.pm line 195.
    Compilation failed in require at /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi/YaST/YCP.pm line 119.
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi/YaST/YCP.pm line 119.
    Compilation failed in require at /usr/share/YaST2/modules/URLRecode.pm line 16.
    BEGIN failed--compilation aborted at /usr/share/YaST2/modules/URLRecode.pm line 16.
    Compilation failed in require.
    BEGIN failed--compilation aborted.
    y2base: perl.c:542: perl_destruct: Assertion `(my_perl->Iscopestack_ix) == 1' failed.
    YaST got signal 6 at YCP file /usr/share/YaST2/clients/sw_single.ycp:25
    /sbin/yast2: line 399: 19256 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Broken Yast Opensuse 11.3 :(

    If you have a /home partition, then just leaving that un-formatted will preserve all your data and settings.

    But before doing anything so drastic - please post result of:

    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Praha, CZ, EU
    Posts
    26

    Default Re: Broken Yast Opensuse 11.3 :(

    Config.pm is from the package perl-base. Try reinstalling it:
    Code:
    # zypper in -f perl-base
    If zypper says "nothing to do", remove the package before reinstallnig it:
    Code:
    # rpm -e --nodeps perl-base

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •