Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: strange problem with permission

  1. #1

    Default strange problem with permission

    suse 11.3 kde 4.4.4
    I dont remember what I did but when I restarted suse 11.3 a strange message just after the login and before the desktop was shown appeared, this:

    warning cannot open consolekit session:
    unable to open session:
    the permission of the setuidhelper is not correct

    and after the desktop was shown this other message:

    org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct

    Potresti non essere in grado di connetterti alla rete Bluetooth tramite questo computer
    that in english is something like this:
    It could be possible that you cannot connect to bluetooth network with this computer

    and knetworkmanager didn't start.

    any suggestion??
    thanks many many

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: strange problem with permission

    I don't know for sure what might be going on but why don't you try these two terminal commands. (Menu / System / Terminal / Konsole):

    Code:
    sudo rm /var/lib/NetworkManager/NetworkManager.state
    
    sudo /etc/init.d/network restart
    You must enter the root user password after each command to allow it to function. You might want to try restarting your computer after the second command. Let us know if this did any good or not.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: strange problem with permission

    I gave your command, but it gives me this:

    pla@linux-otqk:~> sudo rm /var/lib/NetworkManager/NetworkManager.state
    sudo: must be setuid root

    so I tryed to accesss as su, and it gives me this:

    pla@linux-otqk:~> su
    Password:
    su: impossibile impostare i gruppi: Operation not permitted
    that in English is something like :
    impossible to set groups: operation not permitted

    I cannot access to Yast it say me that the password is wrong, of course it is correct
    I can access to / without password and write on it

    I think it could be a permission problem, so I made this ls -l / may be it helps you to help me :-)

    pla@linux-otqk:~> ls -l /
    totale 140
    drwxrwxrwx 2 root root 4096 12 ago 09:38 bin
    drwxr-xr-x 4 root root 4096 23 lug 10:56 boot
    drwxrwxrwx 2 root root 4096 22 lug 22:38 crypt
    drwxrwxrwx 46 root root 12288 15 ago 18:34 dati
    drwxrwxrwx 17 root root 3760 17 ago 11:16 dev
    drwxrwxrwx 132 root root 12288 17 ago 11:16 etc
    drwxrwxrwx 6 root root 4096 29 lug 13:49 home
    drwxr-xr-x 4 root root 4096 12 ago 12:45 home-factory
    drwxrwxrwx 14 root root 4096 6 ago 17:08 lib
    drwxrwxrwx 10 root root 12288 6 ago 17:08 lib64
    drwxrwxrwx 2 root root 16384 22 lug 22:35 lost+found
    drwxrwxrwx 3 root root 4096 15 ago 17:33 media
    drwxrwxrwx 2 root root 4096 1 lug 20:58 mnt
    drwxrwxrwx 3 root root 4096 23 lug 14:15 opt
    drwxrwxrwx 2 root root 4096 12 ago 09:34 pla
    dr-xr-xr-x 158 root root 0 17 ago 2010 proc
    drwxrwxrwx 27 root root 4096 12 ago 09:44 root
    drwxrwxrwx 3 root root 12288 12 ago 09:43 sbin
    drwxrwxrwx 2 root root 4096 1 lug 20:58 selinux
    drwxrwxrwx 4 root root 4096 6 lug 07:39 srv
    drwxr-xr-x 30 root root 4096 17 ago 11:15 suse-factory
    drwxr-xr-x 12 root root 0 17 ago 2010 sys
    drwxrwxrwx 55 root root 4096 17 ago 11:25 tmp
    drwxrwxrwx 13 root root 4096 6 lug 07:39 usr
    drwxrwxrwx 15 root root 4096 6 lug 07:49 var
    drwxr-xr-x 1 root users 8192 6 ago 12:31 winvista
    pla@linux-otqk:~>

    many thanks

  4. #4

    Default Re: strange problem with permission

    FWIW,
    Mine looks like
    Code:
    tar@localhost:~> ls -l /
    total 125
    -rw-r--r--   1 root root      0 2010-03-24 07:48 1
    drwxr-xr-x   2 root root   4096 2010-08-11 08:12 bin
    drwxr-xr-x   4 root root   3072 2010-03-24 08:03 boot
    drwxr-xr-x  16 root root   3300 2010-08-14 08:35 dev
    drwxrwxrwt   2 root root   4096 2010-07-22 10:59 DOCUMENTS
    drwxr-xr-x 118 root root  12288 2010-08-17 04:05 etc
    drwxr-xr-x   8 root root   4096 2010-04-04 02:59 home
    drwxr-xr-x  11 root root   4096 2010-05-02 12:23 lib
    drwxr-xr-x   8 root root  12288 2010-07-31 08:17 lib64
    drwxrwxrwt  10 root users  4096 2010-07-05 09:57 local
    drwxr-xr-x   2 root root   4096 2010-06-08 18:34 local2
    drwxr-xr-x   2 root root   4096 2010-07-20 17:00 local3
    drwx------   2 root root  16384 2009-11-30 23:42 lost+found
    drwxr-xr-x   2 root root   4096 2010-08-08 16:42 media
    drwxr-xr-x   2 root root   4096 2010-07-18 16:52 mnt
    drwxr-xr-x   4 root root   4096 2010-02-16 13:37 opt
    dr-xr-xr-x 140 root root      0 2010-08-14 03:27 proc
    drwx------  32 root root   4096 2010-08-16 14:30 root
    drwxr-xr-x   3 root root  12288 2010-08-11 08:12 sbin
    drwxr-xr-x   2 root root   4096 2009-10-23 22:08 selinux
    drwxr-xr-x   5 root root   4096 2009-11-30 23:50 srv
    drwxr-xr-x  12 root root      0 2010-08-14 03:27 sys
    drwxrwxrwt  28 root root   4096 2010-08-17 04:56 tmp
    drwxr-xr-x  13 root root   4096 2009-11-02 17:49 usr
    drwxr-xr-x  15 root root   4096 2009-11-02 18:08 var
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: strange problem with permission

    pier andreit wrote:
    > I think it could be a permission problem, so I made this ls -l / may be
    > it helps you to help me :-)


    show us the output of these

    Code:
    ls -hal /home
    ls -hal /home/pla/.*autho*
    sudo ls -hal /root/.*autho*
    sudo ls -hal /etc/pas*
    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: strange problem with permission

    Quote Originally Posted by pier_andreit View Post
    pla@linux-otqk:~> ls -l /
    totale 140
    drwxrwxrwx 2 root root 4096 12 ago 09:38 bin
    drwxr-xr-x 4 root root 4096 23 lug 10:56 boot
    drwxrwxrwx 2 root root 4096 22 lug 22:38 crypt
    drwxrwxrwx 46 root root 12288 15 ago 18:34 dati
    drwxrwxrwx 17 root root 3760 17 ago 11:16 dev
    drwxrwxrwx 132 root root 12288 17 ago 11:16 etc
    drwxrwxrwx 6 root root 4096 29 lug 13:49 home
    drwxr-xr-x 4 root root 4096 12 ago 12:45 home-factory
    drwxrwxrwx 14 root root 4096 6 ago 17:08 lib
    drwxrwxrwx 10 root root 12288 6 ago 17:08 lib64
    drwxrwxrwx 2 root root 16384 22 lug 22:35 lost+found
    drwxrwxrwx 3 root root 4096 15 ago 17:33 media
    drwxrwxrwx 2 root root 4096 1 lug 20:58 mnt
    drwxrwxrwx 3 root root 4096 23 lug 14:15 opt
    drwxrwxrwx 2 root root 4096 12 ago 09:34 pla
    dr-xr-xr-x 158 root root 0 17 ago 2010 proc
    drwxrwxrwx 27 root root 4096 12 ago 09:44 root
    drwxrwxrwx 3 root root 12288 12 ago 09:43 sbin
    drwxrwxrwx 2 root root 4096 1 lug 20:58 selinux
    drwxrwxrwx 4 root root 4096 6 lug 07:39 srv
    drwxr-xr-x 30 root root 4096 17 ago 11:15 suse-factory
    drwxr-xr-x 12 root root 0 17 ago 2010 sys
    drwxrwxrwx 55 root root 4096 17 ago 11:25 tmp
    drwxrwxrwx 13 root root 4096 6 lug 07:39 usr
    drwxrwxrwx 15 root root 4096 6 lug 07:49 var
    drwxr-xr-x 1 root users 8192 6 ago 12:31 winvista
    All those directories with mode 777 are not good. Either you have a serious disk error, or you followed some bad advice to chmod everything 777. This will muck up with programs that are paranoid and expect their files and directories to be only root accessible.

    If you don't have much data of value on the system, I would recommend a reinstall.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: strange problem with permission

    > All those directories with mode 777 are not good.

    NICE catch Ken! (i totally missed it!)


    > Either you have a
    > serious disk error, or you followed some bad advice to chmod everything
    > 777.


    sounds like *buntu advice to me...disastrous advice imho..


    > If you don't have much data of value on the system, I would recommend a
    > reinstall.


    +1
    777 is a great way to insure permission problems..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  8. #8

    Default Re: strange problem with permission

    Quote Originally Posted by pier_andreit View Post
    I gave your command, but it gives me this:
    Code:
    pla@linux-otqk:~> ls -l /
    totale 140
    drwxrwxrwx   2 root root   4096 12 ago 09:38 bin
    drwxr-xr-x   4 root root   4096 23 lug 10:56 boot
    drwxrwxrwx   2 root root   4096 22 lug 22:38 crypt
    drwxrwxrwx  46 root root  12288 15 ago 18:34 dati
    drwxrwxrwx  17 root root   3760 17 ago 11:16 dev
    drwxrwxrwx 132 root root  12288 17 ago 11:16 etc
    drwxrwxrwx   6 root root   4096 29 lug 13:49 home
    drwxr-xr-x   4 root root   4096 12 ago 12:45 home-factory
    drwxrwxrwx  14 root root   4096  6 ago 17:08 lib
    drwxrwxrwx  10 root root  12288  6 ago 17:08 lib64
    drwxrwxrwx   2 root root  16384 22 lug 22:35 lost+found
    drwxrwxrwx   3 root root   4096 15 ago 17:33 media
    drwxrwxrwx   2 root root   4096  1 lug 20:58 mnt
    drwxrwxrwx   3 root root   4096 23 lug 14:15 opt
    drwxrwxrwx   2 root root   4096 12 ago 09:34 pla
    dr-xr-xr-x 158 root root      0 17 ago  2010 proc
    drwxrwxrwx  27 root root   4096 12 ago 09:44 root
    drwxrwxrwx   3 root root  12288 12 ago 09:43 sbin
    drwxrwxrwx   2 root root   4096  1 lug 20:58 selinux
    drwxrwxrwx   4 root root   4096  6 lug 07:39 srv
    drwxr-xr-x  30 root root   4096 17 ago 11:15 suse-factory
    drwxr-xr-x  12 root root      0 17 ago  2010 sys
    drwxrwxrwx  55 root root   4096 17 ago 11:25 tmp
    drwxrwxrwx  13 root root   4096  6 lug 07:39 usr
    drwxrwxrwx  15 root root   4096  6 lug 07:49 var
    drwxr-xr-x   1 root users  8192  6 ago 12:31 winvista
    pla@linux-otqk:~>
    many thanks
    Pier_andreit, you should check how bad the permission problem might be. It could be just the root folders and none of the sub-folders.
    Code:
      
    ls -halR   /var/    | less 
    
    ##      or 
    ls -halR   /bin/    | less
    If these are not uniformly 0777 then fix the root folders.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  9. #9

    Default Re: strange problem with permission

    thanks to everybody, I tried to update with the 11.3 dvd, it seems that everything gone well,
    ls -l / after update:
    Code:
    pla@linux-otqk:~> ls -l /
    totale 140
    drwxr-xr-x   2 root root   4096 12 ago 09:38 bin
    drwxr-xr-x   4 root root   4096 19 ago 20:18 boot
    drwxrwxrwx   2 root root   4096 22 lug 22:38 crypt
    drwxrwxrwx  47 root root  12288 19 ago 09:53 dati
    drwxr-xr-x  18 root root   4000 20 ago 19:09 dev
    drwxr-xr-x 133 root root  12288 20 ago 19:10 etc
    drwxr-xr-x   6 root root   4096 29 lug 13:49 home
    drwxr-xr-x   4 root root   4096 12 ago 12:45 home-factory
    drwxr-xr-x  14 root root   4096  6 ago 17:08 lib
    drwxrwxrwx  10 root root  12288 19 ago 19:45 lib64
    drwxrwxrwx   2 root root  16384 22 lug 22:35 lost+found
    drwxrwxrwx   3 root root   4096 15 ago 17:33 media
    drwxrwxrwx   2 root root   4096  1 lug 20:58 mnt
    drwxr-xr-x   3 root root   4096 23 lug 14:15 opt
    drwxrwxrwx   2 root root   4096 12 ago 09:34 pla
    dr-xr-xr-x 191 root root      0 20 ago  2010 proc
    drwx------  28 root root   4096 19 ago 18:55 root
    drwxr-xr-x   3 root root  12288 19 ago 19:45 sbin
    drwxrwxrwx   2 root root   4096  1 lug 20:58 selinux
    drwxrwxrwx   4 root root   4096  6 lug 07:39 srv
    drwxr-xr-x  30 root root   4096 19 ago 17:22 suse-factory
    drwxr-xr-x  12 root root      0 20 ago  2010 sys
    drwxrwxrwt  56 root root   4096 20 ago 19:11 tmp
    drwxr-xr-x  13 root root   4096  6 lug 07:39 usr
    drwxrwxrwx  15 root root   4096  6 lug 07:49 var
    drwxr-xr-x   1 root users  8192  6 ago 12:31 winvista
    pla@linux-otqk:~>
    network manager starts and the error messages doesn't appear anymore

  10. #10
    Join Date
    Jun 2009
    Location
    Pennsylvania, USA
    Posts
    233

    Default Re: strange problem with permission

    pier andreit wrote:

    >
    > thanks to everybody, I tried to update with the 11.3 dvd, it seems that
    > everything gone well,
    > ls -l / after update:
    >
    > Code:
    > --------------------
    > pla@linux-otqk:~> ls -l /
    > totale 140
    > drwxr-xr-x 2 root root 4096 12 ago 09:38 bin
    > drwxr-xr-x 4 root root 4096 19 ago 20:18 boot
    > drwxrwxrwx 2 root root 4096 22 lug 22:38 crypt
    > drwxrwxrwx 47 root root 12288 19 ago 09:53 dati
    > drwxr-xr-x 18 root root 4000 20 ago 19:09 dev
    > drwxr-xr-x 133 root root 12288 20 ago 19:10 etc
    > drwxr-xr-x 6 root root 4096 29 lug 13:49 home
    > drwxr-xr-x 4 root root 4096 12 ago 12:45 home-factory
    > drwxr-xr-x 14 root root 4096 6 ago 17:08 lib
    > drwxrwxrwx 10 root root 12288 19 ago 19:45 lib64
    > drwxrwxrwx 2 root root 16384 22 lug 22:35 lost+found
    > drwxrwxrwx 3 root root 4096 15 ago 17:33 media
    > drwxrwxrwx 2 root root 4096 1 lug 20:58 mnt
    > drwxr-xr-x 3 root root 4096 23 lug 14:15 opt
    > drwxrwxrwx 2 root root 4096 12 ago 09:34 pla
    > dr-xr-xr-x 191 root root 0 20 ago 2010 proc
    > drwx------ 28 root root 4096 19 ago 18:55 root
    > drwxr-xr-x 3 root root 12288 19 ago 19:45 sbin
    > drwxrwxrwx 2 root root 4096 1 lug 20:58 selinux
    > drwxrwxrwx 4 root root 4096 6 lug 07:39 srv
    > drwxr-xr-x 30 root root 4096 19 ago 17:22 suse-factory
    > drwxr-xr-x 12 root root 0 20 ago 2010 sys
    > drwxrwxrwt 56 root root 4096 20 ago 19:11 tmp
    > drwxr-xr-x 13 root root 4096 6 lug 07:39 usr
    > drwxrwxrwx 15 root root 4096 6 lug 07:49 var
    > drwxr-xr-x 1 root users 8192 6 ago 12:31 winvista
    > pla@linux-otqk:~>
    > --------------------
    >
    > network manager starts and the error messages doesn't appear
    > anymore
    >
    >

    You still have some serious permission problems with your system; /var,
    /srv, /lib64, and several others should NOT be mode 777, and that's only for
    the root directory. It looks like someone set everything to 777, then the
    update ran /etc/permissions. You probably should look at some of the
    subdirectories in /etc, /var or /usr; if they are mode 777 you haven't fixed
    everything yet.

    If I were you, I would do a complete, clean install - that's the only way to
    guarantee everything is back to reasonable security.



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •