Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Memory usage 100% = auto log out :(

  1. #1
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Memory usage 100% = auto log out :(

    Well I have searched the forums, looked through google and still cannot find the answer. My memory usage keeps building up and up as time goes by, when it hits 100% it logs me out. I have a tad over 9 Gib in swap, that is how it was set up when I did auto install and let it do the partitions. I have 4Gib memory. When i first log in it shows about about 800+ MB being used and starts adding more from there. I can run applications for about 6-8 hours before it hits the 100% marker. At first I was blaming this on the video player, but when I put on a play list each song seems like it gets stuck in memory also adding about .02% per song to max memory. This seems to pertain to each application I do.



    Uploaded with ImageShack.us

    This pic shows my Computer setting and usage through system monitor and conky script. In another note, I never see my Swap partition being used at all. I am real green to linux and not sure if I was suppose to turn something on. In the partitioner it shows it being mounted and as swap.
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: Memory usage 100% = auto log out :(

    OpenSuse version ???

    9 gig is over kill for swap but should real not cause a problem.

    also might want to see if you are running out of space on root due to temp files.

    df /

  3. #3
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Re: Memory usage 100% = auto log out :(

    Code:
    opensuse version 11.3
    Linux Artista3 2.6.35-20-default #1 SMP 2010-08-11 06:08:17 +0200 x86_64 x86_64 x86_64 GNU/Linux
    I did a fresh install yesterday to see if it would fix the problem, yet no luck, I have tried the 2.6.35 kernel default and desktop, same results. I upgraded to kde 4.5 day before yesterday and it crashed a lot faster (auto log)

    Is there a way to log memory usage, that tells me what is going into memory and what is leaving so I can see if one or more items is stacking up?

    /root is 4.7Gib out of 98.4Gib and /home is on its own partition still 84% free space
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

  4. #4
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Memory usage 100% = auto log out :(

    @Artista: which KDE Widget is it you have running on the right side of the desktop? I really like that: it shows "top processes", etc.
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  5. #5
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Re: Memory usage 100% = auto log out :(

    that is Conky, really lite weight script to keep track of everything. If you want to know how to set it up easy let me know, can show you how to make it transparent on KDE. You need to download Conky and Feh both are on opensuse download page.
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

  6. #6
    Carlos E. R. NNTP User

    Default Re: Memory usage 100% = auto log out :(

    On 2010-08-13 17:36, Artista wrote:
    >
    > Well I have searched the forums, looked through google and still cannot
    > find the answer. My memory usage keeps building up and up as time goes
    > by, when it hits 100% it logs me out. I have a tad over 9 Gib in swap,
    > that is how it was set up when I did auto install and let it do the
    > partitions. I have 4Gib memory. When i first log in it shows about about
    > 800+ MB being used and starts adding more from there. I can run
    > applications for about 6-8 hours before it hits the 100% marker. At
    > first I was blaming this on the video player, but when I put on a play
    > list each song seems like it gets stuck in memory also adding about .02%
    > per song to max memory. This seems to pertain to each application I do.


    Use "top" on a terminal, sorting by memory (key 'M') to find out what applications are using that
    amount of memory. You are probably using a buggy application that eats it.

    There is also a system that can log usage data to files. I think it is "sysstat", but I don't really
    know how to make use of it.



    > In another note, I never see my Swap partition being used
    > at all. I am real green to linux and not sure if I was suppose to turn
    > something on. In the partitioner it shows it being mounted and as swap.


    The partitioner can say that swap was reserver for use, but doesn't say if it is really activated
    for use. Do

    grep swap /etc/fstab

    You need a line similar to this:

    LABEL=a_swap swap swap pri=-1 0 0


    (because I named or labeled the swap partition, but that is not the only method)



    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Elessar))

  7. #7
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Re: Memory usage 100% = auto log out :(

    My /etc/fstab was made by defualt and it looks like this

    Code:
    /dev/disk/by-id/ata-WDC_WD2500KS-00MJB0_WD-WCANK3670031-part5 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-WDC_WD2500KS-00MJB0_WD-WCANK3670031-part1 /                    ext4       acl,user_xattr        1 1
    /dev/disk/by-id/ata-WDC_WD6400AAKS-00A7B2_WD-WCASY6559646-part2 /Storage             ntfs-3g    default               0 0
    /dev/disk/by-id/ata-WDC_WD6400AAKS-00A7B2_WD-WCASY6559646-part1 /Windows7            ntfs-3g    default               0 0
    /dev/disk/by-id/ata-WDC_WD2500KS-00MJB0_WD-WCANK3670031-part3 /home                ext4       acl,user_xattr        1 2
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    So the the line that you are showing I do not see. so guess mine looks more like swap swap defaults 0 0

    On a side note, early early this morning a got a patch that downloaded, not sure what the patch was for but after its fix I have yet to encounter the issue of auto-logging out. Though memory will stand around 99% while watching a dvd, but at least now it drops back down to 63% memory use when I turn it off.

    Swap at this point is still not accepting anything and sits a 0% used.

    xorg #1 143Mib give or take + - 5Mib jumps
    FireFox #2 128Mib give or take + - 5Mib jumps
    Plasma-desktop 21Mib and they start dropping from there, those are the top 3
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

  8. #8
    Carlos E. R. NNTP User

    Default Re: Memory usage 100% = auto log out :(

    On 2010-08-15 05:36, Artista wrote:
    >
    > My /etc/fstab was made by defualt and it looks like this
    >
    >
    > Code:
    > --------------------
    > /dev/disk/by-id/ata-WDC_WD2500KS-00MJB0_WD-WCANK3670031-part5 swap swap defaults 0 0


    This is the line.

    Does it have an empty space at the start? Remove it.

    Do

    Code:
    file -s /dev/disk/by-id/ata-WDC_WD2500KS-00MJB0_WD-WCANK3670031-part5
    The answer should be something like:

    /dev/sda6: Linux/i386 swap file (new style) 1 (4K pages) size 2620594 pages Label a_swap

    If it says something else, your line in fstab is bad. Either the swap partition is another one, or
    it is not a swap.

    You can run something like this:

    Code:
    file -s /dev/sda* | grep swap
    To find where it is. Then find the correct ID and correct the fstab line.


    If fstab is indeed correct, and it points to a swap partition, run:

    Code:
    swapon -s
    If it says nothing, then activate the swap partition with "swapon -a". See if it complains of
    something and report back. You can also give swapon the device name of the partition to activate as
    swap. If this one also fails, perhaps the swap partition is bad: then remake it:

    Code:
    mkswap -c L A_name_you_choose /dev/whatever
    Don't give the incorrect device name or you will destroy another partition.

    Once done, activate that swapspace with swapon as above.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Elessar))

  9. #9
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Re: Memory usage 100% = auto log out :(

    Ok I tried what you said and still no luck. Here is a little better view of what is going on.


    If I go to the partitioner and look at the fstab options it shows no selected options in the fstab file. (as you can see in the picture) I am not sure but all the other mount points have "/" in front of them other the swap one is that right? I also ran the commands you told me too and I keep getting errors.

    Code:
     jennifer@Artista3:~> sudo mkswap -c L swap /dev/sdb5
    sudo: mkswap: command not found
    Or do I need to run that as init 3? or can I add the commands through the partitioner. When you said I could destroy another partition it made me a tad nervous.

    print out for other command...
    Code:
    jennifer@Artista3:~> file -s /dev/disk/by-id/ata-WDC_WD2500KS-00MJB0_WD-WCANK3670031-part5
    /dev/disk/by-id/ata-WDC_WD2500KS-00MJB0_WD-WCANK3670031-part5: symbolic link to `../../sdb5'
    Sorry for all the questions, the last Fstab file I did I remade with all UUID and the way this one is set up has me all mixed up....I do not recall swap having the default option? I may go ahead and try to re-do this one from scratch and write it all in UUID, though I have heard some problems going that route. But the 5 times I have installed Opensuse (re-installs from trial and error) it has done this set up with the swap partition.
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

  10. #10
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Re: Memory usage 100% = auto log out :(

    ok rewrote the /etc/fstab file and got to the point were you were showing.

    Code:
    jennifer@Artista3:~> su -l root
    Password: 
    Artista3:~ # file -s /dev/sdb5
    /dev/sdb5: Linux/i386 swap file (new style) 1 (4K pages) size 2456319 pages
    Artista3:~ # file -s /dev/sdb* | grep swap
    /dev/sdb5: Linux/i386 swap file (new style) 1 (4K pages) size 2456319 pages
    Artista3:~ # swapon -s
    Filename                                Type            Size    Used    Priority
    /dev/sdb5                               partition       9825276 0       -1
    Artista3:~ #
    I opened up a web browser (fire fox) started a dvd (kafeine) and have sys monitor up and a terminal trying to put a load on the sys, but swap still shows no activity. So am I still missing something or does it take a heavy load? I was also looking around and found people in Ubuntu forums same problem, no answer....As far as swap not doing anything.
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •