Results 1 to 9 of 9

Thread: kwin and Xorg sporadically consuming CPU

  1. #1

    Default kwin and Xorg sporadically consuming CPU

    Hi all,

    I am using openSUSE 11.2 x64 with KDE 4.3.5.

    I am experiencing sudden, sporadic drops in performance due to the kwin and Xorg processes suddenly consuming large amounts of CPU for a few minutes (maybe 30-40% each) before dropping back to normal (1-3% each). I am seeing this using top.

    Any suggestions what I can do to find the cause of and correct this?

    Many thanks!

  2. #2
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: kwin and Xorg sporadically consuming CPU

    In most cases, you can fix these by using the NVIDIA/ATI/INTEL drivers for your graphics card. What graphics card do you have and did you install a proprietary driver?
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  3. #3

    Default Re: kwin and Xorg sporadically consuming CPU

    I have an NVIDIA Quadro FX 2700M and I did install the proprietary driver.

    From dmesg:
    [ 9.814874] nvidia: module license 'NVIDIA' taints kernel.
    [ 10.251726] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010

    Here is my xorg.conf:

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildmeister@builder58) Fri Mar 12 02:13:46 PST 2010


    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection

    Section "Files"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "IQT HDIT22W DSUB"
    HorizSync 31.0 - 82.0
    VertRefresh 56.0 - 76.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "Quadro FX 2700M"
    Option "UseEdidDpi" "FALSE"
    Option "DPI" "96 x 96"
    EndSection

    Section "Screen"

    # Removed Option "TwinViewXineramaInfoOrder" "CRT-0"
    # Removed Option "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
    # Removed Option "metamodes" "CRT: 1920x1080 +0+0, DFP-0: nvidia-auto-select +1920+0, DFP-1: NULL"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "DFP-1"
    Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1920+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,391
    Blog Entries
    1

    Default Re: kwin and Xorg sporadically consuming CPU

    Maybe this is a powermizer issue? (I don't have nvidia hardware, so only a guess on my part, but it does cause problems for some users when dynamically switching between clock frequencies).

    nVidia PowerMizer powersaving/cooling in Linux (updated) | Nobody was Born with Linux Knowledge

    NVidia Powermizer - how to tweak ??

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,391
    Blog Entries
    1

    Default Re: kwin and Xorg sporadically consuming CPU

    Edit: Double post.
    Last edited by deano_ferrari; 13-Aug-2010 at 14:30. Reason: Accidental double-post

  6. #6
    Join Date
    Aug 2010
    Location
    Linden, NJ, USA
    Posts
    39

    Default Re: kwin and Xorg sporadically consuming CPU

    I believe this might be the "resolved" bug https://bugzilla.novell.com/show_bug.cgi?id=584919 that it seems you're still experiencing and I am also on OpenSuse 11.3.

  7. #7

    Default Re: kwin and Xorg sporadically consuming CPU

    Thanks for the ideas. I think it is less likely it is the bug since I don't have KDE 4.4. I am investigating the PowerMizer possibility first and will report back once that process is complete.

  8. #8

    Default Re: kwin and Xorg sporadically consuming CPU

    I updated my NVIDIA driver and KDE to 4.4.4 but things got catastrophically worse with applications like firefox for example churning away at 100%. I downgraded my NVIDIA driver back to 195.36.15 from 256.44 and everything went back to normal with no issues with kwin, xorg or anything else.

    It seems the 256.44 kernel module caused all sorts of issues. I'm not sure then if it was the upgrade to KDE 4.4.4 or the NVIDIA reinstall that improved things but I'll take it.

    It takes a bit of getting used to in Linux how a simple upgrade can really clobber your system!

  9. #9

    Default Re: kwin and Xorg sporadically consuming CPU

    This has now been narrowed down a bit. When the symptoms occur (i.e. Xorg/kwin consuming CPU and load average shooting up), if I remove AC power to the laptop, as soon as openSUSE displays the notification that power has been removed, top shows the CPU usage return to normal. After plugging the power back it things continue normally for a few minutes before it occurs again. This is repeatable and reproducible.

    Clearly this is something to-do with power management or fan/clock control etc. Any ideas what it might be and what I can do about it other than the NVIDIA settings? I'm still working on getting those to work.

    Many thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •