Results 1 to 3 of 3

Thread: Kernel-syms

  1. #1
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Kernel-syms

    I was trying to get the package ready to install my Graphics card to the new update. This is the problem that I am having.

    Code:
    Problem: nothing provides kernel-devel = 2.6.35-21 needed by kernel-syms-2.6.35-21.1.x86_64
     Solution 1: do not install kernel-syms-2.6.35-21.1.x86_64
     Solution 2: break kernel-syms by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): c
    Now the vanilla kernel is 2.6.35-21 were as the "default" opensuse one is 2.6.35-20. I have googled and told opensuse download search engine to look for the 2.6.35-20. I cannot find it at all.

    If I upgraded to the vanilla kernel without the opensuse patches would it make my machine unstable? Or can I tell it to break some of the dependencies?
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Kernel-syms

    So when I check our repo I only see 2.6.35-20.1 and are you saying you have installed 2.6.35-21.? Here is the location I am using which seems to have the Kernel-syms file.

    Code:
    http://ftp.yandex.ru/opensuse/repositories/Kernel:/HEAD/openSUSE_11.3/
    No one is really going to help all that much when you use a kernel higher that 2.6.34 and moving beyond the above repository does not seem wise. I suggest using a release for a while and not updating every few days unless there is a very good reason to do so. I would think you could load the 2.6.35-20.1 version and you would be OK.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Aug 2010
    Location
    Oklahoma
    Posts
    30

    Default Re: Kernel-syms

    I did get the graphics driver to work and yes the update was cause I could not play a game with the 2.6.34 Kernel, it had issues with wine. I went ahead and told it to break it dependencies for the Kernel-syms 2.6.35-21 even though I was running 2.6.35-20 and it worked fine. Wine is up and running and able to play the game just fine. Also there were no issues installing my ATI graphics card the hard way.
    ~Posted by: 01010 00101 01110 01110 01001 00110 00101 10010 or Jenn for short >.>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •