Results 1 to 4 of 4

Thread: x11vnc: several keyboard problems

  1. #1

    Default x11vnc: several keyboard problems

    Hi,
    I've just updated to 11.3 and I found myself having a small problem with x11vnc. I've been accessing to a 11.1 based system with this vnc server with no problems for a very long time, but with 11.3 i found myself unable to type capital letters, or use shortcuts involving shift/ctrl/alt gr. I can still type it anywhere locally and copy-paste it through vnc, but it's really anoying. It also seems long press in keys like the arrows (to navigate through text) don't work either

    To start the server I'm using a shotcut in ~./kde4/Autostart/ with the command:
    x11vnc -shared -allinput -forever -desktop XXX

    Any ideas?

  2. #2

    Default Re: x11vnc: several keyboard problems

    I think some of your problems may be solved by using the "-xkb" option to x11vnc.

    I believe -xkb is on by default now starting with x11vnc 0.9.11.

  3. #3

    Default Re: x11vnc: several keyboard problems

    Adding this option fixed it, thanks!

  4. #4

    Default Re: x11vnc: several keyboard problems

    I believe -xkb is on by default now starting with x11vnc 0.9.11.
    Actually, it is on by default since 0.9.10 released in May of this year.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •