Results 1 to 6 of 6

Thread: Amarok won't play audio

  1. #1
    Join Date
    Aug 2010
    Location
    The Netherlands
    Posts
    4

    Default Amarok won't play audio

    Hi, I've just installed suse 11.3 and installed the necessary mp3/ogg etc packages for Amarok.

    But amarok just keeps crashing when i try to play an audio cd, mp3 or radio stream.

    something about segmentation fault, but not enough data for a bug report.

    Kaffeine plays audio like a charm, but amarok seems only able to crash.

    I really hate any not working programs on my computer, so what can i do to solve this?

    solving meaning:
    1) get rid of amarok, but keep kaffeine playing every format.
    2) fix amarok so it plays audio.

    I am really a noob to linux and not a big fan of the terminal. So please give step by step explanation, thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: Amarok won't play audio

    I presume you followed the media tutorial since you said Kaffeine plays audio fine. I personally would try and update Amarok to the latest version in the KDE updated applications repository.

    (I don't know if this is the names are correct as I am now at work on a windows pc but you should be able to find what I'm talking about).
    Do the following: Open YaST -> Software -> Software Repositories.
    Then, in the menu: Configured Software Repositories-> Repositories.
    Now hit the Add -> Community Repositories, and select: KDE UpdatedApps
    Add the repository and accept the key when prompted. Click Ok to exit.Now go to YaST -> Software -> Software Management. Over on the left click on view and select Repositories. This should give you a list of all repositories you have
    Click on the KDE Updatedapps repository. The view window will now show all packages in this repository.
    Click on amarok and select update.
    This should update Amarok to the latest version.

    If that doesn't work I would consider clearing Amarok's configuration and cache by removing /home/*username here*/.kde4/share/apps/amarok/ with Dolphin. You will have to enable the viewing of hidden files as all folders with a . in front of them are hidden folder.

    Ok, try this and see if you get it working.
    "To err is human... to really foul up requires the root password."

  3. #3
    Join Date
    Aug 2010
    Location
    The Netherlands
    Posts
    4

    Default Re: Amarok won't play audio

    hmm it didn't work....

    I used the one-click solution for the media update of non-standard-supported audio files before.

    Actually in suse 10.3 i could not get Amarok to play any sound either....weird isn't it.

    So what files/folders do I exactly remove?

    It's not a big deal, because kafeine / vlc / mplayer work perfectly

    (used yast installer to find, download and install the mplayer, because it states everywhere its THE program to play audio/video).

    thanks for the help. maybe i'll learn what i did wrong / went wrong some day

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Amarok won't play audio

    Follow this
    Multi-media and Restricted Format Installation Guide

    Look at it carefully
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Aug 2010
    Location
    The Netherlands
    Posts
    4

    Default Re: Amarok won't play audio

    I followed the guide by adding those repos.

    don't really understand this one" You will install one package from VLC: libdvdcss Install this Package FIRST. That's it!! Then REMOVE this repo. "

    why delete it?

    btw i didnt add that one first, but i guess its a dvd codec?

    so i assume not relevant to the crashing of amarak when trying to play mp3, wav, cdaudio or internetradio.

    Didn't stop preventing Amarok from crashing when trying to play any audio, so I uninstalled Amarok.

    Maybe the solution didn;t work because I already did the one click solution before?

    anyway, solved...kind of. tnx for the help!

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Amarok won't play audio

    libdvdcss is the package you install, and because we want only that package from that repository, we remove the repository. The package however, remains.

    I'd be interest to see your repo list, because amarok works perfectly. You can post it by entering this in a terminal and posting the result:

    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •