Results 1 to 9 of 9

Thread: Sticky Resource Monitor in KDE?

  1. #1
    Join Date
    Aug 2008
    Location
    Ames, IA
    Posts
    8

    Default Sticky Resource Monitor in KDE?

    Does anyone else have a resource monitor appearing on their KDE desktop? My is in the upper-right corner, and lies on top of all other windows. I can work with windows beneath it alright, but it is always showing.

    The resource monitor is always translucent, and appears to have some sort of vertical "thermometer"-style usage scale on its left side. Beside that are two scrolling graphs. The only text/label appears to be a percentage that matches the thermometer bar, but there is nothing to tell me what resources are being monitored.

    Regardless, I use other resource monitoring software and I do not want this one on my desktop. Any suggestions for how I can remove this?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Sticky Resource Monitor in KDE?

    Right click on the desktop and make sure widgets are unlocked.
    Hover over the Resource Monitor and you should get a handle appear to one edge with a selection of options, but one of them should be a X, if you click that it should go.

    Now right click the desktop and Lock Widgets
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,372
    Blog Entries
    1

    Default Re: Sticky Resource Monitor in KDE?

    Unlock the widgets (Right-clicking on desktop should present this option). From there you should be able to delete this widget.

  4. #4
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Sticky Resource Monitor in KDE?

    Why is this on top of all other windows? Is that even possible with plasma widgets?

  5. #5
    Join Date
    Aug 2008
    Location
    Ames, IA
    Posts
    8

    Default Re: Sticky Resource Monitor in KDE?

    Thank you for the quick replies!

    My widgets were already unlocked, and hovering over this resource monitor doesn't show the usual icons to move/delete/options/etc. I did make it disappear by turning off compositing, leading me to believe that the graphics card usage is being displayed. I have an NVIDIA GeForce 8600 GT and I'm using the NVIDIA drivers (installed the "hard" way using through runlevel 3 rather than YaST). Since I now know that turning off compositing will remove the monitor I can address the issue if needed, but I'd love to know how I can keep compositing active while removing the monitor.

    I apologize for referring to the monitor as a "widget". I was using the term as a synonym for "do-hickey" as opposed to the SUSE definition of "widget".

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Sticky Resource Monitor in KDE?

    I have never come across this and doubt it has anything to do with the graphics driver or compositing.

    If you create a new user account and enable desktop effects, do still see it?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Sticky Resource Monitor in KDE?

    I know now what this is. It is one of the desktop effects, called "Show FPS" and the description says it is to "Display KWin's performance in the corner of the screen." In order to turn this off only, 'Personal Settings' > 'Desktop' > 'Desktop Effects' > 'All Effects' and then look for "Show FPS".

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Sticky Resource Monitor in KDE?

    Quote Originally Posted by Lord_Emsworth View Post
    I know now what this is. It is one of the desktop effects, called "Show FPS" and the description says it is to "Display KWin's performance in the corner of the screen." In order to turn this off only, 'Personal Settings' > 'Desktop' > 'Desktop Effects' > 'All Effects' and then look for "Show FPS".
    WOW. Well spotted Lord_Emsworth
    Just shows the benefit of the forum mix.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Aug 2008
    Location
    Ames, IA
    Posts
    8

    Default Re: Sticky Resource Monitor in KDE?

    Quote Originally Posted by Lord_Emsworth View Post
    I know now what this is. It is one of the desktop effects, called "Show FPS" and the description says it is to "Display KWin's performance in the corner of the screen." In order to turn this off only, 'Personal Settings' > 'Desktop' > 'Desktop Effects' > 'All Effects' and then look for "Show FPS".
    FTW!

    Thanks! Disabling "Show FPS" fixed it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •