Results 1 to 4 of 4

Thread: Scanner won't work

  1. #1
    Join Date
    Sep 2009
    Location
    NW Kent, UK
    Posts
    196

    Default Scanner won't work

    Hi,
    I am using Suse 11.1 on a 64-bit computer. Some time ago, I was helped on these forums to get a Brother MFC-640CW printer/scanner to work by downloading the relevant drivers from the Brother website. Although the printer works fine, when I attempt to scan something into the computer nothing happens. A pop up box appears on screen when the printer is used with an XP OS. Can anybody suggest a way to get the scanner working?
    Many thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,552
    Blog Entries
    1

    Default Re: Scanner won't work

    Lets start from the top. Assuming you have the correct scanner drivers installed, Open a terminal and try these commands (with scanner on):

    Code:
    sane-find-scanner
    Code:
    scanimage -L
    If nothing reported, try as root (with 'su -' command). Any difference? It may just be a permissions issue (ie adding the user to the relevant group via yast > security and users).

    If scanner is detected, then try kooka,xsane, or whatever scanning package you have installed.

  3. #3
    Join Date
    Sep 2009
    Location
    NW Kent, UK
    Posts
    196

    Default Re: Scanner won't work

    I get this:

    # No SCSI scanners found. If you expected something different, make sure that
    # you have loaded a kernel SCSI driver for your SCSI adapter.

    found USB scanner (vendor=0x04f9, product=0x0197) at libusb:002:002
    # Your USB scanner was (probably) detected. It may or may not be supported by
    # SANE. Try scanimage -L and read the backend's manpage.

    # Not checking for parallel port scanners.

    # Most Scanners connected to the parallel port or other proprietary ports
    # can't be detected by this program.

    What should I do now?

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,552
    Blog Entries
    1

    Default Re: Scanner won't work

    Code:
    found USB scanner (vendor=0x04f9, product=0x0197) at libusb:002:002
    This is a good sign. Was this output as regular user (or root)? Please answer this question in your next post. Sometimes, (as mentioned before), a user must add themselves to a particular group, to get access to the scanner. We'll worry about that when you report back here. Some useful info concering Brother FAQ:

    http://solutions.brother.com/linux/s...linux_faq.html

    You could try launching Xsane (scanning app) from a terminal with

    Code:
    xsane
    If using KDE4, there is also Skanlite (in the Graphics Apps menu), or from terminal

    Code:
    skanlite

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •