Results 1 to 4 of 4

Thread: Oracle Database 10g Express Edition problem

  1. #1

    Default Oracle Database 10g Express Edition problem

    I installed "oracle-xe-univ-10.2.0.1-1.0.i386.rpm" on openSuse 11.3, by following Installation Guide instructions from </title> <script language="JavaScript" type="text/javascript" src="/ocom/groups/systemobject/@mktg_admin/documents/webcontent/oraclelib.js"> </script> <style type="text/css"> HTML,BODY,TD,H1,H2,H3,H4,OL,UL,DL,LI,DT,DD {font-family:arial,helvetica,san.
    After installation and configuration, when I try to "Go To Database Home Page", the server don't answer.
    Also, when I try to stop and start the oracle service, oracle send "1" ("unknown error").
    I try the procedure twice, with the same result.

    Do you have any idea?
    Thanks, a lot.
    [Adrián E. Córdoba]

  2. #2

    Default Re: Oracle Database 10g Express Edition problem

    I haven't tried in 11.3, but under 11.2 I found that these instructions I saved from another forum post worked well for me:

    Install rpm using rpm -ivh oracle...rpm

    Before doing oracle-xe configure look at below:

    Finally i figured it out.
    Thank you rvanderhoorn but the problem is not with my config.
    The problem is the rpm script installer not the configurer it self.
    the evel message is "warning: script 'oracle-xe' missing LSB tags and overrides"
    Indeed as of this new opensuse release, LSB implementation is stricter and thus does not run oracle's post install script.
    Particularly, the problem is with oracle password.
    The simplest work around i found is
    0- su % to login as root
    1- install the RPM
    2- su
    3- passwd oracle % to change oracle password, choose any pwd you'd like
    4- exit % return as root
    5- /etc/init.d/oracle-xe configure % to configure xe db

  3. #3

    Default Re: Oracle Database 10g Express Edition problem

    Quote Originally Posted by gnunn2 View Post
    I haven't tried in 11.3, but under 11.2 I found that these instructions I saved from another forum post worked well for me:

    Install rpm using rpm -ivh oracle...rpm

    Before doing oracle-xe configure look at below:

    Finally i figured it out.
    Thank you rvanderhoorn but the problem is not with my config.
    The problem is the rpm script installer not the configurer it self.
    the evel message is "warning: script 'oracle-xe' missing LSB tags and overrides"
    Indeed as of this new opensuse release, LSB implementation is stricter and thus does not run oracle's post install script.
    Particularly, the problem is with oracle password.
    The simplest work around i found is
    0- su % to login as root
    1- install the RPM
    2- su
    3- passwd oracle % to change oracle password, choose any pwd you'd like
    4- exit % return as root
    5- /etc/init.d/oracle-xe configure % to configure xe db
    I'll try it.
    Thanks!
    [Adrián E. Córdoba]

  4. #4

    Default Re: Oracle Database 10g Express Edition problem

    I could finally make Oracle 10g XE works properly.
    By using "How to install OrqacleXE on openSUSE 11.1", I followed these instructions:
    1- Installation of orarun.rpm (http://ftp.novell.com/partners/oracl...-10/orarun.rpm).
    2- Installation of oracle-xe-univ-10.2.0.1-1.0.i386.rpm and reboot the system.
    3- Copy oracle-xe.sh as oracle.sh
    cp /etc/profile.d/oracle.sh /etc/profile.d/oracle-xe.sh
    4- Edit Profile file /etc/profile.d/oracle-xe.sh
    (a) Change ORACLE_BASE from /opt/oracle to /usr/lib/oracle/xe/app/oracle
    (b) Change ORACLE_HOME from $ORACLE_BASE/product/10.2/db_1 to $ORACLE_BASE/product/10.2.0/server
    (c) Change ORACLE_SID from orcl to XE
    (d) Comment out For RAC exports
    # For RAC
    #export ORA_CRS_HOME=$ORACLE_BASE/product/10gR2/crs
    #export ORA_ASM_HOME=$ORACLE_BASE/product/10gR2/asm
    (e) Comment out AGENT_HOME
    # Grid Control Agent Home
    #AGENT_HOME=$ORACLE_BASE/product/10.2/agent
    5- Configured the oracle DB server:
    /etc/init.d/oracle-xe configure (I followed the instructions.)
    6- Add the following line to /etc/bash.bashrc.local file:
    . /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/oracle_env.sh

    That's all.
    Thank you, very much.
    [Adrián E. Córdoba]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •